Jump to content

Crashdamage

OTW
  • Content Count

    474
  • Joined

  • Last visited

Community Reputation

0 Neutral

About Crashdamage

  • Rank
    Awesome

Profile Information

  • Location
    Kansas City, Missouri
  1. I've been running CentOS for while now too, started with 5.1 now upgraded to 5.2. Really like it, and I'll run it for years without needing to reinstall. Nice article you wrote, but you don't make this clear... I haven't tried yet to tackle setting up true XEN para-visualization as it looks to be some work, but from what I know about it it should really be good. I'll get around to it sometime. Anyway, maybe I'm wrong but far as I can tell, if you use 'full visualization' (i.e. QMEU + image file) you're not really using XEN as such, just QMEU. XEN only kicks in using 'para-visualization' (XEN kernel + LVM or a physical partition). I tried full visualization, but went back to running Win4LInPro 5.0 (basically a customized QMEU) as it's much simpler to configure and use than 'plain' QMEU and just as fast or faster. Regarding allocating memory under QMEU, rather than allocating more memory, best performance is usually achieved by using less. So allocate as little as you can get away with. Running Win2kPro I only use 128-256MB. Setting 1G really slows things down noticably. XP is a hog compared to Win2k and will need at least 256MB, maybe 512 depending on what apps you use, 1G rarely. Use Win2kPro if at all possible with minimal memory and QMEU will run it near-native speed, except, as you mentioned, disk I/O isn't real good. Also, I see your laptop has 4G of memory. Don't you need to run a PAE kernel for all the RAM to be recognized?
  2. I'll never use it. There are serious problems with Chrome concerning privacy and the EULA terms. Here's just a taste, there's more but I can't find the links right now: http://coderrr.wordpress.com/2008/09/03/go...than-you-think/ http://www.theregister.co.uk/2008/09/03/go...ome_eula_sucks/
  3. mandusr200071 said: It's not really that they don't support it, it's that Mutt is a MUA (Mail User Agent) and does not include a MTA (Mail Transfer agent). Sendmail is an example of a MTA. It's the job of the MTA, not the MUA to send mail to a mail server be it POP, IMAP or SMTP. So, it's the MTA, not Mutt, that is configured to use SMTP. The Mutt philosophy is much like the UNIX/Linux general philosophy: a tool for every job and only that job so everything is fixed just right, not one monkey wrench for fixing everything half-assed. Now somewhat surprisingly, Mutt does have some built-in MRA (Mail Retrieval Agent) capability, but it's POP-only. For IMAP, etc retrieval you'll need a stand-alone MRA like fetchmail. A MDA (Mail Delivery Agent) such as procmail can be added for more functionality, such as sorting incoming mail into several mailboxes or for several users. "They" don't want you to use sendmail, Mutt programmers don't care what MTA you use. You can use whatever MTA you want. I'd never heard of "msmtp" but a quick Google showed it's a simple MTA for replacing sendmail. You didn't say what other "additional programs" you've been messin' around with or just what you mean by "flaky". If you can't make msmtp go I suggest you try configuring qmail to use SMTP for you. qmail, postfix - those and several other MTAs will work fine and very commonly used so plenty of trouble-shooting advice should be a Google away. No doubt, sendmail is utterly configurable but horrendously complicated to learn. Fortunately, much simpler MTAs like qmail are drop-in replacements for sendmail in almost any ordinary circumstance. Well, it might be better to say they assume a working MTA installation. Sendmail is just the original UNIX standard MTA and is still the standard and so just sorta referred to by default. Substitute "qmail" or whatever when you see "sendmail" and very likely you'll be OK.
  4. Another vote for Mutt. I've used it for years and it's got me spoiled. Abook is a nice companion to Mutt. Mutt setup is kind of a bear, but once you get it worked out there's nothing else like it. Haven't been able to get my wife off Thunderbird yet though. BTW, it happens I use Mutt with sendmail, procmail and fetchmail to take advantage of more of what Mutt can do, which is a LOT. But you can use any of the other, simpler replacements for sendmail such as postfix, qmail, etc. And use of procmail and fetchmail is optional if you want to keep setup reasonably simple. If you want to give Mutt a try Google a bit for some sample muttrc (config) files or I can send you mine. It's pretty well notated and so fairly easy to work through.
  5. 10.1 LIVES!!! Yeah, ya jus' can't keep the ol' dog down - 10.1 times too tough! Anyone curious for a little more info, check my last post in the thread about this on Mandriva Club: http://forum.mandriva.com/viewtopic.php?t=...7f45f6a476fd3d0 or ask me some questions I probably can't answer.
  6. iphitus, Actually, you're partially right. While I hadn't changed openssl in a long time, a better look showed that in Feb 2005 I had upgraded to a 10.2 versions for both libopenssl and openssl (and libopenssl-devel). I didn't change them when I did the attempt at Firefox3 so I didn't think that was it, but you were right they'd been updated. So what the heck, I figured worth a try since those packages and libcrypto seem to be somehow involved in this. I --force installed 10.1 versions for all those packages and made sure none of the newer package files got left behind. No help. In a fit of ugly Win-ape behavior I even did another reboot to make sure all stars were properly aligned, I guess. No good, same symbol error. Earlier I'd tried manually replacing all the files from those packages from backups. No good. At least nothing else seems to have broken fooling around. Something else is causing this illness and apparently a none of the doctors have a correct diagnosis. I've got hints from people that have steered me in a general area but no cure. A good thought. But no prize. Thanks anyway.
  7. Scarecrow: I've got stuff installed from who-knows-where. I never had any problems this serious before because I was just careful with rpm and urpmi. Always did --test, etc. Didn't get stupid with updating glibc or other core system files. Never ran auto updates. A dirty little Linux secret is like Windoze, updates are not always a Good Thing. Messages boards are always full of borked installations from updates. Worked great too keep the latest versions of stuff like OpenOffice, Firefox, etc installed for years. I'm borked now, but I may still find a way out. I can't believe it's a big deal to fix if I can just figure out the exact problem. In the meantime, I can still do 90% of what I need and I've got my laptop for the rest. Most stuff works as good as ever and I'm not worried about losing anything. So I'll let this ride for a while and see if I can come up with a save. Greg2: Most times I'd agree with you and hang my head in shame. But read the post I just added in the Club forum. The problem seems somehow connected to the openssl package, but I've never changed it. Besides, everything should be back as it was, but obviously *something* isn't. Question is what...
  8. I haven't been able to Google my way out of this one. Instead of duplicating it here, please read my post on Mandriva Club forum: http://forum.mandriva.com/viewtopic.php?t=78012 Let me know if you have any ideas or need more info. Anything might help. Many thanks! Update: Did some more research and posted a little more diagnostic info. To anyone reading this, thanks for checking this out.
  9. RadioEar wrote: I'm not quite sure if you meant this seriously or not. It's perfectly consistent with M$, who never actually innovate much of anything. If fact, I should've stated the M$ motto as: "If we can't do it, license it, buy it or steal it from those who can." I've said this before and I'll say it again: IE is the #1 thing, not software, keeping users tied to M$ and Windows. Crushing Netscape was the most important business move M$ has ever made, though I'm certain M$ had no idea just how important it was at the time. Keeping browser competition squashed will be even more important to M$ in the future as computing activity becomes more and more Net-based in the coming years. M$ will try to keep IE the defacto standard (particularly for businesses) with non-standard plugins, DirectX and other crap generally bad for the future of other browsers, other OS, the 'Net in general and all users by extension. M$ still is clinging to their highly successful business model of desktop computers with Windows, Office, Outlook and IE. Vista is proof positive of that and of how clueless they really are. When they finally grasp that that is not the future, the battle for the 'Net itself will intensify. Eventually Netscape will maybe be best remembered not as a browser per se, but as the place the 'Net war all began. In American terms, the Boston Tea Party of the battle for the 'Net so to speak. At any rate, browser wars are not over, M$ is just asleep at the wheel again. When they get near the edge of the road and the rumble strip wakes them up we can expect more trouble. Originally it was Netscape/freeware/shareware, and now Mozilla/Firefox/Thunderbird/Opera, etc., all OSS - and of course OSX/Linux - these are not just alternatives to M$, they are truly weapons for for freedom, and will be more important technology than the printing press.
  10. In respect for Netscape's place in history I've re-installed the Netscape theme in Firefox and it will stay permanently. I've used it before and don't know why I changed it anyway, I still like it. Netscape wasn't first, but it set the standard for quite a while. MS couldn't write a browser so they licensed Spyglass Mosaic. The old MS motto: "If we can't do it, license it or buy it from those who can."
  11. Hmmm...I'm kinda outta ideas on installing the rpms. Not surprised that they're just still skipped without giving more info though. All I can suggest from here is a Google search for "package file .rpm was skipped" or similar and see if someone else has gotten around this. As for running the command line version of Sopcast, what happens when you try to start it in a terminal? No error messages, etc? From your original post I thought it installed successfully.
  12. It's a little strange you got no error messages during the rpm install giving some hints as to why the rpm packages were skipped. But there are some things you can try to install the GUI version from the rpms. First, try installing both rpms at once. I don't really expect this to do the trick but it's worth a try and the best way to install anyway. I'd do it in the order they are listed in on the Sopcast website. And do it using the '--test' switch to be safe, as so: # rpm -ivh --test qsopcast-0.3.5-2mgc.i686.rpm sp-sc-1.0.2-1mgc.i686.rpm Post any errors back here. If as I expect it just skips the package again, try again but this time using the '--conflicts' switch instead of '--test'. Again, post any errors. You might also try '--requires' and '--obsoletes' or 'rpm -Uvh' instead of 'rpm -ivh'. Whatever you do, don't try '--force' unless you are willing to face the possible consequences. The whole idea is to make rpm give some info about exactly what the problem is so a strategy to fix it can be figured. As for installing the command line version, it failed with mplayer simply because it dind't find it: mplayer: could not connect to socket mplayer: No such file or directory On the other hand, I'm not sure what you mean by "Simply nothing happens in both cases." At a glance, it seems to have succeeded with kaffeine/xine.
  13. Clearly, you just need to install whatever package contains libstdc++5. But I believe Greg2's suggestion of: $ urpmi libstdc++5 ...while handy, will only look for an installed package named 'libstdc++5', and not find a package containing a file with the name 'libstdc++5' particularly if the package containing it is named differently. And since it's not installed you get "No package named libstdc++5" which is not a lot of help. Now, daniewicz was kind enough to give you the package name for libstdc++5 for his machine, but not how to find the correct package for yours. You can do a search for 'libstdc++5' in MCC>Software Management, but this is one of those times when some of the old 'rpm' commands can come in handy... To find a package for your installation named 'libstdc++5' *or* one that contains libstdc++5, in a console type (you do not need to be root): $ rpm -q --whatprovides libstdc++5 For example, on my 10.1 machine I get: $ rpm -q --whatprovides libstdc++5 libstdc++5-3.3.4-2mdk This query will not work on *any* file in a package but IIRC the package or file doesn't have to be installed, if it's in the rpm database you should get a result. Then just install that package. To find what what apps require libstdc++5: $ rpm -q --whatrequires libstdc++5 ...and you'll get a list of dependencies. There are many other possible queries, see: man rpm. I hope I got this stuff right. If not feel free to pile on.
  14. null wrote: Win2k doesn't recognize the SATA drive 'cause you got no SATA controller drivers installed. You just need to load the SATA controller drivers from the CD that came with the motherboard - which you do still have, right? You already have Win2k running so no need to do the F6 thing, etc - just use the CD to install drivers. Then it should recognize the SATA drive like any other. For Linux do as AussieJohn suggested and make sure everything is set properly. If still no go well, scarecrow is right about not all SATA controllers being supported yet. Try a Google search about Linux compatibility for your controller chipset and see what that turns up. No doubt SATA is the future standard. Next home workstation I build for myself in a year or two I'll definitely take the SATA path. Seems most SATA controllers are already supported and Linux support for SATA should be a moot point by then, plug 'n go about every time.
  15. null said: I'm certainly no expert on such stuff with Linux, but it all sounds very possible. On this box I'm still using the by now very old version of Xine that came with Mandrake 10.1. Even an old Xine plays (almost) everything pretty well. I don't know what the problem you have is but something doesn't sound right. Maybe you don't have Flash installed and working and it's the Flash stuff on websites that's causing trouble? Can you play downloaded videos or DVDs? As far as your problems with SATA drives I just can't help. I've avoided using them so far and still will for a while. Things just don't seem totally sorted out yet. I tell you what - I'm about to build a new combo server/workstation for my office to (partially) replace a very trusty but outdated Novell 5.1 server. I'll load Win2k Pro SP4 and use special heavy-duty 250G IDE drives. I know SATA drives are bit quicker than IDE and I could put SATA drivers on a floppy and F6 'em in or slipstream the drivers onto a Win2k disc for installation, but the speed advantage over IDE drives just ain't that much. So screw it, I'm gonna run something Win2k Pro natively understands better. I'll go for Tried and True. But you may ask, for a server why not use SCSI? No doubt, SCSI drives (which the old server uses) are fast and dependable but big ones are expensive (jeez, small ones still are) and quality IDE drives are about as reliable. In this case speed isn't critical but cost, as always, is a big factor and I'll need plenty of storage space. So all things considered SCSI isn't really the best choice. AussieJohn said: Well, like I said, one doesn't really NEED several partitions, for many a separate /home is enough I suppose. I still say it's just a good idea, certainly at least for more experienced users. Multiple partitions does make multiple OS, experimenting and reinstalling easier but that's usually not why I've done it all these years. I mean, for example this box still has (now much modified) 10.1 on it, never reinstalled since it came out so obviously it's not a toy I play with. I installed 10.1 on several partitions for reliability and other reasons because, like you, I use this box to do stuff, real work everyday. Having everything (except /home, I'd guess) under / may not have "inconvenienced" you (yet), since Linux IS very reliable. But I don't feel lucky and it has saved my ass more than once, particularly a separate /var. I'm not going to go into all the reasons or different schemes for partitioning here 'cause this post is already too long and anyway Google will give plenty of info. Read up some and then decide for yourself. Last, clearly I never should've said anything about installing Windoze after LInux. I was thinking back to the only time I've tried it, which was a long time ago on my son's box which had no NTFS partition created during the original Linux install, trying to add it first on the drive 'cause that's where Win2k insisted on it being etc....it was so long ago I'd forgotten how I got it worked out, but I sure remembered being pissed at the time. And obviously if there's an existing Win partition things are easier. One of these days I'll shut up....sorry.
×
×
  • Create New...