Jump to content

Localhost problem

Guest cebo

Recommended Posts


newbie in need of help here. For some reason, even though I can ping localhost and from a terminal and receive a response, neither firefox, konqueror or yahoopops can connect to it. I get an error box stating that "the connection was refused when attempting to contact" I'm using mandrake 10.1 official and have searched the internet in vain for an answer.


Any help much appreciated thanks.

Link to comment
Share on other sites

welcome aboard and a good laughter :lol:

i am getting the same result on every box ;). why do you want to connect to which is your computers very own loopback connection? you won't get access to any website there. :cheesy:


just for amusement and further information: is a loopback network connection.


If you telnet, ftp, etc... to, you are immediately connected to your own machine.


For example, if your system was named "joker", and you attempted to telnet to, you would see:


# telnet


Connected to joker

Escape character is '^]'.


Convincing newbies to connect to is a frequent joke on the Internet.


localhost is another name for


Link to comment
Share on other sites

It's not that I want to connect to localhost myself. I've been trying to use 2 programs, yahoopops, and webhttrack, both of them use localhost, and yet both give an error saying they can't connect to it. webhttrack in konqueror says

An error occurred while loading http://drew.comp:8080/server/step2.html:

Could not connect to host drew.comp (port 8080)

while using yahoopops with thunderbird I get

Could not connect to server localhost; the connection was refused.

I just don't understand... :help:

Link to comment
Share on other sites serves its purpose. I use it to test / view websites I am working on my local server.


Any chance you have some proxy configured with your internet connection or browser ? That would produce that "connection was refused" error your getting.

Link to comment
Share on other sites

Thanks for the responses. First of all, I've done a check and I have no proxies configured anywhere in either Firefox, Konqueror or anywhere else.

The program I most want to use is yahoopops, which lets you download from yahoo mail with a mail client. I've installed it with no problems that I can tell, and have followed the steps in setting up the mail client, using thunderbird, as listed at http://yahoopops.sourceforge.net/modules.p...&artid=3&page=1

I've put 'localhost' in the various fields, and then get the error message 'can't connect blah blah blah' when I try and use it. It may be just coincedence that webhttrack gives virtually the same error, but I think it does want to use an internal server.

When I ping localhost in a terminal I get this response

[drew@10 drew]$ ping localhost

PING drew.comp ( 56(84) bytes of data.

64 bytes from drew.comp ( icmp_seq=1 ttl=64 time=0.035 ms

64 bytes from drew.comp ( icmp_seq=2 ttl=64 time=0.038 ms

64 bytes from drew.comp ( icmp_seq=3 ttl=64 time=0.038 ms

64 bytes from drew.comp ( icmp_seq=4 ttl=64 time=0.038 ms

64 bytes from drew.comp ( icmp_seq=5 ttl=64 time=0.042 ms

64 bytes from drew.comp ( icmp_seq=6 ttl=64 time=0.036 ms

and on and on... does this not mean theres a server running there.

Sorry if this is a bit vague or stoopid - it does strike me as odd that no-one else has ever had this problem (from what I've googled) so I'm assuming it's something extremely obvious that I've overlooked - but I just don't know what.



Link to comment
Share on other sites

cebo: It's normal that you can ping your localhost - this has nothing to do with whether theres a webserver running. It simply means that your loopback network works - doesn't really tell you a lot.


Do you have a firewall running? It may be blocking access to the necessary ports on your machine.

Link to comment
Share on other sites

This sounds a bit like problems I was having with NFS which I think was something with the msec levels. I actually set it to off but it still didn't help and I kept getting refusals ...


Unfortunately it was a 'production' server so i couldn;t wait around (home ents and file server for music/divx) so I installed something else but Im sure it was fixable, just I wasn't sure where to look!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...