Jump to content

cant' eject cdrom (scd1)

chris z

Recommended Posts

hi folks.......


(brace yerselves. this is gonna be long, but thorough.)


i asked around on musb about this & recieved several suggestions, but none have worked, so i'm gonna throw it out here & see if anybody has an answer.


the problem:

when i mount my cdrom with a data cd, after unmounting it i can't eject the cd via the physical eject button on the cdrom nor will it eject by right clicking my cdrom desktop icon & selecting eject. nor will it eject from terminal as user. the only way i can eject it is using the eject command as root from terminal. when i try right clicking the icon to eject, i get this message in a pop up box....... "eject /dev/scd1 failed!" here's what i get when i eject it from terminal as root in verbose mode. (which does eject the cd after this message scrolls)

[root@default chris]# eject -v /dev/scd1
eject: device name is `/dev/scd1'
eject: expanded name is `/dev/scd1'
eject: `/dev/scd1' is a link to `/dev/scsi/host0/bus0/target1/lun0/cd'
eject: `/dev/scsi/host0/bus0/target1/lun0/cd' is not mounted
eject: `/dev/scsi/host0/bus0/target1/lun0/cd' is not a mount point
eject: `/dev/scsi/host0/bus0/target1/lun0/cd' is not a multipartition device
eject: trying to eject `/dev/scsi/host0/bus0/target1/lun0/cd' using CD-ROM eject command
eject: CD-ROM eject command failed
eject: trying to eject `/dev/scsi/host0/bus0/target1/lun0/cd' using SCSI commands
eject: SCSI eject failed
eject: trying to eject `/dev/scsi/host0/bus0/target1/lun0/cd' using floppy eject command
eject: floppy eject command failed
eject: trying to eject `/dev/scsi/host0/bus0/target1/lun0/cd' using tape offline command
eject: tape offline command failed
eject: unable to eject, last error: Invalid argument

i get the same results if try ejecting using eject -v /mnt/cdrom2 which is the mount point for that device.


some info:

i'm trying to do this using Texstar's KDE3.1.4. this problem only started sometime in the past 2 weeks, or so, though i'm not sure of the exact date that this started. i know the eject functions (right click & push button) did work at one time in this version of KDE (i've had it since September), so i don't think it's a Texstar issue. i haven't done anything (that i can think of) that should/would affect the cdrom or the eject function. (IE: screwing around with device settings, installing any cd related apps, screwing around with mount points, etc...) the cdrom works fine, otherwise. i can mount it, read data from it, unmount it, all as user or via right click icon for mount/unmount or from terminal. my cd burner is not affected by this. i can mount/unmount the burner via both methods & i can eject from the burner via all mehtods described.


technical stuff:


generic atapi that came with the pc. never had a problem with it & still don't as far as reading data cd's & playing music cd's go. mount points are /mnt/cdrom2 & /dev/scd1. the cdrom is slave. (hdb)


tdk cdrw 48x16x48. no problems with that performing nor ejecting. mount points are /mnt/cdrom0 & /dev/scd0. the cd burner is master. (hda)

i DO have scsi emulation enabled for both drives (i need this due to k3b issues). i DO NOT have supermount or automount enabled for either drive. here's my fstab entries:

[root@default chris]# cat /etc/fstab
/dev/hdc7 / ext2 defaults 1 1
none /dev/pts devpts mode=0620 0 0
/dev/hdc10 /home ext2 defaults 1 2
/dev/scd0 /mnt/cdrom auto user,noauto,ro,exec 0 0
/dev/scd1 /mnt/cdrom2 auto user,noauto,ro,exec 0 0
none /mnt/floppy supermount dev=/dev/fd0,fs=auto,--,iocharset=iso8859-1,sync,codepage=850,umask=0 0 0
/dev/hdc1 /mnt/win_c vfat iocharset=iso8859-1,codepage=850,umask=0 0 0
/dev/hdc5 /mnt/win_d vfat iocharset=iso8859-1,codepage=850,umask=0 0 0
/dev/hdc6 /mnt/win_e vfat iocharset=iso8859-1,codepage=850,umask=0 0 0
none /proc proc defaults 0 0
/dev/hdc9 /usr ext3 defaults 1 2
/dev/hdc8 swap swap defaults 0 0


here's my mtab entries:

[root@default chris]# cat /etc/mtab
/dev/hdc7 / ext2 rw 0 0
none /proc proc rw 0 0
none /proc/bus/usb usbdevfs rw 0 0
none /dev devfs rw 0 0
none /dev/pts devpts rw,mode=0620 0 0
/dev/hdc10 /home ext2 rw 0 0
none /mnt/floppy supermount rw,sync,dev=/dev/fd0,fs=auto,--,iocharset=iso8859-1,codepage=850,umask=0 0 0
/dev/hdc1 /mnt/win_c vfat rw,iocharset=iso8859-1,codepage=850,umask=0 0 0
/dev/hdc5 /mnt/win_d vfat rw,iocharset=iso8859-1,codepage=850,umask=0 0 0
/dev/hdc6 /mnt/win_e vfat rw,iocharset=iso8859-1,codepage=850,umask=0 0 0
/dev/hdc9 /usr ext3 rw 0 0


here's my lilo.conf entries:

[root@default chris]# cat /etc/lilo.conf
       append="quiet devfs=mount hda=ide-scsi hdb=ide-scsi acpi=off"
       append="devfs=mount hda=ide-scsi acpi=off"
       append="failsafe devfs=nomount hda=ide-scsi acpi=off"
       append="quiet devfs=mount hda=ide-scsi acpi=off"

       append="quiet devfs=mount hda=ide-scsi hdb=ide-scsi acpi=off"

       append=" quiet devfs=mount hda=ide-scsi hdb=ide-scsi acpi=off"


and, yes, i do realize that my hard drive is secondary master, but that doesn't matter concerning the eject problem. that's how it's been set up for years.


what i've tried so far:

per some suggestions in musb, i've tried disabling scsi emulation. i've tried commenting out the line in fstab for both the cdrom & burner, one at a a time, rebooting & letting the new hardware be detected. i've tried enabling supermount/automount. i've tried changing permissions to user for eject, scd1, scd0, cdrom2, & cdrom0. none of those methods solved the problem.


assorted weirdness:

i have noticed that the eject command is some how defaulting to the cd burner. IE:, if i just type eject in terminal without a path to either device, it opens my cdburner by default. same goes for the KDE eject function (kdeeject). also, i can't even eject the cdrom by using the paper clip in the hole trick.


ok, that's all the pertinent info i can think of that would be useful. so, if anybody has a suggestion or solution, i'm all ears. :P



Edited by chris z
Link to comment
Share on other sites


I have the same problem... posted many months ago. My CD-ROM is an Asus 52x and it is super nice, but will not eject except as root. I get the same error and everything checks out fine otherwise. I have tried to get answers from Asus and Mdk but no luck... so I live with it. Wish I had an answer, but I finally accepted it as a firmware/hardware thing as the previous drive (AOpen) worked fine until it wore out.


It works fine under Win 98SE which makes me mad... :wall:

Link to comment
Share on other sites



what, change permissions for cdroms & scd1&0?


currently here's what i have:


/mnt/cdrom permissions:rwxr-xr-x owner:root group:root (this is my burner)

/mnt/cdrom2 same as above (this is my cdrom)


/dev/cdrom0 permissions:rw-rw---- owner:chris group:cdwriter (????) (this is my burner)

/dev/cdrom2 same as above (this is my cdrom)


/dev/scd0 (burner) same as above

/dev/scd1 (cdrom) same as above


why would they permissions/owners/groups be different in /dev from /mnt? also, why are the /dev groups cdwriter? maybe something to do with k3b/xcdroast settings?





Link to comment
Share on other sites

I checked my permissions and my burner and cdrom are both root:root in /mnt, but slightly different than yours in /dev:


my burner is user:cdwriter

my cdrom is user:cdrom


I can't do much now, but can check more (if you point me to what you may be looking at) after work (around midnight our time) I may be able to help more.


My setup seems to get the job done. I am running 9.2, k3b, and have supermount enabled. I get the "scsi" error from k3b, but never enabled that, but have been burning quite a few cds successfully.

Link to comment
Share on other sites



the problem isn't ejecting the drive from cli. i can do that. in fact, that's the only way i can do it, even when the drive is not mounted. you can't eject it via the eject button on the drive itself, nor with the right click eject option from the desktop shortcut. the burner works fine with all methods, so i wanted to figure out why the burner ejects via all methods, but why i need to cli eject as root for the cdrom. and, yes, i can eject with either eject /mnt/cdrom(2) or via eject /dev/scd0(1).




i don't know what else to point you to. (sorry) i mean, that's what i was sorta hoping for........for somebody to point me to the solution, based on the info i provided. if you need some more info, please let me know what & i'll post it. i doubt if i'll be awake, or at least sober enough :o to discuss this with you at midnight, but thanks for the offer. just post on here with anything you can tell me or need for me to tell you & i'll check back periodically. i really don't want to re-enable supermount as i like it disabled. it gave me lots of headaches concerning k3b a while back.



Link to comment
Share on other sites

hmmm....well have you tried uninstalling eject (mdk may be using the independent eject app out there)? it sounds like something you installed or did ahs meesup the configuration of your desktop icon and messed with your actual device's function because the only time you may not be able to manually eject the cd trya is if you have a disc mounted and even then you can sometime s get away with it ( i know i have manually ejected the cd tray with the device button many many times while having a disc mounted).


so my guess is that some app you recently installed or tweaked has buggered things up.

Link to comment
Share on other sites

well, i haven't done anything to or with k3b as far as changes, upgrades, or tweaking goes, for months now. and, xcdroast is the version that came with the mdk installation. that's what i thought at first too, but i honestly can't think of anything i installed, uninstalled, or upgraded that would screw with cdroms or the eject function. also, sarah31, i did think of uninstalling eject, but when i tried it wanted to take half of MDK with it! (drakconfig, draktools, any several other necessary apps........depends hell in reverse!) i may try playing with changing permissions later. or, tomorrow morn. time to take a break from geeking for the day & start drinking. Friday night, ya know. if you have any other ideas or thoughts, put 'em here.



Link to comment
Share on other sites



ya know, as they say, some times it's the little things........


so, after having tried evrything under the sun to make my cdrom eject normally, i gave this nifty little command a try......


lsof -V /dev/scd1


lo & mutherfreakin' behold! here's what it told me........


[root@default chris]# lsof -V /dev/scd1


kscd    1899 chris 10r BLK 11,1      1436 /dev/scsi/host0/bus0/target1/lun0/cd


KSCD!!!!! i have KSCD set to load upon boot into KDE desktop & dock in the kicker! it (for some reason) also automagically links to cdrom2/scd1, preventing it from being ejected by any way except for CLI. since i play music cd's on the cdrom, i have KSCD set to default to that drive. all i did was quit KSCD, tried mounting, unmounting, then ejecting a data cd from CDROM2 & walla!!! it ejects, both with the eject button on the drive & by right clicking the desktop icon & choosing "eject" from the drop down menu.


after weeks of pulling my hair out over this, editing lilo & fstab, screwing with mount points, enabling & disabling supermount, screwing with permissions, posting here & asking in #musb for help, it turns out the answer was staring me in the face all along. :cheeky:


so, if anybody ever runs into a problem like this, try that bit of code above, just substituting the path to reflect your device. if you should try it & you get something like this........


lsof: command not found


then you have to install lsof. just.......


urpmi lsof


yep, Chris is a happy boy! :P :D :lol: :thumbs:



Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...