Jump to content
  • Announcements

    • spinynorman

      Mandriva Official Documentation

      Official documentation for extant versions of Mandriva can be found at doc.mandriva.com.   Documentation for the latest release may take some time to appear there. You can install all the manuals from the main repository if you have Mandriva installed - files are prefixed mandriva-doc.
    • paul

      Forum software upgrade   10/29/17

      So you may have noticed the forum software has upgraded !!!
      A few things that have changed. We no longer have community blogs (was never really used) We no longer have a portal page.
      We can discuss this, and decide whether it is needed (It costs money) See this thread: Here
newbie4ever

no dev/dsp NO SOUND AT ALL

Recommended Posts

I have the aRts mixxer thing, and everytime I log in, I get the no dev/dsp found. I looked at my old mandrake 8.2 system, and I have it there, but when I tried to copy it to a floppy, it wouldn't let me. I look at my directory dev and sure enough no dsp. I tried installing more rpms with the file name dsp, but that doesn't do it either, I installed all the ones that mention something about sound. Is there a place I can download this file so it just works?

Share this post


Link to post
Share on other sites

What happens when you go into MCC>Hardware>and try to setup the sound card?

 

I believe the file refered to is automatically made with the sound config/setup. I am guessing setup needs to be ran again. Of course, that does not answer why it failed!

Share this post


Link to post
Share on other sites

This may not help solve your problem, but achieve a better understanding overall perhaps. Files such as dsp and hda are not actually files as we think of them. They are dynamically created when the system boots and runs it's check for "new hardware." Actually /dev/dsp is a symlink to /dev/sound/dsp or whatever and if you do a ls -l /dev/sound/dsp (or whatever your /dev/dsp links to) you will see by the first character that this is not just a file. I don't even know what "c" stands for actually, but...

Share this post


Link to post
Share on other sites

c is for character device. Contrary to b which are block devices, character devices cannot be approached with addresses of data to read.

 

As you may guess, drives are block devices.

 

/dev only holds links and devices.

 

This is because linux (and brethren) is file oriented, not device oriented like windows, and technically (imho) this is one of the things that makes it truely better than windows. Device oriented systems can get locked if the device doesn't respond, and need loads of patches to work around such problems.

 

I have a little experience with creating devices, instead of mkdir you use

mknod (maj) (min) [path]

which means you make a node with a major and minor number, that the system can subsequently use.

 

Normally this is done by the system (and the user should never have to do this; I was trying to get something to work, so I used it --didn't work in the end anyway), when you load the module.

If there is no mention of your sound card in /etc/modules.conf, this would explain a lot.

So please give us the output of

cat /etc/modules.conf

(should have stuff like: snd-slot-0 or so in it)

 

If you cannot fix things in MCC, you may try

sndconfig

from the command line. Be sure to know what kind of audio card you have.

You may as well tell us, what kind of audio do you have?

 

If your mdk8.2 system worked fine with the audio, what is in the /etc/modules.conf there?

That may just work on 9.1/9.2 too.

Share this post


Link to post
Share on other sites

Basically, I run the configure tool on the sound card, and it changed modules.conf with the driver I chose, but does not produce a /dev/dsp/ folder. Nor does it add an entry to /sbin/lsmod for sound.

I checked the BIOS for on-board PCI options, because this is how I fixed my ethernet adapter earlier.

Sadly, the only audio options were "auto" and "off" and it was set to auto. I checked SiS's website about their pesky 7012 on-board sound adapter, and they just recommended to use i810 drivers in linux.

That and the 3 other driver options would not work. Do you have any ideas?

Share this post


Link to post
Share on other sites

Am using on-board 7012 (below are the details, maybe it'll be useful for comparison). The module /driver is the one installed by the MDK 9.1, i didnt change the driver in MCC (initially i did as i thought it wasnt working, turns out that the volume was zero at default). anyway, can you try to use snd-intel8x0 driver in MCC?

 

 

From MCC

 

Vendor: Silicon Integrated Systems [siS]

Alternative drivers: ali5455:i810_audio:nvaudio

Bus: PCI

Bus identification: 1039:7012:1019:1808

Location on the bus: 0:2:7

Description: SiS7012 PCI Audio Accelerator

Module: snd-intel8x0

Media class: MULTIMEDIA_AUDIO

 

 

/etc/modules.conf

 

probeall scsi_hostadapter ide-scsi

probeall usb-interface usb-ohci

above snd-intel8x0 snd-pcm-oss

alias sound-slot-0 snd-intel8x0

alias /dev/nvidia* nvidia

 

 

Driver used at default

[root@localhost james]# lspcidrake -v | fgrep AUDIO

snd-intel8x0 : Silicon Integrated Systems [siS]|SiS7012 PCI Audio Accelerator [MULTIMEDIA_AUDIO] (vendor:1039 device:7012 subv:1019 subd:1808)

 

What sound driver currently used

[root@localhost james]# grep sound-slot /etc/modules.conf

alias sound-slot-0 snd-intel8x0

 

Check if driver is loaded or not

[root@localhost james]# /sbin/lsmod

Module Size Used by Tainted: P

sg 34636 0 (autoclean)

ide-floppy 15580 0 (autoclean)

sd_mod 13100 0 (autoclean) (unused)

ppp_deflate 4408 0 (autoclean)

zlib_inflate 21156 0 (autoclean) [ppp_deflate]

zlib_deflate 21144 0 (autoclean) [ppp_deflate]

bsd_comp 5336 0 (autoclean)

ip_conntrack_irc 4304 0 (unused)

ip_conntrack_ftp 5200 0 (unused)

ipt_state 1080 1

ipt_limit 1560 1

ipt_LOG 4280 1

ip_conntrack 27264 3 [ip_conntrack_irc ip_conntrack_ftp ipt_state]

iptable_filter 2348 1 (autoclean)

ip_tables 14648 4 [ipt_state ipt_limit ipt_LOG iptable_filter]

nvidia 1831136 11 (autoclean)

snd-seq-oss 31104 0 (unused)

snd-seq-midi-event 5640 0 [snd-seq-oss]

snd-seq 42608 2 [snd-seq-oss snd-seq-midi-event]

snd-pcm-oss 43556 1

snd-mixer-oss 14488 0 [snd-pcm-oss]

snd-intel8x0 21988 1

snd-ac97-codec 40160 0 [snd-intel8x0]

snd-pcm 77536 0 [snd-pcm-oss snd-intel8x0]

snd-timer 18376 0 [snd-seq snd-pcm]

snd-mpu401-uart 4396 0 [snd-intel8x0]

snd-rawmidi 17600 0 [snd-mpu401-uart]

snd-seq-device 5832 0 [snd-seq-oss snd-seq snd-rawmidi]

snd-page-alloc 7732 0 [snd-intel8x0 snd-pcm]

snd 40868 0 [snd-seq-oss snd-seq-midi-event snd-seq snd-pcm-oss snd-mixer-oss snd-intel8x0 snd-ac97-codec snd-pcm snd-timer snd-mpu401-uart snd-rawmidi snd-seq-device]

soundcore 6276 0 [snd]

ppp_async 9216 0

ppp_generic 24060 0 [ppp_deflate bsd_comp ppp_async]

slhc 6564 0 [ppp_generic]

af_packet 14952 0 (autoclean)

sr_mod 16920 0 (autoclean)

floppy 55132 0

ntfs 76812 1 (autoclean)

nls_iso8859-1 3516 4 (autoclean)

nls_cp850 4316 3 (autoclean)

vfat 11820 3 (autoclean)

fat 37944 0 (autoclean) [vfat]

supermount 15296 2 (autoclean)

ide-cd 33856 0

cdrom 31648 0 [sr_mod ide-cd]

ide-scsi 11280 0

scsi_mod 103284 4 [sg sd_mod sr_mod ide-scsi]

usb-ohci 20584 0 (unused)

usbcore 72992 1 [usb-ohci]

rtc 8060 0 (autoclean)

ext3 59916 3

jbd 38972 3 [ext3]

 

Init level that sound runs

[root@localhost james]# /sbin/chkconfig --list sound

sound 0:off 1:off 2:on 3:on 4:on 5:on 6:off

 

Init level that alsa runs

[root@localhost james]# /sbin/chkconfig --list alsa

alsa 0:off 1:off 2:on 3:on 4:on 5:on 6:off

 

If sound is muted or not

[root@localhost james]# aumix -q

vol 94, 94, P

pcm 87, 87

speaker 87, 87

line 87, 87, P

mic 0, 0, R

cd 87, 87, P

igain 87, 87

line1 87, 87, P

phin 87, 87, P

video 87, 87, P

 

Program using souncard (am playing something on zinf)

[root@localhost james]# /sbin/fuser -v /dev/dsp

 

USER PID ACCESS COMMAND

/dev/dsp james 1674 f.... artsd

Share this post


Link to post
Share on other sites

I am using the intel8x0 driver. Soundcore is in the "lsmod" list. In chkconfig switch "3" is on for ALSA. But "aumix" is not treated as a valid command.

Under system configuration, I looked at what Services were running. ALSA was listed as "stopped". I tried to start it, and the log said that it shut it down [OK] and started again [OK]. This is where it gets weird: the tag still says that it is stopped, even though the log says that it started OK. There is no log of a crash. When I click to "stop" it says that it is stopping [OK]. When I click to "start" it says it is starting [OK]. The tag still says it is stopped.

 

Is my ALSA service broken somehow?

Share this post


Link to post
Share on other sites

In MCC / Hardware / HardDrake , click on the SiS7012 PCI Audio Accelerator, then "Run config tool"

 

You should see this

Here you can select an alternative driver (either OSS or ALSA) for your sound card (Silicon Integrated Systems [siS]|SiS7012 PCI Audio Accelerator).

 

Your card currently use the ALSA "snd-intel8x0" driver (default driver for your card is "snd-intel8x0")

 

---------

there would be three selections for the driver

1. ali5455 (ALI 5455 audio support)

2. i810_audio (Intel 810 audio support)

3. nvaudio ()

 

------

Select i810_audio (Intel 810 audio support)

 

This should load the OSS driver.

 

the next time you run MCC, you'll see this:

 

Here you can select an alternative driver (either OSS or ALSA) for your sound card (Silicon Integrated Systems [siS]|SiS7012 PCI Audio Accelerator).

 

Your card currently use the OSS "i810_audio" driver (default driver for your card is "snd-intel8x0")

 

In the driver, you'll see this:

snd-intel8x0 (Intel 82801AA,82901AB,i810,i820,i830,i840,i845

 

 

I guess you were using the OSS drivers and not the ALSA drivers thats why ALSA was listed as stopped.

 

--------

 

If you want to use ALSA driver, after running "Run config tool" , click on "Let me pick any driver" and select "snd=intel8x0"

 

 

--------

 

You should also log out and log in again for the changes to take place.

 

--------

 

For Aumix, check in Kicker / Multimedia / Sound if Aumix is there. If not you can use Kmix or ALSA Mixer.

Anything you choose, make sure Master, PCM, Line, CD, Video are on and are not set to zero.

 

Hope this helps...

post-10-1071154653.jpg

Edited by james

Share this post


Link to post
Share on other sites

just a bit more info (MDK 9.1 sound progs/components in my box)...

 

aumix-2.7-13mdk

Summary: A GTK+/Ncurses audio mixer

Description: This is a program for adjusting audio mixers from the command line or scripts, or interactively at the console or a terminal with a full-screen, ncurses-based interface or a GTK-based X interface.

 

kmix is part of kdemultimedia-3.1-10mdk

Version: 3.1-10mdk

Size: 17552 KB

Summary: K Desktop Environment - Multimedia

Description: Multimedia tools for the K Desktop Environment.

- noatun: a multimedia player for sound and movies, very extensible due to it's plugin interface

- aktion: a player specialiced on movies, needs xanim

- kaudiocreator: CD ripper and audio encoder frontend.

- kaboodle: light media player

- kmid: A standalone and embeddable midi player, includes a karaoke-mode

- kmidi: midi player, can use sound patch files and create a WAV file

- kmix: the audio mixer as a standalone program and Kicker applet

- kscd: A CD player with an interface to the internet CDDB database

- krec: A recording frontend using aRts

 

the one in the screenshot was alsamixergui-0.9.0-0.6rc1_2mdk

Name: alsamixergui

Version: 0.9.0-0.6rc1_2mdk

Size: 69 KB

Summary: Advanced Linux Sound Architecture (ALSA) graphical mixer

Description: Alsamixergui is a FLTK based frontend for alsamixer. It is written directly on top of the alsamixer source, leaving the original source intact, only adding a couple of ifdefs, and some calls to the gui part, so it provides exactly the same functionality, but with a graphical userinterface.

Share this post


Link to post
Share on other sites

I had too much other work for the past few weeks, but I got back to it...

 

I am able to get HardDrake to say it's using the ALSA intel8x0 setting. (not OSS)

(by choosing "snd-intel8x0" after choosing "choose any driver").

 

It claims that it is changing modules.conf, but makes no mention of /dev/dsp/

 

When I check modules.conf, I see "alias sound-slot-0 snd-intel8x0" and

"above snd-intel8x0 snd-pcm-oss". This agrees with james' comment,

but seems contrary to the fact that I chose ALSA drivers.

 

HardDrake refuses to create a /dev/dsp folder even though you claim that it should.

What other step must I take to create a /dev/dsp folder, and can I download it?

Is there a module in Mandrake that I need to reinstall??

 

Probably because it lacks /dev/dsp, or maybe for other reasons, ALSA will refuse to run. It does produce logs saying it "started [OK]" but the flag in Services

says that it is stopped the entire time.

 

On boot, the ALSA message does indicate a failure in starting the task:

"Starting ALSA version ...."

"can't open /root/temp/asound/sound_files.tmp" (I have to check the exact wording)

"can't open /root/temp/asound/sound_files.tmp"

"Failed to find sound card, load state 1134" (wording? number is accurate).

 

I will concentrate my efforts on that bizzare message, and try to write it down properly next time.

Share this post


Link to post
Share on other sites

the boot log was:

 

Starting ALSA 0.9.6 (intel8x0)

can't open /root/tmp/asound.state_tmp

can't open /root/tmp/asound.state_tmp

starting mixer settings alsactl : load state : 1134 : no sound cards found [FAILED]

 

another time it produced

alsactl: save_state : 1061: no sound cards found

 

which probably meant that it did find the temp file, but that did not help.

 

I restarted the computer again to take a closer look at the pci traffic messages

that always zoom by too fast, and got a glimpse of

"no IRQ found for interrupt port A of device 00.09.00 please use pci=biosirq"

followed by something like "redundant entry in pci table"

 

Wondering if the sound device is having pci bus conflicts, I checked config again and verified that nothing is in the same location as the sound card (0:2:7).

Of couse, ISA is at 0:2:0 and usb is at 0:3:x and I wonder if ISA is bumping into 0:2:7.

Share this post


Link to post
Share on other sites

Sorry for the late reply, just couldnt figure out the cause of the errors.

Am grasping at straws here, did you perhaps downloaded the ALSA drivers (or are you using the one installed by Mandrake?) and performed ./snddevices after make install?

Saw this below in the HOWTO for K7S5A (its under Hardware - The Elite's K7s5a mainboard HOWTO).

-----

Install your kernel sources, in my case:

 

"rpm -ivh kernel-source-2.4.3-20mdk.i586.rpm"

 

Then decompress alsa drivers:

 

"bzip2 -d alsa-driver-0.9.0beta10.tar.bz2 && tar -xvf alsa-driver-0.9.0beta10.tar"

 

Make them and install them and create the devices files:

 

"cd alsa-driver-0.9.0beta10 && make install && ./snddevices"

-----

 

i tried to swap disk from my sons comp (the system was using crystal sound card drivers and VIA mobo), did an "upgrade" from 9.1 cd1 and the ALSA drivers ran for 7012 (well, it took several times of selecting alsa in mcc then logging in and out, even several reboots before the alsa drivers were firmly in place but it did install). i hope i could help more, but for now, am stumped. maybe someone has a better idea ...

Share this post


Link to post
Share on other sites

I decided to walk through Hard Drake's troubleshoot one more time, and at the "LSMOD" stage I decided to try something. On previous attempts, I had noticed that module "snd" had no comments, and that "soundcore" was used by "snd". But the module list has never contained mention of "alsa" or of "snd-intel8x0" (possibly because they are included in "snd"?) But I decided that I would try "insmod snd-intel8x0" in the hopes that this was the missing step that HardDrake was supposed to have done.

 

The output included a lot of "unresolved symbol snd_pcm_hw_constraint_list_Rfbf425a" type errors, and would not add snd-intel8x0 to the list.

 

Is this because when module "snd" is loaded, snd-intel8x0 is automatically there?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×