Jump to content
radioz

How to disable 'wobbly windows'? [solved]

Recommended Posts

I have compiz enabled on my fresh install of 2009.1 (with recent updates) and despite disabling the 'Wobbly Windows' setting in Desktop/System Settings, my windows still wobble when moved.

 

Is there any way to disable this short of disabling compiz? I like some of the other effects.

 

Thanks,

 

radioz

 

 

[moved from Software by spinynorman]

Edited by radioz

Share this post


Link to post
Share on other sites

The compiz configuration manager allows to enable or disable the wobbly windows. If they still wobble... are you sure you are using compiz and not metisse?

Share this post


Link to post
Share on other sites

Compiz Fusion is selected in the Control Center, and 'Wobbly Windows' is de-selected in the 'Desktop Settings/System Settings/Desktop Effects/All Effects' tab.

 

Is there some other configuration that I need to modify?

 

Thanks for the help!

 

radioz

Share this post


Link to post
Share on other sites

Hmm...disable compiz, remove the hidden file /home/username/.config/compiz and reenable compiz afterwards, then try if it fails again.

 

Basically, a simple click should disable the wobbling windows. At least it does on my machines.

Share this post


Link to post
Share on other sites

Well, I removed /home/<username>/.config/compiz/compizconfig/config (while compiz was disabled) but it had no effect after re-enabling compiz again. It still wobbles, despite being turned off.

 

The contents of the config file are:

 

[kde4_session]

backend = ini

profile =

 

and that's it. It seems pretty simplistic; it doesn't look like it provides any config info regarding wobbling. Does anyone know what other config files I should be checking?

Share this post


Link to post
Share on other sites

yep that could be it...I've always installed ccsm because it allows to manage the settings and effects easier

Share this post


Link to post
Share on other sites

Ahh...that was it!

 

Here I was expecting to be able to edit Compiz settings from within KDE, but that does not work.

 

It is slightly annoying that ccsm does not show up in the application menu. But typing ccsm in a terminal brings it up and sure enough, 'wobbly windows' was enabled in the configuration. Turning that off solved my problem.

 

Thanks guys for all your help. I'm still learning KDE4.

 

radioz

 

p.s. Is there a way to mark a topic as solved? (never mind, I figured it out)

Edited by radioz

Share this post


Link to post
Share on other sites

Oh, ccsm ain't visible in KDE4? Wow... I thought you had it all configured through ccsm. :unsure: Because, in Gnome, ccsm always shows up in the systems-menu.

 

You can make a shortcut to the application in order to make the access to it easier - or edit the menu accordingly. At least, that was possible in KDE 3.5, but I guess the option is not gone in KDE 4

Share this post


Link to post
Share on other sites
It is slightly annoying that ccsm does not show up in the application menu.
It should show up under Applications--> Tools. If not you can always install Fusion-Icon that gives you easy access via the system tray.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...