Jump to content
Sign in to follow this  
Zac Medley

Wbar in Mandriva, with summary

Recommended Posts

EDIT: The steps for installing Wbar in the Mandriva GNOME desktop are summarized here.

 

From reading the Wiki... I am trying to install from source.

 

Step 1

 

For most applications, step 1 is accomplished by running the command ./configure in the top level of the source code directory.

 

I'm running mandriva 2009.Spring but when I run the ./configure I get "bash: configure: command not found"

 

What am I doing wrong?

 

 

[moved from Software by spinynorman]

Edited by Zac Medley

Share this post


Link to post
Share on other sites

Have you downloaded a source package that you are trying to compile? If so, you would need to be sitting in that directory of the extracted tarball that you downloaded. Then, in this directory you will see the configure file which is invoked when you type:

 

./configure

 

Of course, it's dependent on you actually being in the directory where configure exists for it to run and work. If you can explain a bit more about what you're trying to do, what you're trying to compile we'll be able to help a bit better.

Share this post


Link to post
Share on other sites

I'm trying to install Wbar, and I extracted the source package wbar-1.3.3.tbz2 to create a folder /wbar-1.3.3.

 

While in the folder /wbar-1.3.3 I tried $./configure.

 

I tried this because when I run $make, I get an error (which I have googled and found has occurred for other people) so I thought that running ./configure would help me to figure out what else I needed.

 

And before anybody mentions them, I already know about Kiba-Dock and Avant Window Navigator. I still think that Wbar is better.

Edited by Zac Medley

Share this post


Link to post
Share on other sites

OK, in the extracted folder, do you see a file called configure? If so, then it should work. If you are having problems, please copy and paste the text where it fails so we can see where it's going wrong. Also do the same with the make error.

 

OK, it seems that with wbar, no configure is required. I checked the README file, and you just make and make install. So, please try this and post the results if it fails to work then we can see where it went wrong.

 

Also, install libimlib2 library because you are probably missing this.

Share this post


Link to post
Share on other sites

wbar is a C++ application, where there's no config script. Run "make" instead.

Plus- it won't compile cleanly under gcc 4.3.X or newer, but there is a patch for it.

Personally, I find wbar excessively ugly- its sole good point is that it works without compositing enabled.

Edited by scarecrow

Share this post


Link to post
Share on other sites
wbar is a C++ application, where there's no config script. Run "make" instead.

Plus- it won't compile cleanly under gcc 4.3.X or newer, but there is a patch for it.

Personally, I find wbar excessively ugly- its sole good point is that it works without compositing enabled.

 

Here is the error:

 

 

[matthew@localhost wbar-1.3.3]$ make

g++ `imlib2-config --cflags` -Wall -O2 -c -o XWin.o XWin.cc

XWin.cc: In constructor ‘XWin::XWin(int, int, int, int)’:

XWin.cc:33: warning: deprecated conversion from string constant to ‘char*’

XWin.cc:33: warning: deprecated conversion from string constant to ‘char*’

g++ `imlib2-config --cflags` -Wall -O2 -c -o Icon.o Icon.cc

g++ `imlib2-config --cflags` -Wall -O2 -c -o Bar.o Bar.cc

g++ `imlib2-config --cflags` -Wall -O2 -c -o IconLoader.o IconLoader.cc

IconLoader.cc: In constructor ‘IconLoader::IconLoader(const char*)’:

IconLoader.cc:20: error: ‘getenv’ was not declared in this scope

make: *** [iconLoader.o] Error 1

 

I Googled the error and I found a patch, but what do I do with the patch?

 

And thanks.

 

EDIT:

 

OK, this is interesting, I put the patch file into the /wbar-1.3.3 directory and ran $make. Now I get this:

 

[matthew@localhost wbar-1.3.3]$ make

g++ `imlib2-config --cflags` -Wall -O2 -c -o IconLoader.o IconLoader.cc

IconLoader.cc: In constructor ‘IconLoader::IconLoader(const char*)’:

IconLoader.cc:20: error: ‘getenv’ was not declared in this scope

make: *** [iconLoader.o] Error 1

 

Looks like I'm a little closer.

 

EDIT 2:

 

So now I added this line to SuperBar.cc and also to IconLoader.cc

 

#include <stdlib.h>

 

And following the instructions in this excellent article I have a working Wbar.

 

The last issue is that the article was written for GNOME, and I haven't figured out how to add Wbar to the startup applications in KDE.

Edited by Zac Medley

Share this post


Link to post
Share on other sites

OK that's cool. I'll try that too because I have several rigs running Mandriva that I can test on.

Share this post


Link to post
Share on other sites

Here are the steps I have followed to finish my installation of Wbar in Mandriva 2009.1 GNOME

 

Installing Wbar in Mandriva is not as simple as it is in Ubuntu because there is no RPM available at this time. DeviceGuru has an excellent article about how to install Wbar in Ubuntu, and it also has links to all of the files that your will need.

 

In Mandriva you will need to get the Wbar source code and compile it. Of course, this assumes that you already have the packages necessary for compiling the code installed:

 

#urpmi make

#urpmi gcc-c++

#urpmi libimlib2.devel

 

There are two minor bug fixes that can be applied using your text editor:

Add this line to SuperBar.cc and also to IconLoader.cc

#include <stdlib.h>

 

There is a patch that needs to be applied (thanks to scarecrow at mandrivausers.org)

http://www.smithux.com/docs/wbar-patched/w…_warnings.patch

You can simply apply it with

#patch < $srcdir/wbar-gcc430_and_warnings.patch

where $srcdir is the place you have extracted the source files.

 

Once you have taken care of those issues you can compile the code:

$make

 

[if you do this in the wrong sequence then there are a variety of possible errors that can occur. One of them is noted here.]

 

And then, as root:

#make install

 

Once Wbar is installed, you can quickly test it by issuing the following command from a console (Menu > Accessories > Terminal) window:

 

$wbar -pos center -above-desk

 

Next, download this file to your desktop, set its permissions to executable (â€chmod +x wbar_startâ€), and move it to /usr/bin/ on your system

 

# ~/Desktop/wbar_start /usr/bin/

 

Now add Wbar to the list of applications that start automatically when GNOME loads. To do this, start GNOME’s Sessions configuration tool (System > Preferences > Startup Applications), and add Wbar to the list of startup programs. For its startup command, enter: “/usr/bin/wbar_startâ€.

 

Now you will need to install Wbarconf so that you can customize your launchers. You can download the source files from here. Extract the package and then open a terminal. Install by logging on as root and typing:

 

#../install.sh /usr/ (or)

#../install.sh /usr/local/

 

And then add the Wbarconf application to your main menu. I put my launcher in System > Administration.

 

Summary

 

1. DeviceGuru >> Adding Wbar, Prism and gadgets to Ubuntu

2. Downloads – wbar – Google Code

3. Add this line to SuperBar.cc and also to IconLoader.cc:

#include <stdlib.h>

4. #patch < wbar-gcc430_and_warnings.patch

5. $make

6. #make install

7. $wbar -pos center -above-desk (to test your installation)

8. #mv ~/Desktop/wbar_start /usr/bin/

and make sure you set permissions to executable

9. Add wbar to your Startup Applications

10. Install Wbarconf

11. Add Wbarconf to your Main Menu

Edited by Zac Medley

Share this post


Link to post
Share on other sites
Guest zero pointer

Just for posterity's sake, here's the easy way of accomplishing this:

 

  • install alien:
    sudo urpmi alien


  • download the .deb file from the wbar google projects page
  • convert the .deb file to a .rpm file with alien:
    sudo alien --to-rpm *deb


  • install the resulting rpm
    sudo urpmi *rpm


Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...