Jump to content
viking777

And now the rot hits 2009 [solved]

Recommended Posts

Yes, it is most definitely worth fixing, even if it seems you are the only one experiencing problems. Because chances are in the future, someone else might come across the problem. I've logged bugs for problems that I've had that I didn't see open bugs for. Because, if someone already had come across it, they too would have opened it to get it fixed.

 

It's not a case of waiting to see if someone else has the problem before opening up the bug. What I found with mine is that then a few people posted on my bug saying that they too also had the same problem! Obviously, they searched to see if a bug with that problem was open, and came across mine. And then added their comments rather than open up a duplicate bug.

Share this post


Link to post
Share on other sites

I see... Although Ian is right in principle, I see I can't really help. Do as you see fit :)

 

Yves.

Share this post


Link to post
Share on other sites
I don't think that is it David, but I can't honestly be sure. Firstly the guy in the post seems to have put something to do with Nvidia into skip.list. Both my skip.list files are empty. Secondly he seems to run a test install every time, I have never done that, I just jump in! Thirdly in his test install he seems to have got some error messages - I didn't (but then neither did he when he installed it for real).

 

Part of the problem is that I don't really understand the function of the multitude of modules relating to nvidia, and dkms that Mandriva seems to carry - there seem to be so many, and being a simple soul, installing the driver for myself is a damn sight easier than trying to work out what is going wrong with the automatic method :unsure:

 

It's a she ;) and it's definitively not the same bug, in fact the bug reported in that thread isn't even a bug, the built bots just need time to build a non-essential package.

 

But I already said here, go to IRC and speak with Anssi

Share this post


Link to post
Share on other sites

OK guys I have a chance to experiment with this problem with your help if you wish. Cooker is offering me a kernel upgrade today(kernel desktop 2.6.29.1-3) so I can use this to get some detailed output that might help me phrase a bug report.

 

Furthermore I now see that someone with the exact same laptop as myself has just reported a similar problem so that motivates me to do something as well.

 

As I said earlier in the thread, I removed the dkms modules before because I got fed up with waiting for them to install only to have the whole thing fail anyway.So prior to doing anything I have reinstalled dkms-nvidia-current which pulled in as dependencies nvidia-current-doc and x11-driver-nvidia-current (all for the 180.44 driver). After install it asked me to use XFdrake to configure my graphics card and then restart X I did this, the settings were correct, so I accepted the defaults then logged out and in and all was fine (I expected this because it was not a kernel upgrade).

 

This is the output of urpmi so you can see what it is proposing to install:

 

To satisfy dependencies, the following packages are going to be installed:

 

   Package						Version	  Release	   Arch   
(medium "Main")
 drak3d						 1.25.1	   1mdv2009.1	noarch  
 drakbackup					 0.19.2	   1mdv2009.1	noarch  
 drakconf					   12.9		 1mdv2009.1	noarch  
 drakconf-icons				 12.9		 1mdv2009.1	noarch  
 draksnapshot				   0.20.1	   1mdv2009.1	noarch  
 drakx-finish-install		   12.28.1	  1mdv2009.1	i586	
 drakx-installer-binaries-probe 1.37.2	   1mdv2009.1	i586	
 drakx-net					  0.74.4	   1mdv2009.1	noarch  
 drakx-net-text				 0.74.4	   1mdv2009.1	noarch  
 drakxtools					 12.28.1	  1mdv2009.1	i586	
 drakxtools-backend			 12.28.1	  1mdv2009.1	i586	
 drakxtools-curses			  12.28.1	  1mdv2009.1	i586	
 evince						 2.26.1	   1mdv2009.1	i586	
 evolution					  2.26.1.1	 1mdv2009.1	i586	
 evolution-data-server		  2.26.1.1	 1mdv2009.1	i586	
 fontconfig					 2.6.0		5mdv2009.1	i586	
 gnome-media					2.26.0	   2mdv2009.1	i586	
 gtk+2.0						2.16.1	   3mdv2009.1	i586	
 gurpmi						 6.25.2	   1mdv2009.1	noarch  
 harddrake					  12.28.1	  1mdv2009.1	i586	
 harddrake-ui				   12.28.1	  1mdv2009.1	i586	
 hcl							1.7.1		1mdv2009.1	noarch  
 initscripts					8.88		 18mdv2009.1   i586	
 kernel-desktop586-2.6.29.1-3m> 1			1mnb2		 i586	
 kernel-desktop586-devel-2.6.2> 1			1mnb2		 i586	
 kernel-desktop586-devel-latest 2.6.29.1	 3mnb2		 i586	
 kernel-desktop586-latest	   2.6.29.1	 3mnb2		 i586	
 kernel-source-2.6.29.1-3mnb	1			1mnb2		 i586	
 kernel-source-latest		   2.6.29.1	 3mnb2		 i586	
 libcamel14					 2.26.1.1	 1mdv2009.1	i586	
 libcddb-slave2_0			   2.26.0	   2mdv2009.1	i586	
 libdrakx-net				   0.74.4	   1mdv2009.1	noarch  
 libdrm-common				  2.4.9		1mdv2009.1	i586	
 libdrm2						2.4.9		1mdv2009.1	i586	
 libdrm_intel1				  2.4.9		1mdv2009.1	i586	
 libebackend0				   2.26.1.1	 1mdv2009.1	i586	
 libebook9					  2.26.1.1	 1mdv2009.1	i586	
 libecal7					   2.26.1.1	 1mdv2009.1	i586	
 libedata-book2				 2.26.1.1	 1mdv2009.1	i586	
 libedata-cal6				  2.26.1.1	 1mdv2009.1	i586	
 libedataserver11			   2.26.1.1	 1mdv2009.1	i586	
 libedataserverui8			  2.26.1.1	 1mdv2009.1	i586	
 libegroupwise13				2.26.1.1	 1mdv2009.1	i586	
 libevince1					 2.26.1	   1mdv2009.1	i586	
 libexchange-storage3		   2.26.1.1	 1mdv2009.1	i586	
 libexiv2_5					 0.18.1	   1mdv2009.1	i586	
 libfontconfig-devel			2.6.0		5mdv2009.1	i586	
 libfontconfig1				 2.6.0		5mdv2009.1	i586	
 libgail18					  2.16.1	   3mdv2009.1	i586	
 libgdata1					  2.26.1.1	 1mdv2009.1	i586	
 libgdk_pixbuf2.0_0			 2.16.1	   3mdv2009.1	i586	
 libgdk_pixbuf2.0_0-devel	   2.16.1	   3mdv2009.1	i586	
 libgladeui1_-devel			 3.6.2		1mdv2009.1	i586	
 libgladeui1_9				  3.6.2		1mdv2009.1	i586	
 libgnome2					  2.26.0	   3mdv2009.1	i586	
 libgnome2_0					2.26.0	   3mdv2009.1	i586	
 libgtk+-x11-2.0_0			  2.16.1	   3mdv2009.1	i586	
 libgtk+2.0_0				   2.16.1	   3mdv2009.1	i586	
 libgtk+2.0_0-devel			 2.16.1	   3mdv2009.1	i586	
 libmetacity-private0		   2.26.0	   3mdv2009.1	i586	
 libnautilus1				   2.26.2	   2mdv2009.1	i586	
 libudev0					   140		  3mnb2		 i586	
 libvolume_id1				  140		  3mnb2		 i586	
 mandriva-gfxboot-theme		 4.1.19.10	1mdv2009.1	i586	
 mdkonline					  2.76.2	   1mdv2009.1	noarch  
 metacity					   2.26.0	   3mdv2009.1	i586	
 msec						   0.60.18	  2mdv2009.1	i586	
 msec-gui					   0.60.18	  2mdv2009.1	i586	
 nautilus					   2.26.2	   2mdv2009.1	i586	
 numlock						2.1.2		2mdv2009.1	i586	
 perl						   5.10.0	   25mdv2009.1   i586	
 perl-base					  5.10.0	   25mdv2009.1   i586	
 perl-suid					  5.10.0	   25mdv2009.1   i586	
 pm-utils					   1.2.4		4mdv2009.1	i586	
 shorewall					  4.2.8		1mdv2009.1	noarch  
 shorewall-common			   4.2.8		1mdv2009.1	noarch  
 shorewall-perl				 4.2.8		1mdv2009.1	noarch  
 timezone					   2009f		1mdv2009.1	i586	
 transfugdrake				  1.9.1		1mdv2009.1	noarch  
 udev						   140		  3mnb2		 i586	
 userdrake					  1.9.1		1mdv2009.1	i586	
 virtualbox-kernel-2.6.29.1-de> 2.2.0		2mdv2009.1	i586	
 virtualbox-kernel-desktop586-> 2.2.0		1.20090416.2> i586	
 x11-driver-input-vboxmouse	 2.2.0		2mdv2009.1	i586	
 x11-driver-video-intel		 2.7.0		1mdv2009.1	i586	
 x11-driver-video-vboxvideo	 2.2.0		2mdv2009.1	i586	
297MB of additional disk space will be used.
136MB of packages will be retrieved.
Proceed with the installation of the 86 packages? (Y/n)

 

Notice I don't only have the devel packages but the source packages as well - this was one of my earlier attempts to get this to work.

 

Here is more relevant output:

 

 rpm -qa | grep nvidia
nvidia-current-doc-html-180.44-2mdv2009.1
dkms-nvidia-current-180.44-2mdv2009.1
x11-driver-video-nvidia-current-180.44-2mdv2009.1

rpm -qa | grep kernel
kernel-desktop-devel-2.6.29-0.rc8.3.1mnb-1-1mnb2
kernel-desktop586-devel-2.6.29.1-2mnb-1-1mnb2
kernel-source-latest-2.6.29.1-2mnb2
virtualbox-kernel-desktop586-latest-2.2.0-1.20090412.1mdv2009.1
kernel-headers-2.6.29-1mnb2
kernel-desktop586-devel-latest-2.6.29.1-2mnb2
kernel-source-2.6.29.1-1mnb-1-1mnb2
kernel-desktop586-2.6.29.1-2mnb-1-1mnb2
virtualbox-kernel-2.6.29.1-desktop586-2mnb-2.2.0-1mdv2009.1
kernel-desktop586-devel-2.6.29.1-1mnb-1-1mnb2
kernel-source-2.6.29.1-2mnb-1-1mnb2
kernel-desktop586-2.6.29.1-1mnb-1-1mnb2
kernel-firmware-extra-20090212-2mnb2
virtualbox-kernel-2.6.29.1-desktop586-1mnb-2.2.0-1mdv2009.1
kernel-desktop586-latest-2.6.29.1-2mnb2
kernel-firmware-20090111-3mnb2

uname -a
Linux localhost 2.6.29.1-desktop586-2mnb #1 SMP Fri Apr 10 21:51:25 EDT 2009 i686 Intel® Core(tm)2 Duo CPU	 T7300  @ 2.00GHz GNU/Linux

 

Now can anyone see any reason why the upgrade shouldn't work?

 

I'll leave this post open for a short while and if I don't get any replies I will run the update and post that output along with any findings that I have.

 

EDIT. OK back again with a new kernel. The urpmi part of the install gave no useful info so I will omit that, it simply said installation complete reboot for new kernel. So I did.

 

After the reboot dkms set about installing the Nvidia module and a couple of Vbox modules. The Nvidia module showed no errors, the Vbox modules both failed. When the boot was complete I was dropped into my usual terminal with the usual 'Would you like to diagnose' dialog. I usually ignore this but this time I pressed 'Yes'. There were various EE errors the most significant of which seemed to be:

 

FATAL. Module Nvidia not found.

 

It then went on to ask if I would like to view the Xserver output. Again I usually say no but this time I said yes.

 

Again various errors the most frequent of which was "Failed to load module type 1" and "Failed to load module freetype"

 

I was then asked if I would like to configure the Xserver, I accepted, XFdrake launched and all the options in it were correct. I pressed 'TEST' and just got warnings as above about type1 and freetype.

 

All this I have done a dozen times before and the result is always the same - I install manually.

 

During the manual installation I get 1 warning - /usr/lib/xorg/modules/extensions/libglx.so is not a symbolic liink. (but it is believe me I have checked!)

 

Press OK the install completes and everything is back to normal except for Vboxdrv which I will now also have to install manually.

 

The only other output related to reading /var/log/Xorg.).log which I include below - but it is rather long.

 

 

 

X.Org X Server 1.6.1
Release Date: 2009-4-14
X Protocol Version 11, Revision 0
Build Operating System: Linux_2.6.22.18-server-1mdv Mandriva
Current Operating System: Linux localhost 2.6.29.1-desktop586-3mnb #1 SMP Thu Apr 16 10:46:24 EDT 2009 i686
Build Date: 14 April 2009  04:56:28PM

Before reporting problems, check [url="http://qa.mandriva.com"]http://qa.mandriva.com[/url]
to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Fri Apr 17 11:37:34 2009
(==) Using config file: "/etc/X11/xorg.conf"
(==) ServerLayout "layout1"
(**) |-->Screen "Screen0" (0)
(**) |   |-->Monitor "Monitor0"
(==) No device specified for screen "Screen0".
Using the first device section listed.
(**) |   |-->Device "device1"
(**) |-->Input Device "Keyboard1"
(**) |-->Input Device "Mouse1"
(**) |-->Input Device "SynapticsMouse1"
(**) Option "AllowMouseOpenFail"
(**) Option "Xinerama" "0"
(**) Option "IgnoreABI" "true"
(**) Ignoring ABI Version
(==) Automatically adding devices
(==) Automatically enabling devices
(==) FontPath set to:
catalogue:/etc/X11/fontpath.d,
built-ins
(==) ModulePath set to "/usr/lib/xorg/extra-modules,/usr/lib/xorg/modules"
(WW) AllowEmptyInput is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
(WW) Disabling Keyboard1
(WW) Disabling Mouse1
(II) Loader magic: 0x1bc0
(II) Module ABI versions:
X.Org ANSI C Emulation: 0.4
X.Org Video Driver: 5.0
X.Org XInput driver : 4.0
X.Org Server Extension : 2.0
(II) Loader running on linux
(--) using VT number 7

(--) PCI:*(0@1:0:0) nVidia Corporation GeForce 8600M GS rev 161, Mem @ 0xf2000000/16777216, 0xd0000000/268435456, 0xf0000000/33554432, I/O @ 0x00002000/128
(II) Open ACPI successful (/var/run/acpid.socket)
(II) System resource ranges:
[0] -1	0	0xffffffff - 0xffffffff (0x1) MX[B]
[1] -1	0	0x000f0000 - 0x000fffff (0x10000) MX[B]
[2] -1	0	0x000c0000 - 0x000effff (0x30000) MX[B]
[3] -1	0	0x00000000 - 0x0009ffff (0xa0000) MX[B]
[4] -1	0	0x0000ffff - 0x0000ffff (0x1) IX[B]
[5] -1	0	0x00000000 - 0x00000000 (0x1) IX[B]
(WW) "dri" will not be loaded unless you've specified it to be loaded elsewhere.
(II) "extmod" will be loaded. This was enabled by default and also specified in the config file.
(II) "dbe" will be loaded. This was enabled by default and also specified in the config file.
(II) "glx" will be loaded. This was enabled by default and also specified in the config file.
(II) "record" will be loaded by default.
(II) "dri" will be loaded even though the default is to disable it.
(II) "dri2" will be loaded by default.
(II) LoadModule: "dbe"
(II) Loading /usr/lib/xorg/modules/extensions//libdbe.so
(II) Module dbe: vendor="X.Org Foundation"
compiled for 1.6.1, module version = 1.0.0
Module class: X.Org Server Extension
ABI class: X.Org Server Extension, version 2.0
(II) Loading extension DOUBLE-BUFFER
(II) LoadModule: "v4l"
(II) Loading /usr/lib/xorg/modules/drivers//v4l_drv.so
(II) Module v4l: vendor="X.Org Foundation"
compiled for 1.5.99.3, module version = 0.1.1
ABI class: X.Org Video Driver, version 5.0
(II) LoadModule: "extmod"
(II) Loading /usr/lib/xorg/modules/extensions//libextmod.so
(II) Module extmod: vendor="X.Org Foundation"
compiled for 1.6.1, module version = 1.0.0
Module class: X.Org Server Extension
ABI class: X.Org Server Extension, version 2.0
(II) Loading extension Multi-Buffering
(II) Loading extension MIT-SCREEN-SAVER
(II) Loading extension XFree86-VidModeExtension
(II) Loading extension XFree86-DGA
(II) Loading extension DPMS
(II) Loading extension XVideo
(II) Loading extension XVideo-MotionCompensation
(II) Loading extension X-Resource
(II) LoadModule: "type1"
(WW) Warning, couldn't open module type1
(II) UnloadModule: "type1"
(EE) Failed to load module "type1" (module does not exist, 0)
(II) LoadModule: "freetype"
(WW) Warning, couldn't open module freetype
(II) UnloadModule: "freetype"
(EE) Failed to load module "freetype" (module does not exist, 0)
(II) LoadModule: "glx"
(II) Loading /usr/lib/xorg/modules/extensions//libglx.so
(II) Module glx: vendor="NVIDIA Corporation"
compiled for 4.0.2, module version = 1.0.0
Module class: X.Org Server Extension
(II) NVIDIA GLX Module  180.44  Mon Mar 23 15:29:02 PST 2009
(II) Loading extension GLX
(II) LoadModule: "record"
(II) Loading /usr/lib/xorg/modules/extensions//librecord.so
(II) Module record: vendor="X.Org Foundation"
compiled for 1.6.1, module version = 1.13.0
Module class: X.Org Server Extension
ABI class: X.Org Server Extension, version 2.0
(II) Loading extension RECORD
(II) LoadModule: "dri2"
(II) Loading /usr/lib/xorg/modules/extensions//libdri2.so
(II) Module dri2: vendor="X.Org Foundation"
compiled for 1.6.1, module version = 1.0.0
ABI class: X.Org Server Extension, version 2.0
(II) Loading extension DRI2
(II) LoadModule: "nvidia"
(II) Loading /usr/lib/xorg/modules/drivers//nvidia_drv.so
(II) Module nvidia: vendor="NVIDIA Corporation"
compiled for 4.0.2, module version = 1.0.0
Module class: X.Org Video Driver
(II) LoadModule: "synaptics"
(II) Loading /usr/lib/xorg/modules/input//synaptics_drv.so
(II) Module synaptics: vendor="X.Org Foundation"
compiled for 1.6.0, module version = 1.1.0
Module class: X.Org XInput Driver
ABI class: X.Org XInput driver, version 4.0
(II) v4l driver for Video4Linux
(II) NVIDIA dlloader X Driver  180.44  Mon Mar 23 15:05:32 PST 2009
(II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
(II) Primary Device is: PCI 01@00:00:0
(WW) Falling back to old probe method for v4l
(II) Loading sub module "fb"
(II) LoadModule: "fb"
(II) Loading /usr/lib/xorg/modules//libfb.so
(II) Module fb: vendor="X.Org Foundation"
compiled for 1.6.1, module version = 1.0.0
ABI class: X.Org ANSI C Emulation, version 0.4
(II) Loading sub module "wfb"
(II) LoadModule: "wfb"
(II) Loading /usr/lib/xorg/modules//libwfb.so
(II) Module wfb: vendor="X.Org Foundation"
compiled for 1.6.1, module version = 1.0.0
ABI class: X.Org ANSI C Emulation, version 0.4
(II) Loading sub module "ramdac"
(II) LoadModule: "ramdac"
(II) Module "ramdac" already built-in
(II) resource ranges after probing:
[0] -1	0	0xffffffff - 0xffffffff (0x1) MX[B]
[1] -1	0	0x000f0000 - 0x000fffff (0x10000) MX[B]
[2] -1	0	0x000c0000 - 0x000effff (0x30000) MX[B]
[3] -1	0	0x00000000 - 0x0009ffff (0xa0000) MX[B]
[4] -1	0	0x0000ffff - 0x0000ffff (0x1) IX[B]
[5] -1	0	0x00000000 - 0x00000000 (0x1) IX[B]
(**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
(==) NVIDIA(0): RGB weight 888
(==) NVIDIA(0): Default visual is TrueColor
(==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
(**) NVIDIA(0): Option "TwinView" "1"
(**) NVIDIA(0): Option "TwinViewOrientation" "Clone"
(**) NVIDIA(0): Option "MetaModes" "DFP-0: 1280x800 @1280x1024 +1280+0, DFP-1: 1280x1024_60 +0+0; DFP-0: 1024x768 +1024+0, DFP-1: 1024x768 +0+0; DFP-0: 800x600 +800+0, DFP-1: 800x600 +0+0; DFP-0: 640x480 +640+0, DFP-1: 640x480 +0+0; DFP-0: 320x240 +320+0, DFP-1: 320x240 +0+0"
(**) NVIDIA(0): Option "TwinViewXineramaInfoOrder" "DFP-1"
(**) NVIDIA(0): Option "AddARGBGLXVisuals"
(**) NVIDIA(0): Enabling RENDER acceleration
(II) NVIDIA(0): Support for GLX with the Damage and Composite X extensions is
(II) NVIDIA(0):	 enabled.
(II) NVIDIA(0): NVIDIA GPU GeForce 8600M GS (G86) at PCI:1:0:0 (GPU-0)
(--) NVIDIA(0): Memory: 524288 kBytes
(--) NVIDIA(0): VideoBIOS: 60.86.48.00.20
(II) NVIDIA(0): Detected PCI Express Link width: 16X
(--) NVIDIA(0): Interlaced video modes are supported on this GPU
(--) NVIDIA(0): Connected display device(s) on GeForce 8600M GS at PCI:1:0:0:
(--) NVIDIA(0):	 Seiko (DFP-0)
(--) NVIDIA(0):	 Sony SDM-HS95P (DFP-1)
(--) NVIDIA(0): Seiko (DFP-0): 330.0 MHz maximum pixel clock
(--) NVIDIA(0): Seiko (DFP-0): Internal Dual Link LVDS
(--) NVIDIA(0): Sony SDM-HS95P (DFP-1): 165.0 MHz maximum pixel clock
(--) NVIDIA(0): Sony SDM-HS95P (DFP-1): Internal Single Link TMDS
(**) NVIDIA(0): TwinView enabled
(II) NVIDIA(0): Display Devices found referenced in MetaMode: DFP-0, DFP-1
(II) NVIDIA(0): Assigned Display Devices: DFP-0, DFP-1
(II) NVIDIA(0): Validated modes:
(II) NVIDIA(0):	 "DFP-0:1280x800@1280x1024+1280+0,DFP-1:1280x1024_60+0+0"
(II) NVIDIA(0):	 "DFP-0:1024x768+1024+0,DFP-1:1024x768+0+0"
(II) NVIDIA(0):	 "DFP-0:800x600+800+0,DFP-1:800x600+0+0"
(II) NVIDIA(0):	 "DFP-0:640x480+640+0,DFP-1:640x480+0+0"
(II) NVIDIA(0):	 "DFP-0:320x240+320+0,DFP-1:320x240+0+0"
(II) NVIDIA(0): Virtual screen size determined to be 2560 x 1024
(--) NVIDIA(0): DPI set to (98, 96); computed from "UseEdidDpi" X config
(--) NVIDIA(0):	 option
(**) NVIDIA(0): Enabling 32-bit ARGB GLX visuals.
(--) Depth 24 pixmap format is 32 bpp
(II) do I need RAC?  No, I don't.
(II) resource ranges after preInit:
[0] -1	0	0xffffffff - 0xffffffff (0x1) MX[B]
[1] -1	0	0x000f0000 - 0x000fffff (0x10000) MX[B]
[2] -1	0	0x000c0000 - 0x000effff (0x30000) MX[B]
[3] -1	0	0x00000000 - 0x0009ffff (0xa0000) MX[B]
[4] -1	0	0x0000ffff - 0x0000ffff (0x1) IX[B]
[5] -1	0	0x00000000 - 0x00000000 (0x1) IX[B]
(II) NVIDIA(0): Initialized GPU GART.
(II) NVIDIA(0): ACPI display change hotkey events enabled: the X server is new
(II) NVIDIA(0):	 enough to receive ACPI display change hotkey events.
(II) NVIDIA(0): Setting mode
(II) NVIDIA(0):	 "DFP-0:1280x800@1280x1024+1280+0,DFP-1:1280x1024_60+0+0"
(II) Loading extension NV-GLX
(II) NVIDIA(0): NVIDIA 3D Acceleration Architecture Initialized
(==) NVIDIA(0): Disabling shared memory pixmaps
(II) NVIDIA(0): Using the NVIDIA 2D acceleration architecture
(==) NVIDIA(0): Backing store disabled
(==) NVIDIA(0): Silken mouse enabled
(**) NVIDIA(0): DPMS enabled
(II) Loading extension NV-CONTROL
(II) Loading extension XINERAMA
(==) RandR enabled
(II) Initializing built-in extension Generic Event Extension
(II) Initializing built-in extension SHAPE
(II) Initializing built-in extension MIT-SHM
(II) Initializing built-in extension XInputExtension
(II) Initializing built-in extension XTEST
(II) Initializing built-in extension BIG-REQUESTS
(II) Initializing built-in extension SYNC
(II) Initializing built-in extension XKEYBOARD
(II) Initializing built-in extension XC-MISC
(II) Initializing built-in extension SECURITY
(II) Initializing built-in extension XINERAMA
(II) Initializing built-in extension XFIXES
(II) Initializing built-in extension XFree86-Bigfont
(II) Initializing built-in extension RENDER
(II) Initializing built-in extension RANDR
(II) Initializing built-in extension COMPOSITE
(II) Initializing built-in extension DAMAGE
(II) Initializing extension GLX
(II) Synaptics touchpad driver version 1.1.0
(--) SynapticsMouse1 auto-dev sets device to /dev/input/event2
(**) Option "Device" "/dev/input/event2"
(II) SynapticsMouse1: x-axis range 1472 - 5472
(II) SynapticsMouse1: y-axis range 1408 - 4448
(II) SynapticsMouse1: pressure range 0 - 255
(II) SynapticsMouse1: finger width range 0 - 0
(II) SynapticsMouse1: buttons: left right middle
(**) Option "SHMConfig" "on"
(--) SynapticsMouse1 touchpad found
(**) Option "SendCoreEvents"
(**) SynapticsMouse1: always reports core events
(II) XINPUT: Adding extended input device "SynapticsMouse1" (type: TOUCHPAD)
(**) SynapticsMouse1: (accel) keeping acceleration scheme 1
(**) SynapticsMouse1: (accel) filter chain progression: 2.00
(**) SynapticsMouse1: (accel) filter stage 0: 20.00 ms
(**) SynapticsMouse1: (accel) set acceleration profile 0
(--) SynapticsMouse1 touchpad found
(II) config/hal: Adding input device AT Translated Set 2 keyboard
(II) LoadModule: "evdev"
(II) Loading /usr/lib/xorg/modules/input//evdev_drv.so
(II) Module evdev: vendor="X.Org Foundation"
compiled for 1.6.0, module version = 2.2.1
Module class: X.Org XInput Driver
ABI class: X.Org XInput driver, version 4.0
(**) AT Translated Set 2 keyboard: always reports core events
(**) AT Translated Set 2 keyboard: Device: "/dev/input/event0"
(II) AT Translated Set 2 keyboard: Found keys
(II) AT Translated Set 2 keyboard: Configuring as keyboard
(II) XINPUT: Adding extended input device "AT Translated Set 2 keyboard" (type: KEYBOARD)
(**) Option "xkb_rules" "evdev"
(**) Option "xkb_model" "evdev"
(**) Option "xkb_layout" "gb"
(**) Option "xkb_options" "compose:rwin"
(II) config/hal: Adding input device   USB Keyboard
(**)   USB Keyboard: always reports core events
(**)   USB Keyboard: Device: "/dev/input/event12"
(II)   USB Keyboard: Found keys
(II)   USB Keyboard: Configuring as keyboard
(II) XINPUT: Adding extended input device "  USB Keyboard" (type: KEYBOARD)
(**) Option "xkb_rules" "evdev"
(**) Option "xkb_model" "evdev"
(**) Option "xkb_layout" "gb"
(**) Option "xkb_options" "compose:rwin"
(II) config/hal: Adding input device   USB Keyboard
(**)   USB Keyboard: always reports core events
(**)   USB Keyboard: Device: "/dev/input/event11"
(II)   USB Keyboard: Found keys
(II)   USB Keyboard: Configuring as keyboard
(II) XINPUT: Adding extended input device "  USB Keyboard" (type: KEYBOARD)
(**) Option "xkb_rules" "evdev"
(**) Option "xkb_model" "evdev"
(**) Option "xkb_layout" "gb"
(**) Option "xkb_options" "compose:rwin"
(II) config/hal: Adding input device Acer CrystalEye webcam
(**) Acer CrystalEye webcam: always reports core events
(**) Acer CrystalEye webcam: Device: "/dev/input/event9"
(II) Acer CrystalEye webcam: Found keys
(II) Acer CrystalEye webcam: Configuring as keyboard
(II) XINPUT: Adding extended input device "Acer CrystalEye webcam" (type: KEYBOARD)
(**) Option "xkb_rules" "evdev"
(**) Option "xkb_model" "evdev"
(**) Option "xkb_layout" "gb"
(**) Option "xkb_options" "compose:rwin"
(II) config/hal: Adding input device Sleep Button (CM)
(**) Sleep Button (CM): always reports core events
(**) Sleep Button (CM): Device: "/dev/input/event7"
(II) Sleep Button (CM): Found keys
(II) Sleep Button (CM): Configuring as keyboard
(II) XINPUT: Adding extended input device "Sleep Button (CM)" (type: KEYBOARD)
(**) Option "xkb_rules" "evdev"
(**) Option "xkb_model" "evdev"
(**) Option "xkb_layout" "gb"
(**) Option "xkb_options" "compose:rwin"
(II) config/hal: Adding input device Video Bus
(**) Video Bus: always reports core events
(**) Video Bus: Device: "/dev/input/event8"
(II) Video Bus: Found keys
(II) Video Bus: Configuring as keyboard
(II) XINPUT: Adding extended input device "Video Bus" (type: KEYBOARD)
(**) Option "xkb_rules" "evdev"
(**) Option "xkb_model" "evdev"
(**) Option "xkb_layout" "gb"
(**) Option "xkb_options" "compose:rwin"
(II) config/hal: Adding input device Power Button (CM)
(**) Power Button (CM): always reports core events
(**) Power Button (CM): Device: "/dev/input/event6"
(II) Power Button (CM): Found keys
(II) Power Button (CM): Configuring as keyboard
(II) XINPUT: Adding extended input device "Power Button (CM)" (type: KEYBOARD)
(**) Option "xkb_rules" "evdev"
(**) Option "xkb_model" "evdev"
(**) Option "xkb_layout" "gb"
(**) Option "xkb_options" "compose:rwin"
(II) config/hal: Adding input device Power Button (FF)
(**) Power Button (FF): always reports core events
(**) Power Button (FF): Device: "/dev/input/event4"
(II) Power Button (FF): Found keys
(II) Power Button (FF): Configuring as keyboard
(II) XINPUT: Adding extended input device "Power Button (FF)" (type: KEYBOARD)
(**) Option "xkb_rules" "evdev"
(**) Option "xkb_model" "evdev"
(**) Option "xkb_layout" "gb"
(**) Option "xkb_options" "compose:rwin"
(II) config/hal: Adding input device USB Optical Mouse
(**) USB Optical Mouse: always reports core events
(**) USB Optical Mouse: Device: "/dev/input/event10"
(II) USB Optical Mouse: Found 3 mouse buttons
(II) USB Optical Mouse: Found x and y relative axes
(II) USB Optical Mouse: Found scroll wheel(s)
(II) USB Optical Mouse: Configuring as mouse
(**) USB Optical Mouse: YAxisMapping: buttons 4 and 5
(**) USB Optical Mouse: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
(II) XINPUT: Adding extended input device "USB Optical Mouse" (type: MOUSE)
(**) USB Optical Mouse: (accel) keeping acceleration scheme 1
(**) USB Optical Mouse: (accel) filter chain progression: 2.00
(**) USB Optical Mouse: (accel) filter stage 0: 20.00 ms
(**) USB Optical Mouse: (accel) set acceleration profile 0
(II) config/hal: Adding input device SynPS/2 Synaptics TouchPad
(II) Synaptics touchpad driver version 1.1.0
(**) Option "Device" "/dev/input/event2"
(II) SynPS/2 Synaptics TouchPad: x-axis range 1472 - 5472
(II) SynPS/2 Synaptics TouchPad: y-axis range 1408 - 4448
(II) SynPS/2 Synaptics TouchPad: pressure range 0 - 255
(II) SynPS/2 Synaptics TouchPad: finger width range 0 - 0
(II) SynPS/2 Synaptics TouchPad: buttons: left right middle
(--) SynPS/2 Synaptics TouchPad touchpad found
(**) SynPS/2 Synaptics TouchPad: always reports core events
(II) XINPUT: Adding extended input device "SynPS/2 Synaptics TouchPad" (type: TOUCHPAD)
(**) SynPS/2 Synaptics TouchPad: (accel) keeping acceleration scheme 1
(**) SynPS/2 Synaptics TouchPad: (accel) filter chain progression: 2.00
(**) SynPS/2 Synaptics TouchPad: (accel) filter stage 0: 20.00 ms
(**) SynPS/2 Synaptics TouchPad: (accel) set acceleration profile 0
(WW) SynPS/2 Synaptics TouchPad can't grab event device, errno=16
(--) SynPS/2 Synaptics TouchPad touchpad found
(II) config/hal: Adding input device SynPS/2 Synaptics TouchPad
(II) Synaptics touchpad driver version 1.1.0
(**) Option "Device" "/dev/input/event1"
(II) SynPS/2 Synaptics TouchPad: x-axis range 1472 - 5472
(II) SynPS/2 Synaptics TouchPad: y-axis range 1408 - 4448
(II) SynPS/2 Synaptics TouchPad: pressure range 0 - 255
(II) SynPS/2 Synaptics TouchPad: finger width range 0 - 0
(II) SynPS/2 Synaptics TouchPad: buttons: left right middle
(--) SynPS/2 Synaptics TouchPad touchpad found
(**) SynPS/2 Synaptics TouchPad: always reports core events
(II) XINPUT: Adding extended input device "SynPS/2 Synaptics TouchPad" (type: TOUCHPAD)
(**) SynPS/2 Synaptics TouchPad: (accel) keeping acceleration scheme 1
(**) SynPS/2 Synaptics TouchPad: (accel) filter chain progression: 2.00
(**) SynPS/2 Synaptics TouchPad: (accel) filter stage 0: 20.00 ms
(**) SynPS/2 Synaptics TouchPad: (accel) set acceleration profile 0
(--) SynPS/2 Synaptics TouchPad touchpad found

Edited by ianw1974
ianw1974: applied code formatting to tidy things up

Share this post


Link to post
Share on other sites

Well this has now been solved (I think, although the next kernel update will tell for sure) entirely due to the efforts of Anssi Hannula so I would like to publicly thank him for his patience and complement him on his knowledge.

 

The problem was that at some time previously I had used the nvidia installer to install the nvidia driver. Apparently when it runs it deletes certain files that it thinks are unnecessary (and they are as far it is concerned) but for the Mandriva dkms installation of nvidia drivers these files are completely necessary so once you have used the nvidia installer and the files are removed the dkms installer never works again.

 

The solution is:

 

urpmi --replacepkgs x11-driver-video-nvidia-current

 

this replaces the packages removed by the nvidia installer and allows XFdrake to work.

 

I have used this in 2009 and Cooker and in both cases it seems to work.

Share this post


Link to post
Share on other sites

Told you go to Anssi  :P seriously usually a bugreport isn't even necessary, just a quick chat on irc; glad you got it fixed though

Edited by ffi

Share this post


Link to post
Share on other sites
Told you go to Anssi  :P seriously usually a bugreport isn't even necessary, just a quick chat on irc; glad you got it fixed though

 

Yeah, you were right about that. As I have written it above, the 'fix' looks simple, but the detective work involved in getting there was anything but, it involved a true in depth knowledge of the subject which he certainly has - I was very impressed and a little overawed, I thought I was getting to know Linux until I 'spoke' to him!

Edited by viking777

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...