Jump to content

Recent cooker kernel sources


Recommended Posts

Arrived this morning for me (about a fortnight after the kernel!!) (assuming you are talking about kernel 2.6.29-desktop586-0.rc5.1mnb).


I have never booted it before because I have never been able to compile the Nvidia driver (dkms one didn't work - very rarely does with new kernels on cooker). One thing I have noticed already with it is that it wont compile the vboxdrv module either - it tries on every boot but fails each time.

Link to comment
Share on other sites

OK here we go then. I have just installed:




I also have:




















But I have no graphics because I do not have any kernel-headers for this kernel, but even when I do, dkms will not compile the Nvidia driver for me, I will have to do it myself, I know this from past experience as recent as today. For a long time now I have had:




on my system along with all the other related packages that I have listed above, but I could never boot it because I didn't have the kernel-headers package, that only arrived today, as soon as it did I installed it and tried to boot - it failed. I install the Nvidia drivers myself and it works, but never with dkms.


It is only Cooker that behaves this way, 2009.0 is fine with dkms.


So you are absolutely right that Nvidia is supposed to compile with the 'kernel-devel' package, but it never does, at least not for me, I always have to have the 'headers' package as well and even then dkms won't do it (on Cooker).


I don't know if this is how it is supposed to work, but it is how it works for me.

Link to comment
Share on other sites

I'm looking for the -source- packages, not just devel (needed to recompile the kernel). Still wondering why they are there for some flavours but not for standard 2.6.29.x ...



Arrived this morning for me (about a fortnight after the kernel!!) (assuming you are talking about kernel 2.6.29-desktop586-0.rc5.1mnb).


I was referring to the kernel-source packages in that quote (then I got sidetracked into talking about -devel pacakages). Long and short of it the kernel-source packages for kernel 2.6.29.x are already there, have been since Mar 1st.

Link to comment
Share on other sites

Scoonma, sorry it has taken me so long to reply to this post. I log on to MandrivaUsers.org every day and use the 'view new posts' link, but it didn't show up. I do wish they had a 'view your posts' link like many other forums but they don't so I have only just found your question.


Even now I am finding difficulty answering it.


rpm -qa | grep kernel-source


So you see it is installed. But:


urpmq --sources kernel-source-2.6.29-0.rc5.1mnb-1-1mnb2
No package named kernel-source-2.6.29-0.rc5.1mnb-1-1mnb2


Says otherwise?????


All my main sources seem to consist of this:




and my plf sources of this:




It must be in there somewhere, but I don't know where. I am sure there is some clever command line way to ascertain where it came from but it is not obvious to me.

Link to comment
Share on other sites

Thanks Ken - I just picked that up myself. However - yet again it failed to install properly. This has happened on every kernel update that I have done since since I first installed Cooker I think (my memory is not that good!). In Cooker I don't mind because it is a testing distro, but the worrying thing is that the last time I did a kernel update on 2009 it happened with that as well.


The sequence of events is this:


Kernel update shows up in urpmi. I specifically checked this time and it included the kernel-desktop-devel files.


I update and all proceeds normally.


I reboot and I am in a shell - always.


I now know that the reason I am in a shell is that the kernel-devel files have not been installed - I install them with urpmi from the shell and reboot.


I am back in the shell. This time the reason is that the Nvidia drivers have not been installed.


I install an Nvidia driver myself (I keep the package in my home folder now as this occurs so often) reboot and at last I have a desktop.


That is the Nvidia side of things. The Virtualbox side of things I have never got working. The boot process always gets interrupted for about 30 seconds whilst the dkms module attempts to install vboxdrv, but it always gives up and fails. It is exactly the same from a terminal


Stopping VirtualBox kernel module							   [  OK  ]
Recompiling VirtualBox kernel module							[FAILED]


The rest of the story is in this post here: https://mandrivausers.org/index.php?showtopic=80724


It has certainly been like this for the last three kernels, probably longer. It isn't a great deal for me, I don't use Vbox all that much and I can just run it from another distro if I want it, but if 2009.1 is supposed to be at the RC stage, I think it is a pretty fundamental problem to still have - it doesn't bother me, but it will bother other people.

Edited by viking777
Link to comment
Share on other sites

Every time you install a new kernel and then select to boot into it, you must expect to reinstall the video driver even though you are not changing the driver.

Hence when you reboot you come up to a terminal. xorg.conf has had the driver listed as nvidia but at this stage the nvidia driver is no longer actually installed so you have two choices.


1. If you are using the proprietary nvidia driver then you can reinstall it as this point and reboot ( which is the simplest ).


2. If you are using the Mandriva nvidia driver then you need to get into Mandriva first. (This is the method I use but others may have easier or simpler methods. If so then please offer them but don't be critical of mine).

I use the terminal (console) that I have come to here and go root. then I type in ..........<vim /etc/X11/xorg.conf>........press enter. I look for the nvidia driver line then I press the <i> key and use the arrow keys to the end of the word "nvidia" and use the back space key so it now reads "nv" only.

Press the Esc key then type .........:wq.........and then enter . If you then type reboot and press enter you will boot into your account as normal and using MCC you can do your Mandriva nvidia driver reinstall no trouble.


I might add that I never have troubles regarding newer kernels released via updates and I run this routine each and every time. I learned long ago that installing kernels from cooker is not really worth the effort for just normal computer usage. Kudos to those that do so for experimental purposes for without you there would not be the debugging that we all benefit from.


Cheers. John.

Link to comment
Share on other sites

I do wish they had a 'view your posts' link like many other forums but they don't so I have only just found your question.

Click on a viking777 link (or anybody else's for that matter). If this takes you to the member's profile, select Options - Options - Find member's posts. If the link is attached to a post, you can go straight to Find member's posts... :)

Link to comment
Share on other sites

Hey John Good to hear form you again.


I think I get what you are saying which is that you have to install nvidia every time, you do it via the 'nv' driver I do it direct from the terminal - no real difference there. Thing is though dkms is supposed to take care of this automatically, but it isn't on Cooker and hasn't been for a long time. Not only is it not taking care of Nvidia but it is not taking care of vbox either, ie it is constantly failing to do anything.


But here is the latest. This morning I had a working system with the kernel-desktop586-2.6.29-0.rc7.4.1mnb-1-1mnb2 (except for vbox). I went away to another distro then came back and kernel-desktop586-2.6.29-0.rc7.4.1mnb-1-1mnb2 is useless. No compositing, no window borders, window tweaks menu inaccessible - just useless.


So, I reboot into kernel-desktop586-2.6.28-2mnb-1-1mnb2, which I have been using for ages, and what happens - no graphics! This kernel (apart from vbox) has been working perfectly up till now, I haven't altered anything in it but now I have to reinstall the Nvidia drivers yet again - WIHIH??


At the present moment in time Mandriva Cooker has become so unstable it is virtually unusable, it is even worse than Opensuse and that is saying something. I have stopped using Mandriva as my default distro these days because of this instability which seems to be creeping into 2009 as well. I would love for it to work properly again (2008.1 was the best - it broke my heart to uninstall that) but 2009 doesn't deliver any more. I will stick with it, but only in a secondary role, it is no longer good enough to be a first choice distro. Sad but true.


EDIT. I open it up today (2.6.28 kernel), do a urpmi auto-update and it threatens to remove the whole of xfce4 due to various unsatisfied dependencies. I am not going to let it do it of course, but it is just an illustration of how bad things have got right now. I go back into the 2.6.29 kernel and the graphics have gone completely - again! Then whilst I am posting this the Mandriva bug report tool pops up to tell me that mdkapplet has crashed and would I report a bug. When I try to do that I get:


The requested URL's length exceeds the capacity limit for this server


See what I mean?

Edited by viking777
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...