Jump to content
Sign in to follow this  
IcoBgr

Kernel-desktop does not recognize 4Gb RAM

Recommended Posts

Hi,

Ihave bought onother 2Gb RAM and now I have 4 Gb RAM. I put them in Dual Chanel Mode. After that when I boot my Mandriva 2009.0 I found out that it detecs 2,72Gb RAM instead of 3,7Gb.

I installed kernel-server and there I do not have this problem. With kernel-server I got 3,7Gb RAM. Why is this? Any idea why my kernel-desktop do not recognize correctly my RAM? I tried with reinstall of the kernel-desktop but this did not help.

 

Best regards,

Hristo

 

 

[moved from Software by spinynorman]

Share this post


Link to post
Share on other sites

Mandriva has several kernel ‘flavours’.

 

‘desktop’ supports any i686 or later CPU, and up to 4GB of memory.

‘desktop586′ supports any i586 or later CPU, and up to 1GB of memory.

‘laptop’ supports any i686 or later CPU, up to 4GB of memory, and has tuning for better power consumption on laptops.

’server’ supports any i686 or later CPU, and up to 64GB of memory. it has some tuning appropriate for server use.

 

So basically, desktop should detect it all immediately. :huh:

 

Similar topic: https://mandrivausers.org/index.php?showtop...ernel+recognize

Share this post


Link to post
Share on other sites

Yep, what arctic said. You need kernel-desktop- not kernel-desktop586-

 

BTW kernel-laptop has been dropped starting from 2009.0 . All the tweaks it offered have been either integrated in kernel-desktop or discarded as they were not important any more.

Share this post


Link to post
Share on other sites

Ah, not so fast, boys. :)

 

It's actually normal that kernel-desktop won't detect all of 4GB of RAM.

 

What it can actually handle is all RAM in the address space from 0GB to 4GB.

 

Thanks to the vagaries of the PC architecture, on a system with 4GB of RAM, quite a lot of it winds up in the address space above 4GB. This is because there are various 'holes' between 0 and 1GB for all sorts of ancient and arcane reason. Bottom line is, on any OS kernel which can only detect up to the 4GB address space limit, you won't see all of 4GB if the system has it installed. Exactly how much you see depends on several factors, especially your video card.

 

This is explained in more detail by Dan of Dan's Data here:

 

http://www.dansdata.com/askdan00015.htm

 

But note that Dan doesn't consider the possibility of a 32-bit kernel capable of supporting 64GB of RAM, because there is no such thing in the Windows world. In the Linux world, there is.

 

but the bottom line, this is normal and expected. To access all 4GB you need a 64GB kernel, like kernel-server.

 

if you're running the x86-64 edition of Mandriva, BTW, there's no such limitation. The -desktop kernel in the x86-64 edition can address waaaaaaaaaaaaaaaaaaaay more than 4GB of RAM.

Edited by adamw

Share this post


Link to post
Share on other sites

This is normal, and it has nothing to do with Mandriva (or any OS installed). It's a hardware limitation for 32-bit architecture. I think adamw explained the stuation quite sufficiently.

Share this post


Link to post
Share on other sites

Something weird. I now have a total of 4 GB RAM on my system, but only 3.2 GB are recognized. I tried installing kernel-server-latest and after booting into it, I still can only see 3.2 GB RAM (exactly the same amount). I don't have onboard video, and my 8600 GT should have more than enough memory.

 

Wondering what the hell could be the cause of this. I've checked my BIOS for settings in relation to this, but to no avail.

Share this post


Link to post
Share on other sites
Something weird. I now have a total of 4 GB RAM on my system, but only 3.2 GB are recognized. I tried installing kernel-server-latest and after booting into it, I still can only see 3.2 GB RAM (exactly the same amount). I don't have onboard video, and my 8600 GT should have more than enough memory.

 

Wondering what the hell could be the cause of this. I've checked my BIOS for settings in relation to this, but to no avail.

 

You have to enable PAE in your BIOS.

This will, most of the times, decrease the system performance, so (IMHO) you should do better leaving things as-they-are.

Share this post


Link to post
Share on other sites

I've scoured my BIOS setup 3 times and have found no option for that. I fear Dell has removed the capability to enable this. I do remember on a previous Windows installation on this machince, I had enabled PAE, but it was via windows, not my BIOS (obviously). It's not a huge deal, however, as you've stated about the decrease in performance.

Share this post


Link to post
Share on other sites

You shouldn't need to enable PAE in your BIOS. I never had to do this when I put Debian x86_32 on my laptop. It's just finding a kernel that has PAE enabled in it that should get you working.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...