Jump to content
Sign in to follow this  
Guest akh

sound and isdn card on mandrake 9.1

Recommended Posts

Guest akh

Hello everyone.

I'm a linux newbie who has just recently installed mandrake 9.1. The problem I have is to make it recognize my sound card (creative sound blaster live) and my isdn card (eicon diva 2.02 PCI)

I've been searching the forums/web for solutions, but nothing I've tried has helped.

When it comes to the sound card: I got an error message saying: "error while initializing the sound driver. device/dev/dsp can't be opened (ls a directory)" That's when I log in as user. Then I tried log in as root, and run the artswrapper-thing. No go (couldn't find the dev/dsp)

I restarted and got the message (as root) "cpu overload" :shock:

One of the things I've tried was to modify the modules.conf. (think I found it on this forum)

 

Second problem: the isdn card. When I go to harddrake, it's listed there (as network_other) but when I try to set it up with drakconnect, it's not discovered. :(

 

Help!

Share this post


Link to post
Share on other sites

What kind of mb do you have? Are you setting up your pci slots in the bios, and is plugnplay turned off?

 

Questions, questions, questions :wink:

Share this post


Link to post
Share on other sites
Guest akh
What kind of mb do you have? Are you setting up your pci slots in the bios, and is plugnplay turned off?

 

Questions, questions, questions :wink:

 

 

And tough ones too... :oops:

 

when you say mb, what do you mean then? no, I have not done anything in bios, and I'm not sure wether plugnplay is turned off or not. (how do I check that?) I'm totally new to this, so bear with me. :?

Share this post


Link to post
Share on other sites

mb=motherboard (aka mainboard, but not known as fatherboard)

Share this post


Link to post
Share on other sites

Also known as mobo! :lol:

 

How about telling us what brand or model the computer is. I'm thinking since your sound card should auto configure, (I have the same one!) some bios adjustments will get you going. With the info, I can give you specific instructions!!

Share this post


Link to post
Share on other sites
Guest akh

I've been using sisoft sandra to find the settings and this is the mainboard info (is that what you need?)

model: dell computer corp 82850 (850) processor to I/O controller (MCH)

processor: intel pentium 4 CPU 2,40GHz

system bios: AT/AT compatible

version: dell -8

plugnplay version: 1.00

Share this post


Link to post
Share on other sites

nope....a google advanced for a Dell 82850

Your search - "Dell 82850" - did not match any documents.

 

Look in the Device Mgr. for info.

Share this post


Link to post
Share on other sites
Guest akh
nope....a google advanced for a Dell 82850
Your search - "Dell 82850" - did not match any documents.

 

Look in the Device Mgr. for info.

 

I went to bios to see, and it said: Dell Dimension 8250 series

Bios version A01

Does that help?

Share this post


Link to post
Share on other sites

Yes, a dell demension 8250 series does help. Next step is to get into the bios, and find the page that has the settings you want to look at. I'm going to look at thedell sight for the bios info.

Share this post


Link to post
Share on other sites

Dell is not very helpful

 

When yopur computer boot, during the dell splash screen, hitting F1 or F2 should get you into the bios. I think they call it a setup screen. Scroll down to the pci section, hit enter, and look yo see if you can turn off plug n play in there. While you're there, see if you can configue the pci slots (the places where your nic and sound card are) for specific irq's. I know this may not be very understandable, but setting the bios away from automatic will enable linux to utilize the configuration, even if pnp is still running.

Share this post


Link to post
Share on other sites
Guest akh
Dell is not very helpful

 

When yopur computer boot, during the dell splash screen, hitting F1 or F2 should get you into the bios. I think they call it a setup screen. Scroll down to the pci section, hit enter, and look yo see if you can turn off plug n play in there. While you're there, see if you can configue the pci slots (the places where your nic and sound card are) for specific irq's. I know this may not be very understandable, but setting the bios away from automatic will enable linux to utilize the configuration, even if pnp is still running.

 

I checked some of those settings before I went to the pub tonight.

creative IRQ 9

EICON IRQ 11

 

I'll turn off plug n play for my next boot.

 

 

edit: to drunk to do anything right now..:wub:

Share this post


Link to post
Share on other sites

That's what I thought. Dell writes their bios for windex. If you confiure your pci slots, that is, assign specific irq's to the slot, then linux should configure it. Linux uses the bios for this, and pnp allows windex to do what it wants. (Windex is actually trying to eliminate the bios! :shock: )

 

Pay attention to the irq being used for your video card or on-board video chip. You do not want conflicts with these items in you configuration. I use irq 5 for network, irq 7 or 9 for audio, (7 is also used for printing!) and 11 for vidoe. It doesn't have to be this way, but that is what I do.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...