Jump to content

configuring wireless cards

Guest LordGrahf

Recommended Posts

Maybe check dmesg and see if it shows anything like that. Also do


cat /var/log/boot


and see if you can scroll back and see if there were any errors right around those times. One thing you can try is to make a backup copy of /etc/hotplug/net.agent and of /etc/rc.d/init.d/network and then do my hack to get mine to work:


In /etc/hotplug/net.agent, I did this:

#     if [ "$AUTOMATIC_IFCFG" != no -a "${INTERFACE:0:3}" == "eth" -a ! -r $CFG ]; #then

#  if [ -r $PCMCIA ] && grep -q "$INTERFACE$" $PCMCIA; #then

#      ONBOOT=no

#  else

#      ONBOOT=yes

#  fi

#  debug_mesg creating config file for $INTERFACE

#  cat > $CFG <<EOF





#            fi

#     if [ -r $CFG ]; then

 # Mandrake Linux and similar

#  if [ "${INTERFACE:0:3}" == "eth" -a -x /sbin/ifplugd ] && ! grep -q '^MII_NOT_SUPPORTED' $CFG; #then


#      debug_mesg invoke ifplugd $INTERFACE

#      exec /sbin/ifplugd $IFPLUGD_ARGS -i $INTERFACE >/dev/null

#  fi


I just commented out all the stuff pertaining to ifplugd. /etc/rc.d/init.d/network was slightly more difficult:


I changed this:

  if  [ "${DEVICE:0:3}" != "eth" -o ${DEVICE/:/} != ${DEVICE} -o ! -x /sbin/ifplugd ] || grep -q '^MII_NOT_SUPPORTED' ifcfg-$i; then

     action "Bringing up interface %s: " $i ./ifup $DEVICE boot



     action "Bringing up interface %s: " $i /sbin/ifplugd $IFPLUGD_ARGS -i $DEVICE



if  [ "${DEVICE:0:3}" != "eth" -o ${DEVICE/:/} != ${DEVICE} -o ! -x /sbin/ifplugd ] || grep -q '^MII_NOT_SUPPORTED' ifcfg-$i; then

     action "Bringing up interface %s: " $i ./ifup $DEVICE boot



     action "Bringing up interface %s: " $i ./ifup $DEVICE boot



See if that solves your problems.

Link to comment
Share on other sites

  • Replies 31
  • Created
  • Last Reply

Top Posters In This Topic

If Steve's suggestion doesn't work (and how you figured that out Steve, I may never know but bravo)


You might want to try adding:


INFO="[provide some info about your card here]"

ESSID="[provide your network name here]"

MODE="[managed or automatic]"

KEY="[if you use encryption, provide your key here]"

to your /etc/pcmcia/wireless.opts file. The default should be in there already and should work, the very top line works with my card, but there is a default there that should work for any card. You might need to reconfigure some other options in there.


Also, try removing the options you put in for the card in /etc/pcmcia/config, turn the laptop off and put the card back in, boot up the laptop and put the stuff back in to that file but before you reboot, go into MCC -> Hardware and scan for new hardware to see if the card is there. If so, follow the instructions in my tutorial on how to configure it. See what happens and let us know.

Link to comment
Share on other sites

If Steve's suggestion doesn't work (and how you figured that out Steve, I may never know but bravo)...


It actually wasn't that difficult. Once I got lucky enough to see the text output of the kernel Oops, I knew it was ifplugd causing the problem. I already knew that /etc/hotplug/net.agent had something to do with the network card from my logs. I then looked in /etc/rc.d/init.d and saw a network script which I knew had to have reference to ifplugd also. Then, shell scripts aren't that hard to read if you have a little knowledge of other programmings languages and I could tell in /etc/rc.d/init.d/network that there was one section to execute with ifplugd under certain circumstances and one section to execute with ifup, so I just changed the ifplugd section to match the ifup one.


I would love to know if this works for LordGrahf.

Link to comment
Share on other sites

Sorry to drop in suddenly, but since this is about configuring wireless cards and this post seems done, I figured no need to start a new post.


I got an Intel Pro/Wireless 2011B PCMIA card on my laptop, which should work. However, it doesn't and I think this is because of the Wireless encryption going on: 128-bits Wep encryption.

Link to comment
Share on other sites

Is the card working? Can you boot into X with it in? Just trying to figure out a bit so we can jump in for assistance.


I will assume you're using Mandrake 9.1 and have followed my tutorial to get everything set up. The 128-bit WEP encryption is controlled by a password that is set up on your Access Point, Router, or other means of connecting to a wireless network. If you to to MCC -> Hardware -> HardDrake you will be able to configure the wireless card under Network Adapters. There is a section in there that lets you choose either Managed or Automatic for your network. If there is no password (common here in the states for open access networks on college campuses, at least it is for my school) then choose Automatic. If there is a password, you will need to choose Managed and provide that password in one of the feilds supplied. I'm not sure which, but if you can't get it from there I will look on my laptop to see.


Hope that helps you out. Let me know if that's not your problem, or something else isn't working.

Link to comment
Share on other sites

Jay, got it working! :D


My card and everything were actually working, I just had to choose "Managed" and type in the key in 1 of the fields.


I'm feeling a bit st*pid. I never had to deal with the encryption stuff, 'cause the wireless home-network was set up FOR us...



Anyway, thanks a lot. Now I have a really cool laptop (Compaq 1400 - nice design) with a really cool OS and wireless network access, which makes it even cooler. 8)


These Forums/this website is great, there are so much info and apps (FTP server) and friendly people together here. It makes a world of difference!




Link to comment
Share on other sites

Guest LordGrahf

who said the discussion's over, it ain't over yet :)

its been a while since I was able to access my laptop, I really do appreciate all of your help so far.

I've tried to modify the files you've pointed out, but still it didn't do any difference.

the weird thing though, when I tried to check my /var/log/boot.log file, I saw this

pcmcia: Starting PCMCIA services:

Jul  6 23:18:44 ip68-100-3-134 pcmcia: cardmgr[899]: error in file 'config' line 981: syntax error

Jul  6 23:18:44 ip68-100-3-134 pcmcia: cardmgr[899]: watching 1 sockets

Jul  6 23:18:45 ip68-100-3-134 pcmcia: done.

Jul  6 23:18:45 ip68-100-3-134 rc: Starting pcmcia:  succeeded

Jul  6 23:18:45 ip68-100-3-134 portmap: portmap startup succeeded


so I went to /etc/pcmcia/config and check line 981, and here's what its saying

card "Compaq HNW-100 11 Mbps Wireless Adapter"

 manfid 0x028a, 0x0002

 bind "orinoco_cs"file:/usr/share/doc/HTML/index.html (this is line 981)


this was under #Wireless, the werid thing is that it's not the card I'm using!

Link to comment
Share on other sites



out of that file. That's really strange that it's even there, but that's obviously an error.


Could you send me your /etc/pcmcia/config file? I want to try something for you, but I need to see the file since I don't have access to my laptop at work.

Link to comment
Share on other sites

  • 2 weeks later...
Guest LordGrahf

back again,

the problem with my card made me think that there might be something wrong with the card itself, so I installed WinXP back just to check if the card is working or not. I must say that if windows is good with anything it would be hardware detection, the card worked perfectly fine from the first boot.

anyways, I'll send a copy of my /etc/pcmcia/config to you liquid, I hope you'll find something.

I've checked my kernel by going to Configuration->KDE->system->Linux Kernel , and I've found this on the main screen of the program


The kernel configuration could not be read due to the following error:

/usr/src/linux/drivers/net/Config.in, line 193:

define_mbool CONFIG_EEPRO100_PIO y

         ^ parse error

Either your kernel sources contain invalid configuration rules or you just found a but in the KDE Kernel Configuraton.


I'm not sure if this is affecting anything. Does anyone know what is causing that parse error?


I also forgot to tell you that I enable ACPI at booting (from Grub) because if I don't do so my computer freezes at the exact same place whether I plug in the card or not.

Link to comment
Share on other sites

Ok, one question for you. I have reviewed your /etc/pcmcia/config file line by line with mine, and I have some options in there that you don't. Strange, but I don't think that is the root of your problem. Another question I have is: What are you using for internet access for this card? What kind/brand/model of router or access point do you have? I am still working through your files to see if I can get something that will work for you, but this question I have is important for when we do get this working.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...