Jump to content
Sign in to follow this  
liquidzoo

NVidia TwinView [solved]

Recommended Posts

Ok, I have both of my monitors working, but I want twinview working to where the monitor on the left is the main monitor and the one on the right is there as extra space. That's the best I can describe it. Currently it's one big monitor (2560x1024) but I want them to act separately, yet still be able to drag across to the other one.

 

Does that make sense?

 

I know this works, I've had it working in both Sabayon and Mandriva, I just can't seem to get the same method working in Gentoo. Here is my xorg.conf file, any help would be greatly appreciated.

 

Section "ServerLayout"
Identifier	 "Layout0"
Screen	  0  "Screen0" 0 0
InputDevice	"Keyboard0" "CoreKeyboard"
InputDevice	"Mouse0" "CorePointer"
EndSection

Section "Files"
RgbPath		 "/usr/lib64/X11/rgb"
FontPath		"/usr/lib64/X11/fonts/local/"
FontPath		"/usr/lib64/X11/fonts/misc/:unscaled"
FontPath		"/usr/lib64/X11/fonts/100dpi/:unscaled"
FontPath		"/usr/lib64/X11/fonts/75dpi/:unscaled"
FontPath		"/usr/lib64/X11/fonts/misc/"
FontPath		"/usr/lib64/X11/fonts/Type1/"
FontPath		"/usr/lib64/X11/fonts/CID/"
FontPath		"/usr/lib64/X11/fonts/Speedo/"
FontPath		"/usr/lib64/X11/fonts/100dpi/"
FontPath		"/usr/lib64/X11/fonts/75dpi/"
FontPath		"/usr/lib64/X11/fonts/cyrillic/"
FontPath		"/usr/lib64/X11/fonts/TTF/"
EndSection

Section "Module"
Load		   "dbe"
Load		   "extmod"
Load		   "type1"
Load		   "freetype"
Load		   "glx"
EndSection

Section "ServerFlags"
Option		 "Xinerama" "0"
EndSection

Section "InputDevice"

# generated from data in "/etc/conf.d/gpm"
Identifier	 "Mouse0"
Driver		 "mouse"
Option		 "Protocol" "auto"
Option		 "Device" "/dev/input/mice"
Option		 "ZAxisMapping" "4 5 8 9"
Option		 "ButtonMapping" "1 2 3 6 7 10 11"
EndSection

Section "InputDevice"

# generated from default
Identifier	 "Keyboard0"
Driver		 "kbd"
EndSection

Section "Monitor"

# HorizSync source: edid, VertRefresh source: edid
Identifier	 "Monitor0"
VendorName	 "Unknown"
ModelName	  "LG L1732TQ"
HorizSync	   30.0 - 83.0
VertRefresh	 56.0 - 75.0
Option		 "DPMS"
EndSection

Section "Device"
Identifier	 "Videocard0"
Driver		 "nvidia"
VendorName	 "NVIDIA Corporation"
BoardName	  "GeForce 7600 GS"
EndSection

Section "Screen"
Identifier	 "Screen0"
Device		 "Videocard0"
Monitor		"Monitor0"
DefaultDepth	24
Option		 "TwinView" "1"
Option		 "MetaModes" "1280x1024, 1280x1024; 1280x1024, 1280x1024"
SubSection	 "Display"
	Depth	   24
Modes	  "1600x1200" "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "Extensions"
#Option "Composite" "Enable"
EndSection

 

 

[moved from Hardware by spinynorman]

Share this post


Link to post
Share on other sites

run nvidia-settings as root?

 

worked for me .. I can post my xorg.conf tomorrow when I'm back at work

Share this post


Link to post
Share on other sites

I did that, same result. I get a taskbar that stretches across both monitors, instead of just one of them, and applications that open up in the middle.

Share this post


Link to post
Share on other sites

I remember seeing some options for that in kcontrol -> peripherals -> display, but now I can't see it. Maybe it's only visible if you have more than one screen connected (I had that before).

Share this post


Link to post
Share on other sites

I saw that too, but it doesn't give me the options I'm looking for.

 

I may make a partition and install Mandriva, just to get that part working, then copy the xorg.conf file over to gentoo and see if that fixes my issue.

 

It might.

 

That is, if I can't figure it out beforehand.

Share this post


Link to post
Share on other sites

You need two have to entries in your xorg.conf, one for each monitor, and then configure server layout properly. you actually don't want twinview, as the point of twinview is to treat two monitors as one large screen.

 

Read this, and look at Appendix P of the nvidia README - that should get you started.

Edited by tyme

Share this post


Link to post
Share on other sites

I will take a look and see if I can get it working.

 

Funny thing is, that xorg.conf file that I posted above is the one from Sabayon, that this was working on. I wondered if I needed 2 monitor entries, though, and I'm not sure how it's going to work with both monitors being identical.

Share this post


Link to post
Share on other sites
Funny thing is, that xorg.conf file that I posted above is the one from Sabayon, that this was working on.
*shrug*, everything I read seems to indicate that you twinview will always treat both monitors as one large desktop.

 

 

I wondered if I needed 2 monitor entries, though, and I'm not sure how it's going to work with both monitors being identical.
It shouldn't make a difference. You just might have to take a second to figure out which is monitor 0 and which is monitor 1, so that you can set the up correctly with rightof or leftof (i think those are the proper keywords) in your server layout.

 

I just remember trying to do this same thing years ago and I could not for the life of me get twinview to do it, and i finally figured out it's because what I wanted to do was not what twinview was intended to do.

Share this post


Link to post
Share on other sites

It could also be that gentoo is reading the variable in a different manner than Mandriva and Sabayon were for some odd reason. It shouldn't, but you never know.

 

I know that in some programs I write code for 1 = True, and others -1 = True and anything else is False.

Share this post


Link to post
Share on other sites
# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 1.0  (buildd@vernadsky)  Tue Mar  4 20:24:34 UTC 2008

# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "ServerLayout"
Identifier	 "Default Layout"
Screen	  0  "Screen0" 0 0
EndSection

Section "Module"
Load		   "glx"
EndSection

Section "ServerFlags"
Option		 "Xinerama" "0"
EndSection

Section "InputDevice"
Identifier	 "Generic Keyboard"
Driver		 "kbd"
Option		 "XkbRules" "xorg"
Option		 "XkbModel" "pc105"
Option		 "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier	 "Configured Mouse"
Driver		 "mouse"
Option		 "CorePointer"
EndSection

Section "Monitor"
Identifier	 "Configured Monitor"
EndSection

Section "Monitor"
Identifier	 "Monitor1"
VendorName	 "Unknown"
ModelName	  "CMO CMC 17"
HorizSync	   30.0 - 82.0
VertRefresh	 56.0 - 76.0
EndSection

Section "Monitor"
Identifier	 "Monitor0"
VendorName	 "Unknown"
ModelName	  "Philips 190P"
HorizSync	   30.0 - 82.0
VertRefresh	 56.0 - 76.0
EndSection

Section "Device"
Identifier	 "Configured Video Device"
Driver		 "nvidia"
Option		 "NoLogo" "True"
EndSection

Section "Device"
Identifier	 "Videocard0"
Driver		 "nvidia"
VendorName	 "NVIDIA Corporation"
BoardName	  "GeForce 8400 GS"
EndSection

Section "Device"
Identifier	 "Videocard1"
Driver		 "nvidia"
VendorName	 "NVIDIA Corporation"
BoardName	  "GeForce 8400 GS"
BusID		  "PCI:1:0:0"
Screen		  1
EndSection

Section "Screen"
Identifier	 "Default Screen"
Device		 "Configured Video Device"
Monitor		"Configured Monitor"
DefaultDepth	24
EndSection

Section "Screen"
Identifier	 "Screen1"
Device		 "Videocard0"
Monitor		"Monitor1"
DefaultDepth	24
Option		 "TwinView" "0"
Option		 "metamodes" "CRT: nvidia-auto-select +0+0"
EndSection

Section "Screen"

# Removed Option "TwinView" "0"
# Removed Option "metamodes" "DFP: nvidia-auto-select +0+0"
# Removed Option "metamodes" "CRT: nvidia-auto-select +0+0, DFP: nvidia-auto-select +1280+0"
Identifier	 "Screen0"
Device		 "Videocard0"
Monitor		"Monitor0"
DefaultDepth	24
Option		 "TwinView" "1"
Option		 "TwinViewXineramaInfoOrder" "DFP-0"
Option		 "metamodes" "CRT: nvidia-auto-select +0+88, DFP: nvidia-auto-select +1280+0"
EndSection

post-3-1212613972_thumb.png

Share this post


Link to post
Share on other sites

Looks like I may just need to add another Monitor section and the relevant screen section to my xorg.conf file, but that is exactly what I want to do, paul, thanks.

 

Well, flip it so the left monitor is the primary, but I can figure out how to do that :P

Share this post


Link to post
Share on other sites

maybe my old post here is worth a look. i don't know if it'll work in gentoo. seems like it will as nvidia driver and xorg seem similiar.

 

i do mine a little different but it has all the features, drag windows, seperate backgrounds thru kde control center. 2nd screen defaults to right of, so it isn't necessary to specify in xorg.

 

i just add 3 lines to my xorg.

in the Section "Device"

Option "TwinView"

Option "MetaModes" "1600x1200, 1600x1200" (yours should say "1280x1024, 1280x1024")

 

in the Section "Screen" Subsection "Display" at the default depth or all depths

Virtual 3200 1200 (yours should say Virtual 2560 1024)

 

http://img386.imageshack.us/my.php?image=m...014jun08mx9.jpg

http://img386.imageshack.us/my.php?image=m...034jun08xc9.jpg

Edited by cybormoron

Share this post


Link to post
Share on other sites

If a mod would please mark this as [solved] I would appreciate it.

 

A quick search of the gentoo forums gave me a topic with this exact issue (well, he was using Gnome, but same issue nonetheless).

 

After adding xinerama to my make.conf USE flags, I recompiled KDE

 

emerge -DuN kde

 

And without changing my xorg.conf file at all, everything is working the way I want.

 

Hopefully this helps someone else too. I'll post screenshots when I get home from my sister-in-law's wedding next week.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...