Jump to content

startx fails to start [solved]


Recommended Posts

I borked my system. :wall: I had way too many kernels installed, and decided to clean things up a little. Well, I cleanded it up and removed my Nvidia driver module.


I can boot to a command prompt, and from what I can tell, the rest of the system is intact.


If I run startx, it fails with the following error;


Could not open /lib/modules/, no such file or directory.


The path is there, just no nvidia96xx.ko.gz file.


How do I figure out what package that file is in? If I could answer that, I could use URPMI to install the missing package.


I looked at the log file and saw nothing unusual, other than the file is missing.


This is Mandriva - One 2008 free.


FWIW, uanme -a reports - rest


Linux duelie #SMP.... The rest is hardware info.

This is a 32 bit system, not 64bit.



[moved from Software by spinynorman]

Link to comment
Share on other sites

Thanks guys, I used input from both of you to fix it. To fix it I,


1. ran urpmi dkms-nvidia ; this found 3 packages I had removed. I instlled them.


2. At this point startx didn't work. Now I edited xorg.conf, and changed 'nvidia' to 'vesa' Tried startx, got a blue screen for about 30 seconds, but no desktop.


3. Ran XFdrake as root, picked the proprietory driver. Did a startx and presto, it all works.


Thank-you! :D

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...