Jump to content

4GB Ipod Nano


Recommended Posts

Hey guys, my daughter just got a 4Gb Ipod Nano. Unbeknownst to me you can't just plug it in and drop some tunes onto it like with my Creative MP3 player. It wants to use Itunes. I checked Apple's site but they only have Windows versions. I do have a Win2k partition but her Ipod is new and it requires Itunes 7.4 to run and Apple discontinued Win2k support with version 7.3x ... this means I need to get her Ipod up and running from scratch on Linux.


I searched around and found an app that replace Itunes, called Banshee http://www.banshee-project.org/Main_Page


Anyone use this and if so can I setup my girls Ipod out of the box with it? If not does anyone have any advice for me?

Link to comment
Share on other sites

Banshee is pretty good and does an excellent job of handling iTunes databases. It should be good for setting up the iPod too. Is this the new iPod Nano with video support or the previous generation?


You could also set the iPod up on a friends Windows computer or Mac. As most Linux distributions now support HFS+ (the Mac filesystem) it doesn't matter which you use for Linux. But I'd go with whatever Banshee recommends.


The other option is gtkpod, but Banshee seems to have overtaken it in terms of features and reliability.

Link to comment
Share on other sites

I see, that makes sense now. So I do need to use Itunes to initially setup the Ipod then once that is done I can use Banshee to add content to it.


It is the new generation Nano with video support. Nice little unit. I was completely satisfied with my little Creative MP3 player till I started mucking around with this Ipod, mine seems like an old 8 track in comparision now = ]

Link to comment
Share on other sites

That is the third generation Nano, which is protected by Apple so you only can upload with itunes.

You can upload music with Amarok, GTKpod but the nano wan't play it. I've tried with my son and daughter there nano's.

In cooker is a new GTKpod with libgpod but you can find them also here

Link to comment
Share on other sites

As willie said, only the first generation iPODs will work (...and if you are smart enough, you will flash them with RockBox firmware).

On the second and third generations of iPOD Nano, Apple did anything possible to force you using just its iTunes crap, and nothing else than that. It even went on encrypting the device firmware...

Conclusion: With iPOD's, you have two viable solutions: either flash them, or flush them- whatever you can/prefer.

Edited by scarecrow
Link to comment
Share on other sites

Awesome guys thanks for the info. I used a friends pc and setup her Ipod then brought it to my pc and tried Banshee and Gtkpod but neither worked.


So I need to flash it? Can someone point me in the right direction for that? It is a 4GB Silver Nano the newer widescreen ones w/video support if that is relevent.


And Willie, thanks for the link to the libgpod app but I am running 2007.1 and those links are for 2008.1 :)

Link to comment
Share on other sites

gtkpod 0.99.12 (with libgpod 0.6.0) does work with current generation iPod Nanos, and I have been using it without issue for several months. You will need to set up your iPod's directories using gtkpod, and may need to modify its iPod_Control/Device/SysInfo file as detailed in the following readme contained in the libgpod 0.6 source file available from sourceforge.



Starting with the iPod Classics and the Video Nanos, libgpod needs an additional configuration step to correctly modify the iPod content. libgpod needs to know the so-called iPod "firewire id", otherwise the iPod won't recognize what libgpod wrote to it and will behave as if it's empty.


There are two ways to set up the iPod to make libgpod able to find its firewire id.


The 1st one is mostly automated. First, make sure you have libsgutils installed before running configure/autogen.sh. If you built libgpod without it, install it and run configure/make/make install. You should now have an ipod-read-sysinfo-extended tool available. Run it with the iPod device path (eg /dev/sda) and the iPod mount point (eg /mnt/ipod) as arguments. This may

require root privileges. ipod-read-sysinfo-extended will read an XML file from the iPod and write it as /mnt/ipod/iPod_Control/Device/SysInfoExtended. See http://ipodlinux.org/Device_Information for more details about the method used. Having that file is enough for libgpod to figure out the iPod firewire id.


The 2nd method requires more manual intervention. First, you need to get your firewire id manually. To do that, run "sudo lsusb -v | grep -i Serial" (without the "") with your iPod plugged in, this should print a 16 character long string like 00A1234567891231. For an iPod Touch, this number will be much longer than 16 characters, the firewire ID is constituted by the first 16 characters. Once you have that number, create/edit /mnt/ipod/iPod_Control/Device/SysInfo (if your iPod is mounted at /mnt/ipod). Add to that file the line below:


FirewireGuid: 0xffffffffffffffff


(replace ffffffffffffffff with the string you obtained at the previous step and don't forget the trailing 0x before the string). Save that file, and you should be all set. Be careful when using apps which lets you manually specify which iPod model you own, they may overwrite that file when you do that. So if after doing that libgpod still seems to write invalid content to the iPod, double-check the content of that SysInfo file to make sure the FirewireGuid line you added isn't gone. If that happens, readd it to the end of the file, and make sure libgpod rewrite the iPod content.


Once that is done, if you compiled libgpod from source, you can test that libgpod can find the firewire ID on your iPod by running libgpod/tests/test-firewire-id /ipod/mount/point

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...