Jump to content
hirohitosan

permissions

Recommended Posts

Hello to everyone!

I hope it's the right place for this question.

I tried to install Joomla on my web server :wall: . First I installed locally. For installing Joomla apache, php, mysql is needed. I installed all. After that joomla papackage must be ununpacked in the /var/www/http folder. Than an web installer tooks everything. When I installed locally I could open the web installer with a web browser (Mozilla), but when I tried to install on a remote server an error:

Access forbidden! 

You don't have permission to access the requested object. It is either read-protected or not readable by the server. 

Error 403 

Apache/2.2.6 (Mandriva Linux/PREFORK-8.1mdv2008.0)

I don't know how to overcame this. To be more specific. Why locally I can open with Mozilla /var/www/http/joomla/index.php and from another computer I get the error message?

 

Thanks

 

 

[moved from Software by spinynorman]

Share this post


Link to post
Share on other sites

Are you installing as root? From the commandline type: su now press enter, then input your root password and press enter again. To leave root mode type exit then press enter.

Edited by {BBI}Nexus{BBI}

Share this post


Link to post
Share on other sites
Are you installing as root?

yes. I logged with ssh, then su install everything, open Mozilla and the ERROR. I don't understand why it works on my local machine but remotely no.

Share this post


Link to post
Share on other sites

Make sure that the joomla directory is owned by apache:

 

chown -R apache:apache joomla

 

or wherever joomla is. And then try again. Either that, or apache has access list preventing external access other than localhost IP.

Share this post


Link to post
Share on other sites

Is your ssh server properly configured?

To install applications you either have to add the logged user to the "wheel" group, or allow root access (which is disabled by default). Su may look like working, but factly it isn't.

Checkout your sshd_config configuration file. Can you see something like

 

# Authentication:
#LoginGraceTime 2m
#PermitRootLogin yes
#StrictModes yes
#MaxAuthTries 6

 

If it's like that, uncomment the #PermitRootLogin yes line.

Share this post


Link to post
Share on other sites

If you haven't configured your sources, then do so via the Easy-Urpmi link. Then install joomla as root with: urpmi joomla

 

You may well get access denied when trying to complete the web based installation, here's how I did mine.

 

1. SSH into remote machine

2. Type: konqueror http://127.0.0.1/joomla

 

After a while the browser should open up and you can complete the installation. :)

Edited by {BBI}Nexus{BBI}

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...