Jump to content
Sign in to follow this  
Guest KShots

How to install two ethernet cards without X windows system?

Recommended Posts

Guest KShots

Wow, guys... Ok, yeah - I think I'll give that a try too. First I'll try leaving the cable modem plugged in for about an hour, then try the setup again, see if that changes anything. Thanks! I'm sure that this thing will be up and running soon now!

 

EDIT: I was looking at that last link you gave me, MOttS, and was surprised to find under my /etc/sysconfig/network-scripts two more files than I was expecting:

ifcfg-eth0

ifcfg-eth0 (using module ne)

ifcfg-eth1

ifcfg-eth1 (using module eepro)

... I wonder if this is confusing things?

(I'm really hoping to read a message from you stating: hey, writing this from a linux machine connected to my inet server...  )
You most definately will get such a post when I'm up and running :D

Share this post


Link to post
Share on other sites
EDIT: I was looking at that last link you gave me, MOttS, and was surprised to find under my /etc/sysconfig/network-scripts two more files than I was expecting:
ifcfg-eth0<!--QuoteEBegin--><!--QuoteEBegin-->ifcfg-eth0 (using module ne)<!--QuoteEBegin--><!--QuoteEBegin-->ifcfg-eth1<!--QuoteEBegin--><!--QuoteEBegin-->ifcfg-eth1 (using module eepro)

... I wonder if this is confusing things?

I have no idea. I only have two.. Look at mine:

[gd@localhost gd]$ ls -l /etc/sysconfig/network-scripts/

total 168

-rw-------    1 root     root         2977 avr 21 11:30 drakconnect_conf

-rw-------    1 root     root         2977 avr 21 11:30 drakconnect_conf.default

-rwxr-xr-x    1 root     root          117 avr 21 11:30 ifcfg-eth0*

-rwxr-xr-x    1 root     root          125 avr 21 11:30 ifcfg-eth1*

lrwxr-xr-x    1 root     root           22 jan 12 09:06 ifcfg-lo -> ../networking/ifcfg-lo

lrwxr-xr-x    1 root     root           20 jan 12 09:06 ifdown -> ../../../sbin/ifdown*

-rwxr-xr-x    1 root     root         4103 sep 19  2002 ifdown-ipv6*

-rwxr-xr-x    1 root     root         1132 jun 26  2002 ifdown-post*

-rwxr-xr-x    1 root     root         1092 sep 19  2002 ifdown-ppp*

-rwxr-xr-x    1 root     root         1678 mar 11  2002 ifdown-sit*

-rwxr-xr-x    1 root     root          902 jun 26  2002 ifdown-sl*

lrwxr-xr-x    1 root     root           18 jan 12 09:06 ifup -> ../../../sbin/ifup*

-rwxr-xr-x    1 root     root        13321 jun 26  2002 ifup-aliases*

-rwxr-xr-x    1 root     root         7695 sep 19  2002 ifup-ipv6*

-rwxr-xr-x    1 root     root          821 jun 26  2002 ifup-ipx*

-rwxr-xr-x    1 root     root          689 jun 26  2002 ifup-plip*

-rwxr-xr-x    1 root     root          926 jun 26  2002 ifup-plusb*

-rwxr-xr-x    1 root     root         2569 sep 19  2002 ifup-post*

-rwxr-xr-x    1 root     root         3809 jun 26  2002 ifup-ppp*

-rwxr-xr-x    1 root     root          563 jui  5  2002 ifup-routes*

-rwxr-xr-x    1 root     root         2882 jun 26  2002 ifup-sit*

-rwxr-xr-x    1 root     root         1646 jun 26  2002 ifup-sl*

-rwxr-xr-x    1 root     root         2821 jun 27  2002 ifup-wireless*

-rwxr-xr-x    1 root     root         5463 jun 26  2002 init.ipv6-global*

-rwxr-xr-x    1 root     root           60 avr 19 06:13 net_cnx_down*

-rwxr-xr-x    1 root     root           35 avr 21 11:30 net_cnx_pg*

-rwxr-xr-x    1 root     root          117 avr 19 06:13 net_cnx_up*

-rwxr-xr-x    1 root     root           60 avr 21 11:30 net_down.default*

-rwxr-xr-x    1 root     root           35 avr 21 11:30 net_prog.default*

lrwxrwxrwx    1 root     root           20 avr 21 11:30 net_resolv.default -> /etc/ppp/resolv.conf

-rwxr-xr-x    1 root     root          117 avr 21 11:30 net_up.default*

-rw-r--r--    1 root     root         4347 sep 19  2002 network-functions

-rw-r--r--    1 root     root        24055 sep 19  2002 network-functions-ipv6

-rwxrwxr-x    1 root     root          125 avr 19 06:42 old.ifcfg-eth1*

[gd@localhost gd]$ cat /etc/sysconfig/network-scripts/ifcfg-eth0

DEVICE=eth0

BOOTPROTO=static

IPADDR=10.0.0.10

NETMASK=255.255.255.0

NETWORK=10.0.0.0

BROADCAST=10.0.0.255

ONBOOT=yes

[gd@localhost gd]$ cat /etc/sysconfig/network-scripts/ifcfg-eth1

DEVICE=eth1

BOOTPROTO=static

IPADDR=192.168.1.1

NETMASK=255.255.255.0

NETWORK=192.168.1.0

BROADCAST=192.168.1.255

ONBOOT=yes

[gd@localhost gd]$

I have only two files. And both of my cards are setup static (should not be your case because you are cable connected to the net right). According to *the* link (well, my last one .. too much link :!: :!: ), one of your ifcfg-ethX file should be set to dhcp (the one connected to the net). So I would put that in the config file of the card connected to the modem :

DEVICE=eth1

USERCTL=no

ONBOOT=yes

BOOTPROTO=dhcp

BROADCAST=

NETWORK=

NETMASK=

IPADDR=

And restart the network by typing as root

service network restart

and then the usual 'ifconfig' to see what is going on with the IPs and 'lsmod' to see if the modules were really loaded and ..

 

good luck

 

MOttS

Share this post


Link to post
Share on other sites
Guest KShots

YES!!! Here's that message you asked for! I'm currently typing this on my linux box thru the lynx text browser! It turned out the cable modem wouldn't respond to anything other than the ethernet card it came with (intel etherexpress 100 PCI), which was detected automagically by Linux (no more find IO/IRQ searching to make it work)! :) :) :) This is VERY kewl... now since I have no graphical way of accessing the internet, this next part could be tricky. I need to share the internet with my home network. I'm going to first configure my other ethernet card manually (I erased all four of those ifcfg-ethN files and regenerated them automatically). I'll go ahead and run drakconf to share this internet connection (eth0 for reference :) (just in case :))) Thanks guys!

Share this post


Link to post
Share on other sites

Hooray! Congrats!

 

Some extra info, in case you are interested in doing the same:

from memory, how it was at this friends place:

 

just modprobe the driver (/etc/modules.conf only gets read upon boot AFAIK) ... then

ifconfig [drivername] eth# [address] up

(hmm, try man ifconfig for correct order/syntax, but I think you have done this before...)

 

then once it is up, just connect to it with any other machine, if you have only win machines, use putty, else use ssh (make sure on the linuxserver sshd is running), then login (under normal user), start a vncsession, if you can figure out how to set it you may want to use icewm instead of kde (less resource hungry), then use vncviewer (tightvnc on linux, vncviewer.exe on win, google to find it..) to connect to the server, and voila, you have a graphical desktop that runs on the (headless) server displayed on your client pc...

 

Anyhow, maybe you already knew a lot/all of this, but in short this is the way I like to set things up....

Share this post


Link to post
Share on other sites
Guest KShots

OK... I am typing this from my windows machine through my linux server!! (HOORAY!)... but I seem to have lost capability to SSH into it. I've tried this:

 

ifconfig - internal net IP = 192.168.1.1...

 

so from Windows, ran SSH Secure Shell Client with that address, and it says "Host unreachable"

 

So, I tried the cable modem's address from eth0, and got the same result... Any ideas how to get thru this?

 

EDIT: Oh, and I'm having trouble with getting my video card to work with X (at least with KDE), so I don't think that SSH into X would work (or does it not care about video drivers?) Anyways, thanks guys!

Share this post


Link to post
Share on other sites

Can you ping the windows machine from the server?

 

Other than that I have no idea..

 

Oh yeah, the vncserver doesn't care about video cards, if your pc boots without a card it can even work!! (normally pc's won't boot without though)

So that's why vnc is no nice...

Oh and you can even use it at a higher resolution than your video card would allow too and higher colour depth...

(btw it is not ssh-ing into X, you just need ssh if you have no keyboard/mon attached to the server and want to control it.. you need vncserver on the server and vncviewer on the client)

 

What if you start a vnc session on the linux machine (skip the ssh part)?

Can you connect to that?

 

I'm just guessing here, it may be that in MCC -> network (you can run this on the console too I think/hope) internet connection sharing you have to indicate that you want to allow all traffic to connect. (Don't know if this is a firewall or not, maybe just iptables..?? Don't know much about this..)

 

Oh yeah, can you do:

ps -ef | grep ssh

to see if your ssh deamon is running?

 

Also, can you ping the linux machine from the win machine?

If not, somehow the linux box is just still refusing all connections, you won't get far if it doesn't respond to ping....

Share this post


Link to post
Share on other sites
Guest KShots

Nope, can't ping it (I get a reply, but it says "Destination port unreachable." I think the firewall is stepping in the way :(

 

Yeah, I can see that sshd is running... just not responding :(

 

EDIT: I also can't ping my internet address...

Share this post


Link to post
Share on other sites

HEY !!!!!!!! congratulation man !!!!!!!!!!!

 

So if the modem works with the ethernet card it came with, this is because your internet service provider gives internet access according to the network card MAC address. This is the 'HWaddr' number of the card when you type 'ifconfig'. For example, my eth1 MAC adresse is 00:EE:B0:00:F2:D7 (see below). So put back your ISA card, bring it up (type 'ifconfig eth0 up') and type 'ifconfig'. Nothe the HWaddr and call your ISP about that. Forget about that if you want to leave the PCI card .. :lol:

eth1      Lien encap:Ethernet  HWaddr 00:EE:B0:00:F2:D7

         inet adr:192.168.1.1  Bcast:192.168.1.255  Masque:255.255.255.0

         UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1

         RX packets:8605211 errors:11 dropped:0 overruns:0 frame:0

         TX packets:8729143 errors:0 dropped:0 overruns:14 carrier:0

         collisions:0 lg file transmission:100

         RX bytes:2836733595 (2705.3 Mb)  TX bytes:621184261 (592.4 Mb)

         Interruption:18 Adresse de base:0xbc00

 

Ok, so to resume what is going on --> You can access the net from your Windows box that is connected to the second ethernet card of your Linux box (ie, you enabled Internet Connection Sharing from drakconf). Right? However, you are not able to access your SSHD server that runs on your LInux box from your windows box. Right? If I'm right with those two sentences, then you can't because when you enable ICS on Mandrake, that installs Shorewall (a firewall). By default, Shorewall blocks everything. Ie, you will not be able to ping the LInux box from anywhere (internet and lan) and vice versa. This is secure --> YES. Anoying -> NO! .. if you can deal with that.

 

SSH with Shorewall

If you want to access your ssh server that runs on your Linux machine from your LAN (not from the net !!) then add the following line to /etc/shorewall/rules and restart Shorewall.

ACCEPT  masq    fw      tcp     22   -

You can restart Shorewall by typing as root.

service shorewall restart

Now if you want to access your ssh server that runs on your linux machine from the internet also (you should not want that for security reason), put that line in /etc/shorewall/rules and restart shorewall

ACCEPT  net     fw      tcp     22      -

Basically, Shorewall works in Zone. Your linux box is 'fw', the internet is 'net' and your lan is 'masq'.

 

VNC with Shorewall

First, you have to install VNC. Type as root

urpmi tightvnc-server

now, as your normal user (not root!), start the vnc server by typing

vncserver :0

It is going to ask you for password, give it one. Now let's enter some stuff in Shorewall so that you can access the service. Enter the following line in /etc/shorewall/rules and restart it (service shorewall restart).

ACCEPT  masq    fw      tcp     5900   -

if you want to be able to access your vncserver AND ssh from your lan, you can combile the two lines as follow:

ACCEPT  masq    fw      tcp     22,5900   -

Don't forget to restart Shorewall!!!. Now try to access the vncserver in windows. Well, start by downloading the viewer from there--> http://www.realvnc.com/download.html (you don't need to fill your name and such. Just select 'Windows 9x/2000/NT/XP (x86)' and clic 'Proceed to Download'. Now download the 'x86 Win32 - viewer program only'. You don't need the whole thing.. only the viewer). Now in Windows, double clic the .exe and enter your Linux box IP (that should be 192.168.1.1) and add a ':0' at the end. So you should enter 192.168.1.1:0. Now clic ok. YOu should be prompt for the password you entered when you started the vncserver.

 

Have fun!

 

MOttS

Share this post


Link to post
Share on other sites

Motts, I'm impressed; I hope this works for KShots, and if it does, I'm just going to have to copy paste that message to the Howto section of my website... ;)

Share this post


Link to post
Share on other sites
I'm just going to have to copy paste that message to the Howto section of my website... ;)

 

HAHA.. you can. My help is under the GPL .. :mystilol: :mystilol:

Share this post


Link to post
Share on other sites
Guest KShots

Thanks MOttS and aRTee! I'm up and running, and I've moved the server to its (now) permanent position with no keyboard/monitor/mouse. Everything seems to be working great! Thanks for your help!

Share this post


Link to post
Share on other sites

WOUHOO!! Finally !!

 

Will you contact your ISP about that nic (the ISA one that doesn't connect) ?

 

Also, I'm wondering, did you decide to control it with VNC or SSH or both? Did you play with Shorewall?

 

What did you do.. ???

 

I want some info .. I want some info .. I'm a Drunken Penguin waiting for some info :mrgreen: :mystismiles: :mystilol: (I just discoved those nice Javascript !!)

 

MOttS

Share this post


Link to post
Share on other sites
Guest KShots

Well, at the moment, I'm logging in with pure SSH... I did a urpmi tightvnc-server and came up with nothing... tried it with just vnc, hoping to come up with something similar but misspelled, but nothing popped up :(. I'm thinking this is odd...

 

I did something else tho, that may affect it:

 

urpmi.removemedia -a

urpmi.addmedia --distrib Online ftp://csociety-ftp.ecn.purdue.edu/pub/man...ndrake/9.1/i586

 

This added three CD's, but I'm finding that even tho the RPM's are listed in the RPMS folder, urpmi doesn't seem to find them :(

Share this post


Link to post
Share on other sites

I remember reading on this board somewhere about deleting some files in in the /var/cache/urpmi directory and running

 

rpm --rebuilddb

 

or something like that. Try searching for urpmi and rebuilddb (or initdb)

Share this post


Link to post
Share on other sites
try

 

rpm --rebuilddb

 

If that doesn't do it, with no rpm processes running look in /var/lib/rpm and delete any __db.0x files then do

 

rpm --rebuilddb

rpm --initdb

 

There it is

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...