Jump to content
Sign in to follow this  
Guest KShots

How to install two ethernet cards without X windows system?

Recommended Posts

Guest KShots

Hello, I'd like to install two ISA ethernet cards on my system... but I don't have the X Windows system currently functioning at anything resembling a workable condition (But I don't need it for what I'm doing). Any ideas how to do this from a console? Thanks!

 

Edit: Oh, I almost forgot: The two ethernet cards are a LinkSys NE2000 and an Intel EtherExpress Pro/10+. Thanks!

Share this post


Link to post
Share on other sites

Hi KShots.

 

Everything is feasible in Linux my friend. I set my server without X so I guess you could do the same. I have a few questions for you. Here they are:

 

What are you trying to do exactly? Just giving IP to you cards or set a server with Internet Connection Sharing and Apache and such things?

 

Are the cards installed?

 

Did you install Mandrake with the cards in the box?

 

They are ISA but which chipset are they using?

 

What do you get when you type 'ifconfig' as root?

 

Can you list which modules are loaded plz. This is done by typing 'lsmod' as root.

 

MottS

Share this post


Link to post
Share on other sites
Guest KShots
What are you trying to do exactly? Just giving IP to you cards or set a server with Internet Connection Sharing and Apache and such things?
I'm trying to set up internet connection sharing for my house with CGI capability (via apache) and possibly (if I'm on a roll) a counterstrike server :). One ethernet card needs to connect to my hub for my LAN, the other connects to my cable modem. I may also want to fiddle around with different firewalls, but I can do that later...

 

I also want to strip away the keyboard/monitor/mouse and log in via SSH to do any further changes, but I think it's already configured for that... just waiting for the ethernet :)

 

Are the cards installed?
Yes

 

Did you install Mandrake with the cards in the box?
Yes... but I could not get them configured during install (it was done as if nothing was detected).... I was looking at the output window during the text-install (alt-f3) and the error-output window (alt-f4), and it said that I needed to know the specific IO address of the cards to install them, and that autoprobing may halt the system (I tried autoprobe anyways and it simply failed).

 

They are ISA but which chipset are they using?
Not sure what you're asking

 

What do you get when you type 'ifconfig' as root?
lo   Link encap:Local Loopback

    inet addr:127.0.0.1  Mask:255.0.0.0

    UP LOOPBACK RUNNING  MTU:16436 Metric:1

    RX packets:24 errors:0 dropped:0 overruns:0 frame:0

    TX packets:24 errors:0 dropped:0 overruns:0 carrier:0

    collisions:0 txqueuelen:0

    RX bytes:1680 (1.6Kb)   TX bytes:1680 (1.6 Kb)

Share this post


Link to post
Share on other sites

Hey !!! You want to do the samething as me man. I have a server with 2 ethernets cards. One is connected to an ADSL modem and the other one to a hub (my box and my wife's box is connected to it).

 

For the questions, you forgot the lsmod :!:

 

By chipset I mean which kind of card is that? Ok they are ISA but which modem are they, which chipset they use (you have to look at the card itself to know that).

 

Could you also post the output of lspci, lsisa (if you have it) and dmesg | grep isa while you are there..

 

MOttS

Share this post


Link to post
Share on other sites
Guest KShots

Ok, sorry about the lsmod :oops: (oops) :oops:

 

Can you list which modules are loaded plz. This is done by typing 'lsmod' as root.

Module                 Size    Used by    Not tainted

isofs                    27988   1    (autoclean)

zlib_inflate           21156   0    (autoclean) [isofs]

nls_iso8859-1        3516   1    (autoclean)

udf                      90464   0    (autoclean)

sr_mod                16920   0    (autoclean) (unused)

ide-cd                  33856   1    (autoclean)

cdrom                  31648   0    (autoclean) [sr_mod ide-cd]

af_packet             14952   0    (autoclean)

floppy                  55132   0

supermount          15296   2    (autoclean)

ext3                     64704   1    (autoclean)

jbd                       48532   1    (autoclean) [ext3]

rtc                          8060  0    (autoclean)

reiserfs               175120   4

raid5                    16912   4

xor                         5472  0    [raid5]

raid0                      3056   1

sd_mod                 11548 72

aha1542                10288 36

scsi_mod               91796  3    [sr_mod sd_mod aha1542]

By chipset I mean which kind of card is that? Ok they are ISA but which modem are they, which chipset they use (you have to look at the card itself to know that).
Well, one's a Linksys NE2000, the other's an intel etherexpress pro 10+
Could you also post the output of lspci and lsisa (if you have it) while you are there..
Sorry, I don't have those (I can install it if I knew which package they were under)

 

Thanks for your help so far!

Share this post


Link to post
Share on other sites
Could you also post the output of lspci and lsisa (if you have it) while you are there..
Sorry, I don't have those (I can install it if I knew which package they were under)

 

lspci is in pciutils. Post the output of dmesg | grep isa also.

 

But so far, your ethernet card's drivers don't seems to be loaded. According to THIS website, the driver for a NE2000 ISA card is ne and it is not listed by lsmod. Also, from THIS website, the driver required by your EE pro card is eepro and it is not listed by lsmod either. So here is how I would tackel that:

 

Open /etc/modules.conf for edition by typing as root:

vi /etc/modules.conf

Now press 'i'. If you see a line related to eth0 or eth1 then report it here. If you see nothing about eth0 and eth1 then I would start by adding those lines to the file:

alias eth0 ne

alias eth1 eepro

now save it (press 'Esc' on your keyboard and type ':wq') and try to bring them up by typing

ifconfig eth0 10.0.0.10 up

ifconfig eth1 192.168.0.1 up

and see what the output will be. You can now look at the ouput of ifconfig to see if you see something else that 'lo' and look also at the output of lsmod to see if the drivers were loaded. Also take a look at dmesg | grep isa to see what the kernel think about it...

 

well.. we'll see..

 

MOttS

Share this post


Link to post
Share on other sites
Guest KShots
lspci is in pciutils.
urpmi pciutils comes back with
no package named pciutils
Post the output of dmesg | grep isa also.
That gave me a blank line... but I also tried dmesg | grep ISA (caps) and that gave me this:
ne.c: You must supply "io=0xNNN" value(s) for ISA cards.

ne.c: You must supply "io=0xNNN" value(s) for ISA cards.

ne.c: You must supply "io=0xNNN" value(s) for ISA cards.

ne.c: You must supply "io=0xNNN" value(s) for ISA cards.

ne.c: You must supply "io=0xNNN" value(s) for ISA cards.

ne.c: You must supply "io=0xNNN" value(s) for ISA cards.

eepro_init_module: Probe is very dangerous in ISA boards!

eepro_init_module: Probe is very dangerous in ISA boards!

eepro_init_module: Probe is very dangerous in ISA boards!

In the "/etc/modules.conf" file, I didn't see anything saying "eth0" or "eth1"... In fact, all I saw was "probeall scsi_hostadapter aha1542", so I added in the lines you suggested.

ifconfig eth0 10.0.0.10 up  

ifconfig eth1 192.168.0.1 up

This gave me this:
SIOCSIFADDR: No such device

eth0: unknown interface: No such device

eth0: unknown interface: No such device

SIOCSIFADDR: No such device

eth1: unknown interface: No such device

eth1: unknown interface: No such device

ifconfig - nope, still only lo...

lsmod - No change

dmesg | grep ISA

ne.c: You must supply "io=0xNNN" value(s) for ISA cards.

ne.c: You must supply "io=0xNNN" value(s) for ISA cards.

ne.c: You must supply "io=0xNNN" value(s) for ISA cards.

Seems to have lost half the ne.c complaints and all the eepro_init_module complaints...

Share this post


Link to post
Share on other sites
lspci is in pciutils.
urpmi pciutils comes back with
no package named pciutils

Come on man .. open rpmdrake and search for 'pci' .. you'll find something about that I promess. Do the same for 'isa'. Now install those usefull packages and post the output of 'lspci' 'lsisa' or 'pcidrake' or ..

 

ne.c: You must supply "io=0xNNN" value(s) for ISA cards.

ne.c: You must supply "io=0xNNN" value(s) for ISA cards.

ne.c: You must supply "io=0xNNN" value(s) for ISA cards.

 

Ok so if the kernel wants you to supply it, go and do so. Add the following line after 'alias eth0 ne' in /etc/modules.conf

options ne io=0x300,11

This is as suggested by the RedHat webpage (see couple post above). If it does not work, we will replace the numbers (300 and 11) by what we get with 'lspci' or 'lsisa' or 'lspcidrake' or whatever you find. Also look HERE and HERE. They show you how to find the 300 (i/o setting) and 11 (irq) for your card. That will help.

Share this post


Link to post
Share on other sites
Guest KShots
Come on man .. open rpmdrake and search for 'pci' .. you'll find something about that I promess. Do the same for 'isa'. Now install those usefull packages and post the output of 'lspci' 'lsisa' or 'pcidrake' or ..  
I'm still having trouble getting X to run :( rpmdrake therefore isn't an option quite yet :(. (Also, found that my serial mouse doesn't want to work after all)

 

I went ahead and ran the eepro's dos configuration utility and set it to IO 0x210-21F using IRQ 9. I also removed its plug and play because I figure if it ever decides to change, I'd have to do this all over again :).

 

My SCSI card is using IRQ 11, so I don't think that would work out too well :(. I can change the SCSI IRQ easily to about anything, but how do I tell Linux about this change? (I don't have a configuration utility for the NE2000, and no jumpers on it, so its configuration can't change I think).

 

Anyways, I gave the above a try, and added "options eepro io=0x210,9" as well, and came up with this:

 

ifconfig eth0 10.0.0.10 up: comes up blank (does this mean it worked?)

ifconfig eth1 192.168.0.1 up: Same error condition as before

 

ifconfig:

eth0  Link encap:Ethernet  HWaddr 00:A0:C9:59:65:F5

     inet addr:10.0.0.10  Bcast:10.255.255.255  Mask:255.0.0.0

     UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1

     RX packets:0 errors:0 dropped:0 overruns:0 frame:0

     TX packets:0 errors:0 dropped:0 overruns:0 carrier:0

     collisions:0 txqueuelen:100

     RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)

     Interrupt:9 Base address:0x210

That address/IRQ looks like my etherexpress pro (eth1?), but it's 0 there...

 

The lo looks the same and there's no eth1 yet

 

lsmod - shows eepro with 15336 2 (autoclean)

dmesg | grep ISA - shows

ne.c: You must supply "io=0xNNN" value(s) for ISA cards.

eepro_init_module: Probe is very dangerous in ISA boards!

id: 0xb4   io: 0x210 eth0: Intel EtherExpress Pro/10+ ISA

 

... So it looks like we're making a lot of progress now! Thanks for all your help so far!

 

I'm going to go ahead and undo the ne2000's IO and IRQ for now just in case it's causing other problems sharing my SCSI's IRQ.

 

I'm going to be heading out for the evening after this, but please don't stop! You've been invaluable for me so far! Thanks!

Share this post


Link to post
Share on other sites
Come on man .. open rpmdrake and search for 'pci' .. you'll find something about that I promess. Do the same for 'isa'. Now install those usefull packages and post the output of 'lspci' 'lsisa' or 'pcidrake' or ..  
I'm still having trouble getting X to run :( rpmdrake therefore isn't an option quite yet :(. (Also, found that my serial mouse doesn't want to work after all)

Oh ok I see.

 

I went ahead and ran the eepro's dos configuration utility and set it to IO 0x210-21F using IRQ 9. I also removed its plug and play because I figure if it ever decides to change, I'd have to do this all over again :).

Good job :!: :!: :!: .. and it seems to work now. We'll configure it later when the other one (ne2000) will come up with ifconfig.

 

My SCSI card is using IRQ 11, so I don't think that would work out too well :(. I can change the SCSI IRQ easily to about anything, but how do I tell Linux about this change? (I don't have a configuration utility for the NE2000, and no jumpers on it, so its configuration can't change I think).

Well, you really have to find that Dos utility. Search Google. It's either you find that Dos utility and set the IO/IRQ by yourself or you find a way to install 'lspci' and co. and we find on with IO/IRQ it is. You have the choice ! :mystilol:

 

ifconfig eth0 10.0.0.10 up: comes up blank (does this mean it worked?)

Well, if you get eth0 and lo by typing 'ifconfig' AND you see eepro when you type 'lsmod' then this card is working. Congratulation!

 

You now have to find a way to set the IO/IRQ for the other card .. :lol:

 

I'll search a bit but make your efforts..

 

MOTtS

 

EDIT: I searched a bit. Here are the results:

 

from http://www.linuxgazette.com/issue50/tag/9.html

If you don't find the Dos utility, you could try this io/irq

The Linksys Ether16 is a nice cheap card. Out of p-n-p mode it acts like a NE2000, at least close enough so the Linux ne driver has no trouble running it. The card comes with a DOS floppy with the configuration program, but Chuck shouldn't need to use that unless the card has been previously used (in a Winxx machine) or unless he wants to set goofy IO address or IRQ settings. The last couple I've purchased new ($30 at my local office supply store) came defaulted to NE2000 mode, IRQ=5, IO address=300.

 

from http://www.linksys.com/support/support.asp?spid=26

This basically say that you need the Dos utility to disable the pnp mode and set the card.

If you have the plug-and-play version of the Ether16 (released in mid-1997), install the card in a DOS workstation and run its Setup program to take the card out of plug-and-play mode before beginning the Linux installation--the card won't work properly with Linux while in plug-and-play mode.

 

This card will work with the ne driver (ne2000) in most distributions using Kernel 2.x

 

I guess this is the Dos utility.. not sure tho..

http://www.linksys.com/support/support.asp?spid=52

Share this post


Link to post
Share on other sites
Guest KShots

Well, I spent most of the day trying to get that DOS configurator to recognize the card (Yes, it was the right one)... and it repeatedly told me that either the card was bad or I had an IO conflict. I tried removing all hardware except that card and my video card, and got the same result... so I went ahead and switched it out for a Magitronic EZ2000 that I just found from one of my really old machines, ran its DOS configurator and switched it to IO 0x340 and IRQ 10 (I believe those were free still). It seems to be an NE2000 compatible card, so I think I'll keep using the "ne" from earlier, just update the IO and such... I'm currently rebooting after a "kernel panic", which made it resync all my RAID partitions (which is taking forever!!), so I'll try it when I get in and let you know how it turns out

 

EDIT: Well, it finished rebooting, and I added the appropriate IO and IRQ, ran ifconfig with this result:

SIOCSIFADDR: No such device

eth1: unknown interface: No such device

eth1: unknown interface: No such device

Well, I went ahead and continued with a lsmod, but there was no "ne" listed :(. A dmesg | grep ISA reveals:

 id: 0xb4   io: 0x210 eth0: Intel EtherExpress Pro/10+ ISA

... and that's it, so it's not showing up as an error, either. Any ideas on how to procede?

Share this post


Link to post
Share on other sites
Well, I spent most of the day trying to get that DOS configurator to recognize the card (Yes, it was the right one)... and it repeatedly told me that either the card was bad or I had an IO conflict. I tried removing all hardware except that card and my video card, and got the same result...

Did you try my link?

Also, I found some files in /proc that may help you finding which IO/IRQ that card is on. That could save you to manually change the IO/IRQ setting of that card. So run

cat /proc/pci

cat /proc/ioports

cat /proc/interrupts

and see if what come out of that. You should see you card there (I see mine).

 

so I went ahead and switched it out for a Magitronic EZ2000 that I just found from one of my really old machines, ran its DOS configurator and switched it to IO 0x340 and IRQ 10 (I believe those were free still). It seems to be an NE2000 compatible card, so I think I'll keep using the "ne" from earlier, just update the IO and such...

Well, did you search Google about that (which driver this card is using)? Try the 'ne2k' driver also !

 

EDIT: Well, it finished rebooting, and I added the appropriate IO and IRQ, ran ifconfig with this result:
SIOCSIFADDR: No such device<!--QuoteEBegin--><!--QuoteEBegin-->eth1: unknown interface: No such device<!--QuoteEBegin--><!--QuoteEBegin-->eth1: unknown interface: No such device

Well, I went ahead and continued with a lsmod, but there was no "ne" listed :(. A dmesg | grep ISA reveals:

 id: 0xb4   io: 0x210 eth0: Intel EtherExpress Pro/10+ ISA

... and that's it, so it's not showing up as an error, either. Any ideas on how to procede?

If 'ne' is not listed when you type 'lsmod' then it is not the proper driver for that card or you have a conflict in your IO/IRQ setting. Try another driver because 'ne' does not seems to work with that card (Magitronic EZ2000). Or put back the original card (NE2000) and try the above commands to find on which IO/IRQ the card is on.

 

Ok I had problems to connect to this website today so I put on a .txt file some info I found on the web about your problem. Here it is (copy-paste)

 

--------------------------

From http://www.freelists.org/archives/huskerlu...2/msg00049.html

You need the Dos disquette with the .exe on it to disable the pnp mode and set the io/irq of the card.

 

cat /proc/pci

 

cat /proc/ioports and cat /proc/interrupts

 

From http://www.scrounge.org/linux/nics.htm

Intel Ether Express Pro 10 --> eepro kernel module. Doesn't work in PNP mode. Boot in DOS and run SOFTSET2.EXE from the driver disk to change parameters.

 

From http://www.scrounge.org/linux/nics.htm

D-Link DE-220PCT (clone of ne2000) --> ne kernel module. Doesn't work in PNP mode. Boot in DOS and run INSTALL.EXE on the driver diskette to install the configuration program to disable PNP.

 

** So really have to find that diskette man .. lol

 

From http://www.scrounge.org/linux/nics.htm

If you are using an ISA nic that you have disabled PNP, you might have a problem if the BIOS doesn't "see" it and attempts to assign its IRQ and I/O Ports to a PCI PNP card. You might be able to deal with this by going into your BIOS settings and seeing if there is any settings that will pre-allocate these resources. Look for the term "legacy."

 

Another prog to set IO/IRQ for your card --> http://www.scyld.com/diag/index.html#isa-diags

--------------------------

Basically, I would do 'cat /proc/interrupts' to know which IRQ address is free. That will look somehing like that:

root@localhost gd # cat /proc/interrupts

          CPU0

 0:    1007544          XT-PIC  timer

 1:      13030          XT-PIC  keyboard

 2:          0          XT-PIC  cascade

 9:          0          XT-PIC  usb-ohci

10:      86787          XT-PIC  EMU10K1, eth0

11:     872343          XT-PIC  nvidia

12:     581927          XT-PIC  PS/2 Mouse

14:     117354          XT-PIC  ide0

15:        234          XT-PIC  ide1

So you see, my IRQ 3,4,5,6,7 an 8 are all free. So do that command, note the free IRQ numbers on a piece of paper and boot DOS (a win9x floppy will do). Don't forget to put you card's utility on it before (check the website). Now set the card's IRQ number to a free one and disable the Plug&Play (pnp) support for that card. Now reboot and check in the Bios to see it assign an Io/IRQ to the card. Now boot linux and write in /etc/modules.conf the things you noted when you were in Dos. Something like that:

alias eth0 ne

options ne io=0x###

Step by step procedure HERE --> http://www.experts-exchange.com/Networking...Q_20110476.html

 

YOU ARE CLOSE MAN !!!

 

MOTtS

Share this post


Link to post
Share on other sites
Guest KShots
did you try my link?
Yeah, that's the one that turned out to be accurate but didn't work. I think it's a dead card.
Also, I found some files in /proc that may help you finding which IO/IRQ that card is on. That could save you to manually change the IO/IRQ setting of that card. So run
cat /proc/pci <!--QuoteEBegin--><!--QuoteEBegin-->cat /proc/ioports <!--QuoteEBegin--><!--QuoteEBegin-->cat /proc/interrupts

and see if what come out of that. You should see you card there (I see mine).

I ran that and didn't see anything around the address/IRQ I set up... or anything I didn't recognize for that matter or that looked like another ethernet card. I think it just lists what it knows about.
Well, did you search Google about that (which driver this card is using)? Try the 'ne2k' driver also !
I've looked around a bit and I'm not sure what to put in google to find these things. I keep getting something like two results not having anything to do with it, but I keep seeing you get links easy. What keyword am I missing here? :oops:
If you are using an ISA nic that you have disabled PNP, you might have a problem if the BIOS doesn't "see" it and attempts to assign its IRQ and I/O Ports to a PCI PNP card. You might be able to deal with this by going into your BIOS settings and seeing if there is any settings that will pre-allocate these resources. Look for the term "legacy."
Yeah, that was one of my thoughts. Seeing as I have no PCI cards other than my video card, and that doesn't use an IRQ, I set everything as legacy-driven instead of PCI/pnp

 

Is there a way to list available drivers that I can try? I seem to recall there being a "ez" or "ez2k" or something similar in the module list.

 

Thanks for everything! I think this can be licked real soon!

Share this post


Link to post
Share on other sites
did you try my link?
Yeah, that's the one that turned out to be accurate but didn't work. I think it's a dead card.

Oh really. Did you try the card with the other OS? Did that card ever work? I'm asking because I'm having problems finding driver for the 'new' card you put in today. Maybe you'll have better luck. Try here:

www.google.com/linux

 

Is there a way to list available drivers that I can try? I seem to recall there being a "ez" or "ez2k" or something similar in the module list.

Yes, actually all the drivers included with your kernel are there:

ls /usr/src/linux/drivers/net/

You can also read those files with 'vi'. Sometimes they talk about which card the driver was really designed for... and so on.

 

Did you check all my links above? Really TWO of them were importants (sorry hey.. LOTS of them lol).

 

1) There is a Linux utility to set IO/IRQ for NE2000 card. So download it from

ftp://ftp.scyld.com/pub/diag/ne2k-diag.c

Download that file and compile it with

gcc -Wall -O6 -o ne2k-diag ne2k-diag.c

Once it is compiled, run it with

./ne2k-diag --help

I think you'll be able to set the IO/IRQ of your NE2000 card with that prog (if the card is really working).

 

2) Same card as you, same problem (look at the END of the webpage):

http://www.experts-exchange.com/Networking...Q_20110476.html

 

And for you Magitronic EZ2000 card, I don't know. I didn't find a webpage saying it is supported and which driver to use and such.

 

MOttS

Share this post


Link to post
Share on other sites
Guest KShots

BOOM! I just got the magitronic card working (Figured I'd keep trying that until it became futile or worked before having to shut down).... it worked on the "ne" driver, but apparently ONLY after doing a modprobe! (Got the idea from that last link you gave me). lsmod lists it, and ifconfig lists both eth0 and eth1 now. I think the hardest part has just been dealt with... let me reboot and see if this sticks :). Once again, thanks!

 

Now, the next step: :oops: I need to let it know that it can update its RPMS via the web instead of the CD (I have my internal CD-ROM on the outside of the case on another computer's power supply at the moment :)). I think that means I need to set up eth0 and eth1 to internal network and cable modem, the internal network hopefully running DHCP and the card connected to the cable modem accept an IP from the modem.

 

Also, so that I can keep posting here, I'd need a prog that shares an internet connection... don't know what package that's under at the moment :oops:.

 

Thanks for everything man! You've been an awesome help!

 

EDIT: OK, upon bootup, both eth0 and eth1 are listed as "FAILED"... but on shutdown, they're listed as "OK". Probably doesn't mean much on shutdown, but the bootup may be problematic... or it simply means that an IP has not been given to it yet? Oh, also, I currently only have one of them plugged in (It's plugged into the ethernet). I think that would cause the other to fail regardless. But the biggest step seems to have been completed!

 

EDIT2: WOOHOO! I configured an IP for one card temporarily and got SSH running AND html works!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...