Jump to content

mandriva 2008 on SATA drive (solved)


Recommended Posts

  • Replies 50
  • Created
  • Last Reply

Top Posters In This Topic

yes I know. Last night I already had gone into terminal and run mcc.


Last night I already went into mcc and selected Display and looked around at the settings. Then I went to bed.


Anyway, this morning I see that Resolution is set on 1280x768 24 bppp.


don't know what 24 bppp is, but I changed resolution to 1280x968 24bppp. then did startx and it looks good !


So I guess mandriva is installed correctly. I thought the install was very nice. Except for the sata non-recognition, and the incorrect display, it went fine.



Thanks for the help. Now I have to get ready and leave for work.


If I have any other questions later, I'll start new threads in software, hardware, or wherever.

Edited by null
Link to comment
Share on other sites

Did you go into the other details about SATA drives that I suggested ???.

Mandriva IS compatible with SATA drives. I still believe that the trouble you had, had nothing whatsoever to do with Mandriva.

I only have SATA Hard Drives and have NEVER had a problem with them from 10.1 through to Mandriva 2008.

The very first time I installed the drives I could not do an OS install because I did not read the SATA HD instructions first. Once I set the HD links I was away and have been ever since.

They are never an issue in any OS install or reinstall to the extent that I forget that they are SATA drives.


Mandriva and SATAs=== :thumbs: :thumbs: :thumbs: :thumbs:


Cheers. John.

Link to comment
Share on other sites

by previous suggestions, I gather you mean when you said:

1. enable sata in bios

2. check back of HD for SATA, not SATA-II


yes, I always had bios set to "enable sata". I have NOT done the sata-II check, but I will.


The SATA drive is in the machine with ALL my data on it. The new IDE drive just has win2k, and mandriva powerpack 2008. So obviously I want to get the sata drive recognized. Then I guess I need to do aussiejohn's comment about the ntfs reading thing.


By the way, the new install of win2k does not recognize the pre-existing sata drive either. My Computer shows Drive C (the IDE drive) and the cd and dvd drives, but no Drive G and Drive H (previously formatted sata drive).


I suppose I need to go into Disk Management or something.


no big hurry on this stuff. I will ask about things as they come along. I think I will like mandriva. Internet, sound and whatever else seems to work nicely so far. I have a Canon printer connected to this win2k/mandriva machine but I haven't checked if mandriva has it or not.


Oh yeah, another post-install mandriva thing. When I installed, it asked me if I wanted to copy the entire DVD to Hard Drive. I said no. Now, after install, if I want to install some more stuff, it sometimes asks for the "mandriva powerpack disk" and ejects my CD tray for me. Well, its a DVD not a CD. I have a DVD burner and a CD burner.

Edited by null
Link to comment
Share on other sites

Linux may be compatible with SATA driuves since kernel 2.6.9 or so, but certain SATA controllers may not be properly supported (e.g. my jmicron onboard was properly supported only since kernel revision

So -if you conrtroller has no kernel driver yet, you must either try a newer kernel revision, or backport the driver yourself- whatever you wish.

Link to comment
Share on other sites

null wrote:


...the new install of win2k does not recognize the pre-existing sata drive either. (snip) I suppose I need to go into Disk Management or something.


Win2k doesn't recognize the SATA drive 'cause you got no SATA controller drivers installed. You just need to load the SATA controller drivers from the CD that came with the motherboard - which you do still have, right? You already have Win2k running so no need to do the F6 thing, etc - just use the CD to install drivers. Then it should recognize the SATA drive like any other.

For Linux do as AussieJohn suggested and make sure everything is set properly. If still no go well, scarecrow is right about not all SATA controllers being supported yet. Try a Google search about Linux compatibility for your controller chipset and see what that turns up.


No doubt SATA is the future standard. Next home workstation I build for myself in a year or two I'll definitely take the SATA path. Seems most SATA controllers are already supported and Linux support for SATA should be a moot point by then, plug 'n go about every time.

Edited by Crashdamage
Link to comment
Share on other sites

Win2k doesn't recognize the SATA drive 'cause you got no SATA controller drivers installed.

yes I do. Immediately after installing win2k, I installed the mobo drivers from the CD, which has sata/raid drivers, ethernet, sound and all the other necessary drivers. Then I installed my video card drivers, as well as my printer software and drivers, and my DVD burner software and drivers. What a pain!! I must have gone through a half-dozen reboots.


That's why I was surprised win2k doesn't show the sata drive. The sata drive was formated, partitioned, and named (G: and H:), under my previous win2k install. Then my IDE drive with win2k on it went bad, so I bought a replacement IDE drive (sorry aussiejohn ;) ) and reinstalled win2k on it (and mandriva). I expected the formerly set-up sata drive to be "known" to the new win2k install, but it is not.

Link to comment
Share on other sites

maybe your sata-drive is defective too ??? or it got screwed up when windows went down ?


if you go to mcc in mandriva do you see a drive called sd(x) ?


btw. which sata-controller does your board use, which sata-drive do you use


I have no problems with 2 maxtor drives on a uli-sata and a plextor-burner on a silicon image sata, mandriva recognizes them all, the sata-drive in my notebook was so far recognized by Mandriva 2007.1, 2008, Ubuntu 7.04, 7.10 and Debian 4.0, so all in all I can say that sata-recognition is fairly good in modern linux distributions.


have you tested if your drive is recognized by a live-linux distro like knoppix ?

Link to comment
Share on other sites

I haven't really messed around with win2k or mandriva regarding the sata drive yet. When I get home from work today, I'll mess with it and find out what lavaeolus is asking.


edit: my live CD of knoppix is kind of old, a few years at least. I didn't try it. I need to make a newer one.

Edited by null
Link to comment
Share on other sites

Good one Null.

Glad to see you haven't lost your sense of humour after what you have experienced.


I am starting to think that you may just happen to have a faulty SATA HD. Is it possible to get your supplier to test it under warranty???. Or even try it out in someones machine that currently has a Windows or Linux OS successfully running SATA at the moment.

Would be worth a try.


Cheers. John.

Link to comment
Share on other sites

hmmm... I doubt it. I probably don't have the receipt anymore anyway. It worked fine for a few weeks while I was using it under my old win2k install.


Under Disk Management in win2k, it shows 4 disks. 3 are not named and one is C: I am assuming that the 3 "un-named" ones are the linux partitions that mandriva created? /, swap, and /home on C.


I'll also check inside the box to make sure sata cable is connected ok and power connector is connected ok.

Link to comment
Share on other sites


power cable on sata drive was only part way pushed on. Now win2k sees the drive. Also mandriva sees the drive.

Must have happened the other day when I installed the 2nd IDE drive, and pulled out the drive cage to screw in the new IDE drive. I unplugged the sata cables then plugged them back in (well, I thought).


When I was installing win2k and mandriva last week there was only the sata drive in the machine, and both cables connected. I know because the side of the case was off and I had checked.


Anyway, I'm a happy camper, and aussiejohn will be happy too.


Post-install questions:

Another weird thing. When I booted mandriva just now (for around the 3rd time since install), now it says "printer found, do you want me to install the software?". Don't know why it waited till now to ask (the printer has been connected and "on" for a couple days). I said yes, but...


... as mentioned before, I did NOT copy the DVD contents to hard drive during install, so it keeps asking me for the mandriva powerpack dvd to install stuff. Then it nicely ejects my CD drive door. But it is a DVD, not a CD. I have a DVD drive also. How do I get it to change?


I already went into Hardware in mcc, and it shows only one CD/DVD burner. My aopen drive (which is a CD burner). I also have an LG DVD burner. They are both IDE. Why isn't the dvd burner listed? And how do I change the source of Mandriva Powerpack to the dvd drive, not the cd drive?




ps: music, sound, video all work great so far!!


scarecrow: even the nba.com videos play on my mandriva distro! Never could see them on my debian machine.

Edited by null
Link to comment
Share on other sites

As you have been moving drives around, adding and removing drives, has the drive name changed on your CD/DVD drives, eg, what was hdd, may now be hdc type of thing, what I am getting at, could it be that what the DVD drive used to be, is now what the CD is? did you change the master/slave order of the CD/DVD drives either by the jumpers or cabling?

Edited by esulcer
Link to comment
Share on other sites

Null, I sure am happy for you that things are working OK for you now. :thumbs: :thumbs: :thumbs: Other less determined newbies often give up.


Esulcer has a good suggestion as well.


But first I think you should go back into the bios and made certain that the IDE positions properly reflect the positions of your various drives, especially the burners.

Mandriva is likely looking at whatever optical drive is nearer first in the chain .......Primary Master---------->Primary Slave-------->Secondary Master-------->Secondary Slave .......when it asks you to insert the Disc. Therefore if you have a CD drive earlier in the chain when a dvd disc is called for, or vice-versa, then of course you will have a problem and it is solved by changing the cable connections appropriately and again change in the bios to reflect that rearrangement. Do not use auto cable connection mode to determine master and slave, use the links on the rear of the drives only to set master and slave.


Cheers. John.

Link to comment
Share on other sites

glad to hear that your hdd problem got fixed.


If you have a running internet connection, you may just disable the dvd-entry in rpmdrake as package source, so it does not ask for the dvd anymore.


seems that mandriva has the tendency to give burners /mnt/cdrom as mountpoint and /mnt/cdrom2 and so on to other drives, but you could edit your /etc/fstab so that your dvd-drive mounts on /mnt/cdrom (assuming that rpmdrake searches /mnt/cdrom for packages), other way would be to change the mountpoints in the Mandriva Control Center.


In my case Mandriva insisted on giving my Plextor sata-DVD-burner /mnt/cdrom and my asus ide-DVD-drive /mnt/cdrom2, ironically rpmdrake searched /mnt/cdrom for packages despite the fact that I had the system installed from my dvd-drive


but the problem was solved with a quick edit of my /etc/fstab :D

Edited by lavaeolus
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...