Jump to content
Darkelve

Cannot Get Ip Address (anymore) In Opensuse 10.3

Recommended Posts

I have 2 computers, both running WindowsXP and OpenSUSE 10.3 with dual-boot. The 'old' system has an Intel (e1000 driver) network card, the new one has a Realtek (Realtek 8111B) card.

 

I used to be able to connect to both systems (almost) effortlessly under OpenSUSE in both systems. However, when I boot the new system in OpenSUSE 10.3, I cannot get an IP address.

 

At least this is what I think that happens; I use a D-Link wireless ethernet 'bridge' thing, meaning -I think- that thing gets an IP address from my access point and gives it to my Linux system. There are 4 leds on that box: power, diag, lan, wlan. On the 'old' system, all four leds start to burn (green) once the computer boots. I can connect to the network fine with the old system in both WinXP and OpenSUSE 10.3

 

Now the weird thing: when I boot the new machine, the 'lan' led does not burn at all. However, when I boot into WindowsXP, when it starts up, the lan led blinks and turns green. Once I log out of Windows, the led turns off again. And when I boot into OpenSUSE 10.3 on the new system, the led stays off no matter what I tried.

 

It worked fine a couple of days ago. Okay, I messed around with the system settings a bit, but not too much so I do not suspect any settings are wrong.

 

Why could this be?

Share this post


Link to post
Share on other sites

Okay... I have done some more research and came up with a couple possible causes/solutions:

 

- Problems due to the network card and P&P setting in the BIOS... this is a probably cause, since I did change the BIOS settings recently, and before the router would give an IP address when booting. Also would explain why the other computer does receive an IP address. Still does not explain though why Windows does get an IP address when it books and Linux does not.

 

- Switching on and off the router (to release IP addresses I assume)

 

- Problem with dual-booting XP and Linux... suggested to power down and back up the router and/or the computer running it (shutting down the computer and pulling out the power cord for a minute). Don't really understand why this would help... 'restarting' the router I can understand, but not sure why pulling the power cord would help.

Share this post


Link to post
Share on other sites

I had a problem with ipv6 and a realtek card. Maybe disable ipv6 on this system:

 

alias net-pf-10 off

 

in /etc/modprobe.conf or whatever is the equivalent in SUSE.

Share this post


Link to post
Share on other sites

Actually the network card configuration module in Yast has an option (check box) to enable/disable IPV6. And I already did (disable it).

Share this post


Link to post
Share on other sites

Might be a stupid question, but have you checked that the kernel module is working (lsmod)? It sounds like the bridge isn't seeing the computer when suse is running (i.e. no electrical current along the wire).

Share this post


Link to post
Share on other sites
Why could this be?

 

I'm not sure if I understood your config correctly. How many D-Link bridge(s) do you have in use? Only one or one for both computers each? Is there any means to access the status/IP address of these device(s), say by using a webfronted?

 

Some D-Link bridges offer different modes of work. If you have a device of such type, can you swith them manually, or is it done fully on automatic?

Share this post


Link to post
Share on other sites
I'm not sure if I understood your config correctly. How many D-Link bridge(s) do you have in use? Only one or one for both computers each? Is there any means to access the status/IP address of these device(s), say by using a webfronted?

 

Some D-Link bridges offer different modes of work. If you have a device of such type, can you swith them manually, or is it done fully on automatic?

 

There is one... if I need network on either computer, I pull out the plug (ethernet jack) and plug it in the other one. Yes, it has two modes... there is a switch with "X" (what is what I should need I think) and "II".

 

This evening I powered down my computer, reset my wireless router, my wireless accesspoint. And now, the Lan button blinks, but not the Wlan button any longer! On neither of the 2 PC's , no matter if I use SUSE or Windos.

 

I have the IP address for the web frontend, but I can't reach it, not even if my LAN led is blinking green.

 

What gives?

Share this post


Link to post
Share on other sites
What gives?

 

This is harsh! Now I really know the reason for my decision to still stick to cables...

 

Don't know what happened, but: What's the meaning of the two modes (client mode / routing mode)? At the router and/or the wireless access point I'd at least enable two different combinations of IP number+hostname for each of your PCs, i.e. same hostname/IP combo for the same PC regardless of operating system.

 

SuSE or Windows, you'd also have to make sure the other/new IP is visible to the router when (re-)plugging.

 

If using DHCP beware of possible cross references (maybe decrease default lease time).

 

HTH,

 

scoonma

Share this post


Link to post
Share on other sites

I'm not using a WEP key (don't ask).

 

Anyways,

 

when I try to get an IP address the system complains it cannot reach the DHCP server. Also if I do an ipconfig (Windoze) or ifconfig, I get a couple of addresses which I am not sure where they are coming from... I suppose this is an address obtained from the Linksys wireless router. And I think the wireless router somehow cannot get a DHCP address from the wireless access point (even though it's not blocked in any way).

 

Maybe my Linksys router's wireless connection is broken somehow?

 

Hmmm, this looks like a good time to look further into those Power-Over-Ethernet/Homeplug devices. Those look easier to configure, and I'm sick of this wireless sh**

Edited by Darkelve

Share this post


Link to post
Share on other sites

I hope I'm not reading this wrong, but why do you have the linksys router giving out DHCP and the wireless access point giving out DHCP as well?

 

I have a wireless access point at home, it doesn't have a DHCP server on it, yet my firewall gives the DHCP perfectly fine across the wireless access point. I would disable one of the DHCP servers to save you getting all these problems if this is the case. Again, I hope I'm not reading it wrong.

Share this post


Link to post
Share on other sites
when I try to get an IP address the system complains it cannot reach the DHCP server. Also if I do an ipconfig (Windoze) or ifconfig, I get a couple of addresses which I am not sure where they are coming from... I suppose this is an address obtained from the Linksys wireless router.

 

Where do you know from? Maybe it's your neighbour...

 

I'd begin configuring the lan in that order the "internet signal" comes in from the outside, that would as I've understood be:

 

1. Access point

2. Router

3. PC clients

 

Is that the correct sequence?

 

Whenever possible I'd stay away from DHCP. It may be convenient when all works fine, but in case of error tracing and bugfixing it's different.

 

So at first I'd take a normal ethernet cable and try to reach the access point (if possible) or at least the router and work out a config with fixed IP numbers for each device. Wireless devices would get a single IP if that's the only way to reach them and two IPs if they can be reached both over cable and through air.

 

This may look like I consider WLAN as an additional option to cable based ethernet connections and not as a basic function - have to admit that applies properly. But it's the only way I'm able to sort this airy(-fairy) stuff out - and it worked in a couple of situations. Best is to fully discard WLAN at home it if possible...

Share this post


Link to post
Share on other sites

"Where do you know from? Maybe it's your neighbour..."

 

No neighbours.

 

"Is that the correct sequence?"

 

Cable Modem -> Wireless Access Point -> Wireless linksys router -> PC clients (onboard ethernet on motherboard)

 

I'll try with a cable when I can.

Share this post


Link to post
Share on other sites

Well, seems like I found the problem.

 

The resetting of the router helped, BUT at the same time it cleared the "SSID" value , so that the router would not get an IP address from the Access Point.

 

I'm typing this in Windows now, need to change a few settings first to get it working in Linux too, since I tried a lot of things and it's a bit messed up :-x

 

 

Darkelve

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...