Jump to content

Mandriva 2006-3beta


Recommended Posts

I am wondering if anyone else is finding their USB setups shot to hell.

When I was using Mandriva2005-LE, I had my usb ThrustMaster Joystick detected and set up perfectly. The same applied to my Epson Perfection 2450 Photo Scanner. They both worked perfectly. No change has been made to any of the hardware setup in the meantime.


I currently have Mandriva2006-2beta as one OS (clean installed from its three iso's) and the Scanner works AOK there but the Joystick is now not even detected, well it is but only as a UPS and is totally unusable.


On my other Mandriva OS I have Mandriva2006-3beta (also cleaned installed from its three iso's) but neither the Scanner or the Joystick work. The scanner is detected and consequently Sane/Xsane open up Ok but when a scan is selected, there is an extremely long pause and finally an error signal as shown in the snapshot below.


You can see in the second snapshot that the Joystick is still shown as a UPS and as such is still unusable. I have tried all the latest updates but nothing has corrected the problem.

Both devices currently work correctly in Win2000 so there is nothing to suggest they are at fault.


Cheers. John.


Does anyone have suggestions or comments that might help ???


[moved from Software by spinynorman]

Link to comment
Share on other sites

Well I checked my underarm deodorant and it seems ok. I know I have changed socks, undies, shirt etc., so it can't be that.

I am just wondering if maybe I have been sent to "Coventry" for something I said in another post in a different thread. Just wondering. :unsure: :unsure: :unsure:



Link to comment
Share on other sites

Greetings John. This morning I tried setting up the scanner on my Epson multi-function USB printer and had similar problems to yours. I am on 2006 Beta 3 with all updates applied from the 2006 sources. I have not applied any updates from cooker.


The scanner works perfectly in LE2005. In 2006 Beta 3, Harddrake reports that a scanner is available, properly detects it as an Epson, and lists a port for it. But after running the Config tool, xsane says that no scanner devices are available. So I don't get as far you've gotten. The only thing that I see in /var/log/messages that suggests a problem is a message that "DEVNAME IS NOT SET" during the mfp device detection.


Scannerdrake does seems to detect the scanner ok because it creates a config file for it as shown below in /var/log/messages.


Sep 6 08:43:35 scannerdrake[8276]: created file /etc/sane.d/epson.conf


My USB flash drive is detected and I can mount it, so at least that is working ok. Those are the only USB devices I have.


Perhaps the scanner issues have been corrected in the latest cooker packages, I don't know, but Beta 3 sure looks like it has problems in this area. The Beta 4 presumably will be out soon, so maybe it will be corrected in there.


EDIT: forgot to mention that the USB printer itself works fine on my Beta 3 install, but not the scanner.

Edited by jboy
Link to comment
Share on other sites

Extreme thanks arctic and jboy for your responses.

Sorry you too are having the same problem but at least we both now know that it is not us at fault. I have constantly updated from cooker but I have a suspicion that the problem is with Mandriva and not with KDE or Sane/Xsane. When I first experienced the problem, like yourself I was not able to get Sane to startup.


When I looked at /etc/sane.d/epson.conf originally, I noticed that the setup in epson.conf was shown as a scsi device whereas in Mandriva2005-LE it was always shown correctly as a usb device and did not need any alteration and the scanner always worked without any tweaking after the OS installed.


When I edited epson.conf to what I knew should be its correct text, then I found that I could get Sane to correctly open up and appear as normal but when you clicked preview or scan then after a very long delay I got the error shown in the screenshot.


Also in Mandriva2005-LE I always found that the usb Joystick was always detected and auto setup correctly with no tweaking of settings required.


I am severely tempted to reinstall Mandriva2005-LE in place of the2006-2beta just so I can find where and what appears for both the scanner and the joystick in terms of settings.

At the moment I do not know where to look for the joystick settings nor do I know if there are any since the device is not detected. When a usb joystick shows up as being detected as a UPS device then something fundamental has been screwed up in Mandrivas hardware detector.


Note that both scanner and joystick are unusable in 2006-3beta but only the joystick problem exists in 2006-2beta and 2006-3beta and considering how long 2006-2beta has been out now it is quite a disappointment to say the least.

This is not a moan against ANY of the Mandriva team who work so damned hard at these things. Perhaps no one there knows of this problem yet but I don't even know how or who to tell. I also guess it could be low on their list if they do know about. I never cease to be amazed at how any of you programmers and compilers even do what you do or even know where to start. Bl***y amazing. :thumbs::thumbs::thumbs:


I got the joystick as a precursor to learning how to use FlightGear (flight simulator) before buying more advanced flight simulation hardware such as pedals and steering pedestals. No point in buying advanced gear if I don't know how to use the simple generic tool first. I have since learned that FlightGear is so far ahead of the Microsoft product that versions of it are used for certified flight simulation training and the Microsoft one is not and apparently never ever likely to be. ( Hell that was good being able to know that)


Sorry for the digression.


If you think you can help in any way with our usb problems then please do post and if I find out anything then be assured that I will post it here.


Cheers. John.

Link to comment
Share on other sites

I have beta3 upgraded from 2005LE and now everytime I login to KDE a popup appears saying "installing software.." then another one then after a little time an error message saying something like "Couldn't install CUPS printer service". I have a HP printer which worked under 2005LE. I was too lazy to mess with it yet though.

Link to comment
Share on other sites

What I have found is that from 2006-3beta onwards is that usb is really screwed up. I hope it all gets fixed in 2006-Official when it eventually comes out or there is going to be a huge deserting of Mandriva. I have found that there is NO /dev/usb at all and since Sane's epson.conf is written to look for the Epson USB scanner there then obviously it cannot start the scanner. Auto detection says that the scanner is detected at libusb:005:002 whatever that means but even editing epson.conf to try to point it there (wherever that is ) makes no difference. 2006-2beta however did have /dev/usb so there is no problem there, although as I posted earlier, the joystick is still not detected or working and it is USB also.

I suspect that the entire USB arena has been rearranged but most of the usb related applications have not caught up yet, hence the stupid things such as the joystick being detected as a UPS and even seemingly allowing you to configure it somehow, despite the fact that it cannot operate as a ups and is totally useless to use as a joystick.

I have installed all the latest updates from cooker a few hours ago including the latest kernel 2.6.12-12.mdk and its matching kernel source but problem is still there.

As kristi mentioned in her post, I too have found mplayer to be extremely unstable and unable to close it down except by using ctrl+alt+esc, but since I hardly ever use it it is no big deal.

If any one has newer info then please let us know because there are others besides myself who could use the info or suggestions.


Cheers. John.

Link to comment
Share on other sites

I noticed simmilar occurances in RC2

I had to handmount my usb storage (sda1),

my Canon A85 camera also had problems (I finally got it to work through gtkam).

And nothing automounts as it did in 2005.


The system is usable, but not enjoyable. I'll wait till official comes out, if it is the same, I'll switch back to 2005.

Link to comment
Share on other sites

Thanks Leo and Solarian for your posts.

I have found that with the new cooker releases and fully updated that the Joystick problem has been corrected but now FlightGear doesn't work. Hilarious isn't it?. Talk about running around in circles. :D :D :D


The scanner problem still exists and I think this is because Sane/Xsane hasn't caught up with all the udev and usb changes and as a consequence it is pointing Sane to the wrong places and I don't know which are the right places. So like Solarian I am just going to wait until 2006 is available and and continue to use my 2005_LE when I need to do scanning or run Flight Gear. I don't want to spend so much time to try and solve a problem that I do not know the first thing about when it will likely be eliminated in a few weeks.


Since I started using cooker and the subsequent problems that one can encounter, it has made me appreciate even more just what an amazing job Mandriva does in trying to make all these differently, individually produced packages work together. Fantastic work Mandriva.


Cheers. John.

Link to comment
Share on other sites

Thanks kristi.


I just completed a full update abut a half hour ago but still no joy. Will give another try.

Funny you should mention hal but now I come to think of it most of this started shortly after hal seemed to come into prominance. I have also noticed that it seems to be updated about three times in every 48hrs so there must be a heck of a lot of problem solving going on with this app.

I am now doing an update run so will post if things change.


Cheers. John.


Bt the way. Thanks to all who moved this thread automagically to Cooker. Neat.




Extra info.

What I find odd with hal is that although it shows up as a distinct rpm package for update and you install it, when you go into MCC to Software to uninstall, you cannot find a hal rpm listed at all. It seems that after you install it it then hides so you cannot remove it except possibly by means of the CLI.

Edited by AussieJohn
Link to comment
Share on other sites

Hi kristi. I installed v3 and have been doing constant cooker updates but remember that these are package updates and not v3 updates.

I am waiting until my Australian ISP Telstra Bigpond has rc2 or later available on its free unmetered website ( doesn't count in the download limit) the same as v2 and v3 were. I downloaded updates late last night and found no change and am at this moment half way through the downloading of the latest updates.

I too am pleased about the new cooker section. Despite some other peoples misgivings, I truly think it will contribute directly to Mandriva itself in its own unique way.


Cheers. John.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...