Jump to content

Need help installing my Lexmark [solved]


Recommended Posts



I have a Lexmark E234, I want to install on Mandriva. When I go to MCC to add a new printer, it autodetects the correct printer, however, it installs a completely different model. When I try to manually configure it, E234 isn't even an option. But it will let me select a PPD driver off the installation disk. The problem with that is, the PPD files are just text files saying to download drivers from the website. I went to Lexmark's site, and that printer didn't show there either. As a noobie, I think somethings wrong :cheesy: .


Please, any help would be great


Thank you in advance

Link to comment
Share on other sites

i think you misunderstood that.

type in "root" as name and add the root password


Sorry everyone, I did misunderstand. I finally did get in then I started to "add printer". All seemed to be going well, until it wanted me to enter "model/driver for E234". That printer and driver were not available only the following were:


Lexmarks - 4076, Z11, Z42, Z43, Z52, Z53 and ALLinONE


However, when it asked for "device for E234" it let me choose "Parallel Port #1 (Lexmark Internation Lexmark E234).


Not sure what that means?

Link to comment
Share on other sites

  • 2 weeks later...
Printers are usually either parallel port or usb. Is your printer supported in Linux? If Cups does not have drivers for your model you may have to find one somewhere. You may want to Google for your printer and Linux support.


Thank you for your response. Before I tried to configure through CUPS I tried MCC and it autodetected my printer (E234). However, when I chose to install it, it installed a different model (Lexmark3000). It does have an option there saying to try the PPD file, which is on my install disc. I tried that and found out it's only an informational file telling to go to lexmark website. Which I did, and they don't even have they're own printer numbver, sad. Anyway, I finally got into CUPS and it only gave me the printer type/drivers:


Lexmarks - 4076, Z11, Z42, Z43, Z52, Z53 and ALLinONE


My printer is on a parallel port, and I feel Linux would support it, or how did it autodetect it?


I'm at a loss :help:

Link to comment
Share on other sites

I recall seeing Lexmark printer problems on the board. You may want to search for them to get some suggestions. I do recall something about their drivers. Do the board search and also use Google. It is odd that Lexmark doesn't have the printer model listed. Could the same printer have two model numbers? Did you install the printer on a Windows system? If so how did it show up (model number). That's all I can say now, good luck.

Just did a google, got a Lexmark page with drivers for the E234n laser printer. It has Red Hat and Suse drivers. They may also work for Mandriva. lexmark drivers

Edited by polemicz
Link to comment
Share on other sites



I went back to Lexmarks

to double check. And to my surprise they listed that printer/driver along with many others that weren't there before. Anyway, it lists the drivers and the only Linux distros supported for that printer is SuSE and Red Hat. I am going to take your advice and do a board and google search more.


I do have that printer installed on my XP side, but there were install discs.


A friend of mine came across this URL I'm going to read over it and see what I can find. If all fails, I guess I'll have to contact Lexmark.


There has to be a way, I just don't understand how it can autodetect the right model and then not support it.



Thanks again for all your help, including all that suggested.

Link to comment
Share on other sites

Anyway, it lists the drivers and the only Linux distros supported for that printer is SuSE and Red Hat.
if they support these two, i guess they have rpms or tarballs available at their site? if they do have such packages, you can try to extract the source code and recompile it or you could simply try to install a redhat rpm (in case there is one). i had installed redhat stuff on mandy before and it worked.
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...