Jump to content

Newbie went away [solved]


Recommended Posts

I was trying to learn on MDK 10.1 a few months back, and the drive I had it on crashed, and I just never reinstalled until now. The first thing I went to do was run EASY-URPMI from your site, plf-free went fine, then when I tried to run update updates, heres what I got:


[root@10 gian]# ftp://mirror.cs.wisc.edu/pub/mirrors/linu...5/main_updates/ with media_info/hdlist.cz

bash: ftp://mirror.cs.wisc.edu/pub/mirrors/linu.../main_updates/: No such file or directory

So then I tried a different mirror site and got this:


[root@10 gian]# ftp://carroll.cac.psu.edu/pub/linux/distr...5/main_updates/ withmedia_info/hdlist.cz

bash: ftp://carroll.cac.psu.edu/pub/linux/distr.../main_updates/: No such file or directory


Anyone have any idea to what I did wrong? I'm sure this newbie did something wrong. I didn't continue with EASY-URPMI because I wanted to see why this happened first.




Thank you all very much in advance,

Link to comment
Share on other sites

When you do the Easy-Urpmi routine and after pressing 3, you are shown the necessary address. When you copy it into Konsole as su or as root you are required to copy the ENTIRE line into konsole not just from the ftp://........... part

See the following example which I just got for Update in Easy-Urpmi:-


urpmi.addmedia --update updates ftp://anorien.csc.warwick.ac.uk/Mandrakel...5/main_updates/ with media_info/hdlist.cz



Do it that way and you will have no problems.




Edited by AussieJohn
Link to comment
Share on other sites

Thanks for your help, I appreciate it.


If I can bug you guys for something else or anyone who's listening. Is libstdc++.so.5 a downloadable file. I don't appear to have it on my system.

The instruction say:

tar -xzvf /home/me/location/firefox-1.0.4.installer.tar.gz

cd /firefox-installer



I did that and got the following

[gian@10 firefox-installer]$ ./firefox-installer

./firefox-installer-bin: error while loading shared libraries: libstdc++.so.5: cannot open shared object file: No such file or directory


So that's when I assumed it wasn't installing due to that file. So, I was wondering if that's a file that can just be downloaded


excuse me for my ignorance


thank a lot

Link to comment
Share on other sites

yes, you can download all packages with the above mentioned easyurpmi tool. you can download it either via a terminal (urpmi libstdc++) or using the mcc.

Link to comment
Share on other sites

If a file which has a .so at the end of it , it means it is part of a larger file which may have many more other .so files in it. That is why you could not get a google reference to it. Yes it is one of two parts of libstdc++. It should be on your Install discs.

Open MCC or Mandrake Control Centre ----> Software Management --->Look at installable software and install software packages -----> All Packages Alphabetical scroll down until you see the libstdc++ package and select it for install. If it has any dependencies, it will tell you and select OK then click Install at the bottom and follow any instructions it will give you about what number disc to insert and so on. None of this needs to be done from the command line at all. Command Line users just prefer that way, but for those not used to command Line it is an awkward way of doing this simple task.


Cheers. John.

Edited by AussieJohn
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...