Jump to content

the disappearing Nvidia module


Recommended Posts

I have run out of tricks up my sleeve getting NVIDIA working here. I have installed these drivers hundreds of times... but this time... the driver dissappears upon reboot.


(EE) NVIDIA(0): Failed to initialize the NVIDIA kernel module!

I do all the usual stuff... log out of kde, install, load "glx", nv to nvidia, startx. Everything is fine until I reboot. I have even tried adding "nvidia" to modprobe.preload and also tried the multimedia kernel with its matching source (of course)


We are running xorg-x11-6.7.0-4.2.101mdk and Official 10.1 (updated) and have a GeForce4



Link to comment
Share on other sites

What do you get when you do: modprobe nvidia?

It just goes back to #

How (syntax) did you add the nvidia line in modprobe.preload?

edited both with su kate and also vi (insert)

# /etc/modprobe.preload: kernel modules to load at boot time.
# This file should contain the names of kernel modules that are
# to be loaded at boot time, one per line.  Comments begin with
# a `#', and everything on the line after them are ignored.
# this file is for module-init-tools (kernel 2.5 and above) ONLY
# for old kernel use /etc/modules


Link to comment
Share on other sites

Right now lsmod shows the nvidia module loaded... but when I reboot... it will be gone..


Let me show you my xorg.conf --- before and after (maybe it will give us a clue):


Now... after a fresh NVIDIA install and while its working:

# File generated by XFdrake.

# **********************************************************************
# Refer to the XF86Config man page for details about the format of
# this file.
# **********************************************************************

Section "Files"
   # Multiple FontPath entries are allowed (they are concatenated together)
   # By default, Mandrake 6.0 and later now use a font server independent of
   # the X server to render fonts.
   FontPath "unix/:-1"

Section "ServerFlags"
   #DontZap # disable <Crtl><Alt><BS> (server abort)
   AllowMouseOpenFail # allows the server to start up even if the mouse doesn't work
   #DontZoom # disable <Crtl><Alt><KP_+>/<KP_-> (resolution switching)

Section "Module"
   Load "dbe" # Double-Buffering Extension
   Load "v4l" # Video for Linux
   Load "extmod"
   Load "type1"
   Load "freetype"
   Load "/usr/X11R6/lib/modules/extensions/libglx.so"

Section "InputDevice"
   Identifier "Keyboard1"
   Driver "keyboard"
   Option "XkbModel" "pc105"
   Option "XkbLayout" "en_US"
   Option "XkbOptions" ""

Section "InputDevice"
   Identifier "Mouse1"
   Driver "mouse"
   Option "Protocol" "ExplorerPS/2"
   Option "Device" "/dev/mouse"
   Option "ZAxisMapping" "4 5"

Section "Monitor"
   Identifier "monitor1"
   VendorName "Packard Bell"
   ModelName "Packard Bell 1511SL"
   HorizSync 30-62
   VertRefresh 50-120
   # Sony Vaio C1(X,XS,VE,VN)?
   # 1024x480 @ 85.6 Hz, 48 kHz hsync
   ModeLine "1024x480"    65.00 1024 1032 1176 1344   480  488  494  563 -hsync -vsync
   # Dell D800 and few Inspiron (16/10) 1280x800
   ModeLine "1280x800"  147.89  1280 1376 1512 1744  800 801 804 848
   # Dell D800 and few Inspiron (16/10) 1680x1050
   ModeLine "1680x1050"  214.51  1680 1800 1984 2288  1050 1051 1054 1103
   # Dell D800 and few Inspiron (16/10) 1920x1200
   ModeLine "1920x1200" 230 1920 1936 2096 2528 1200 1201 1204 1250 +HSync +VSync
   # TV fullscreen mode or DVD fullscreen output.
   # 768x576 @ 79 Hz, 50 kHz hsync
   ModeLine "768x576"     50.00  768  832  846 1000   576  590  595  630
   # 768x576 @ 100 Hz, 61.6 kHz hsync
   ModeLine "768x576"     63.07  768  800  960 1024   576  578  590  616

Section "Device"
   Identifier "device1"
   VendorName "NVIDIA Corp."
   BoardName "NVIDIA GeForce4 (generic)"
   Driver "nvidia"
   Option "DPMS"
   Option "IgnoreEDID" "1"

Section "Screen"
   Identifier "screen1"
   Device "device1"
   Monitor "monitor1"
   DefaultColorDepth 16
   Subsection "Display"
       Depth 8
       Virtual 1024 768
   Subsection "Display"
       Depth 15
       Virtual 1024 768
   Subsection "Display"
       Depth 16
       Virtual 1024 768
   Subsection "Display"
       Depth 24
       Virtual 1024 768

Section "ServerLayout"
   Identifier "layout1"
   InputDevice "Keyboard1" "CoreKeyboard"
   InputDevice "Mouse1" "CorePointer"
   Screen "screen1"

Link to comment
Share on other sites

After a fresh reboot... startx fails... the xorg.conf file is the same.


I am seeing "nvidia" show up with lsmod now... maybe something to do with glx as I see the following now in the log file ???


(EE) Failed to initialize GLX extension (NVIDIA XFree86 driver not found)

Link to comment
Share on other sites

Don't reboot :). Just restart X (ctrl - alt - backspace, or open a console, log in as root and type: init 3, or type: killall X). Make sure the module is loaded and restart X, with the correct xorg.conf


and change this:

Load "/usr/X11R6/lib/modules/extensions/libglx.so"


to Load "glx"

Link to comment
Share on other sites

Afraid I have to reboot and according to lsmod... the module is loaded... but X still fails. Here's the last fiew lines of the log when it fails:


(EE) NVIDIA(0): Failed to initialize the NVIDIA kernel module!

(EE) NVIDIA(0):  *** Aborting ***

(II) UnloadModule: "nvidia"

(II) UnloadModule: "vgahw"

(II) Unloading /usr/X11R6/lib/modules/libvgahw.a

(EE) Screen(s) found, but none have a usable configuration.

the error as it appears on console after typing "startx"

Failed to initialize the NVIDIA kernel module!

  *** Aborting ***

Screen(s) found, but none have a usable configuration.

no screens found

fatal server error

What I do at this point is change "nvidia" back to "nv" which gets me running GUI again.

I gotta be using the right settings... cause it works everytime I install it... but upon reboot something is failing.

Link to comment
Share on other sites

  • 4 months later...

Dunno whether it would affect it, but make sure you have the correct kernel-source, cuz if you "urpmi kernel-source," I think Mandriva will install 2.6.11-12mdk rather than 2.6.11-6mdk. Also try a build just in case. Again, I'm relatively new, but just in case it might do something :).

Link to comment
Share on other sites

Newest nvidia driver will not work properly with older cards.

On ArchLinux that I'm using the devs have issued an alternative (and UNOFFICIAL!) legacy nvidia driver, which seems working decently with old nvidia cards.

Old cards not supported anymore by the nvidia driver are





Vanta/Vanta LT

RIVA TNT2 Model 64/Model 64 Pro

Aladdin TNT2

GeForce 256

GeForce DDR


GeForce2 GTS/GeForce2 Pro

GeForce2 Ti

GeForce2 Ultra

Quadro2 Pro


Of course this shouldn't be scoopy's case (he has a Geforce4), so I guess that something is wrong in the kernel sources. The one and only time I have had such a problem in the past I had to change one kernel resource a little bit (as they pointed me at the nvidia support forums) and after that the modules built properly.

Edited by scarecrow
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...