Jump to content
Sign in to follow this  
Guest Aaack

NVIDIA driver Problem on MDK 10

Recommended Posts

Guest Aaack

Hello everyone!!

 

I'm looking for help here.

I bougth a brand new MSI Geforce FX 5900XT 128 Mb RAM Graphics Card.

I changed my old MSI Geforce 4 MX 440 for the new one and just reboot thinking that the hardware chage was a piece of cake (I've previoulsy did the same a year ago, when I'd change my OLD TNT2 for the GForce 4, without a problem, without even upgrade the driver).

And then my problems started.

 

A bit of history now: I've changed the NVidia drivers every time without problems, My NVidia cards worke really good on my MDK box (from version 8.0 to 10.0),

My systen is:

P4 2.6 MHZ

512 MB RAM DDR

2 HDD 120 Gb on ext 3

dual boot (winXP-MDK 10 kernel 2.6.3-7)

Dual head using the Twinview extension.

Working VIVO, (thanks to rivatv (video IN) and nvtv (tvout)

 

Again that was my prior configuration., I've managed to get a MSI with the same feautes (VI-VO, 2 Heads connectors) in order to keep my workflow.

 

Well the first time I tried to start MDK and it hung up really bad, black screen monitors went to energy save mode and that's was all, no ssh response from otrher pc, no reaction at all.

Ctrl-Alt-SysRq-S/U/B

the second time (without touch anything) the X server complaint and stopped but my pc reamined usable so I deactivate the autolaunch of the x server via drakconf (textmode)

then killall gdm-binary

sh NVIDIA-Linux-x86-1.0-6629-pkg1.run

the installer went flawlessly.

reboot

at the root prompt: gdm

BANG the screen went out of sync, (there was a lot of blinking horizontal lines, a very distorted representation of the prompt, in fact I did wrote "reboot" and the pc rebooted normally)

I've checked for docmentation, I've commented out severla lines of my XF86Config-4, included the twinview configuration.

I've checked if the driver loaded correctly. It did.

Just in case i typed "modproe nvidia" and started gdm again.

Violent hung up.

Ctrl-Alt-SysRq-S/U/B

And again and again.

I was unale to start X, no matter what trick I used.

I booted from the kernel 2.4 with a driver reinstall, didn't worked.

So.. .I booted windows, just to discard a hardware problem

The graphic card worked just fine, doom3 was a beauty, as NFSU2.

So now I'm stuck and completely clueless.

 

In the included file I've paste the XF86Config-4 file and the XFree86.0.log before and after I try to execute GDM.

 

On a last note:

1. Yes, i¡ve tried the prior driver 6111 with an identical result.

2. Yes , XServer run fine with the "nv" driver

3. Yes, I know my kernel is old, but i really don't know how to compile a new one, and i'm afraid to make things worst if I try.

 

Please, help me.

logs.txt

Edited by Aaack

Share this post


Link to post
Share on other sites
Try running XFdrake? Set  Option "NvAGP" "3" (or "0")?

 

I've got a Geforce MX440, I use it with SuSe (9.1) and someone on the nVidia forums advised me to set NvAGP to 0 or 2. I set mine to 0 (zero). After that 3D didn't crash any longer for me.

Share this post


Link to post
Share on other sites
Guest Aaack

Yep NvAGP 0 did the trick, thank you very much!!!

Now my X Server starts fine.

Now I'm getting a different problem. (Should I start a new topic?)

The twinview don't work....

 

With all the twin view lines commented out I have the correct resolution for my monitor (1024*768), but if I try to enable the second one I get something like 640*480 in the first and the second goes to DPMS mode...

 

Any thoughts?

 

PS: Sorry for that duplicated post. I guess I was too desperado =)

Share this post


Link to post
Share on other sites

You can just keep posting here, since your problem does not seem completely solved yet. You can start a new one if you really want to though. Either is fine with me.

 

Don't worry about the duplicate post. Just remember for next time :)

Share this post


Link to post
Share on other sites

That's a bug with the latest nvidia drivers I believe. With the 1024x768 it's not possible to use twinview or something with your old settings. (I forgot the deatils).

 

Use this (works for me):

Option "MetaModes" "1024x768 +0+0, 800x600 @800x768 -800+0; 1024x768 +0+0,800x600 @1024x768 +0+0; 1024x768 +0+0, NULL;  NULL, 800x600"

 

for your metamodes. With ctrl-alt-+/- you can change the settings.

Share this post


Link to post
Share on other sites
Yep NvAGP 0 did the trick, thank you very much!!!

Now my X Server starts fine.

Now I'm getting a different problem. (Should I start a new topic?)

The twinview don't work....

 

With all the twin view lines commented out I have the correct resolution for my monitor (1024*768), but if I try to enable the second one I get something like 640*480 in the first and the second goes to DPMS mode...

 

Any thoughts?

 

PS: Sorry for that duplicated post. I guess I was too desperado =)

 

I believe you might want to change that NVAgp setting, they are as follows...

 

0 : disable agp

1 : use NVIDIA's internal AGP support, if possible

2 : use AGPGART, if possible

3 : use any agp support (try AGPGART, then NVIDIA's AGP)

 

NVAgp = 1 fails for many unsupported chipsets, so it's not an uncommon problem. I would try 2 first and if that fails switch to 3, works on many unsupported chipsets (such as mine, the VIA KM266, also works on KT2xx/KT4xx, KT6xx, etc...). You will notice a performance difference should you decide to play any games.

 

I don't think this will impact your TwinView problem, but at least you will get the performance you paid for :headbang:

Share this post


Link to post
Share on other sites
Guest Aaack

First let me thank you all for the patience and the ideas.

 

I have tried NvAGP 2 and 3 without success, but Option "NvAGP" "1" worked just fine. (?)

I've tried this setting with doom3 for linux and yes it's just beautiful :D

 

Anyway I'm still in the strugle to make my second monitor work. With no success.

 

I've tried the metamode suggested by Devires and it result in a clone of the primary CRT at 800x600 on a virtual desktop of 1024x768, really weird.

I've tried to name both Monitors as reported on the XFree.0.log in vain.

Apparently Xserver use a "virtual size" of 1024x768 and there's no way to convince X to use a "virtual size" of 2048x768

I'll include my new XF86Config-4 and XFree.0.log files

 

When i set the metamodes in 1024x768,800x600@1024x768 all I've is a sleeped second monitor and a primary monitor at 800x600...

 

Hold on...

 

Did I connected the monitors right???

 

Cheching....

 

<time spent>

</time spent>

 

Yes, I did. :wall:

 

Ok now I'm oficially clueless.. again.

 

Any ideas?

 

thanks in advance!!

Share this post


Link to post
Share on other sites
Guest Aaack

Update:

(Still no solution, but... hell!! I'm learning a LOT with this problem) :afro:

 

Ok I rolled back to the 6111 driver, but the behavior was the same, the second monitor went to DPMS.

Then I add some metamodes:

1024x768,NULL

800x600,NULL

640x480,NULL

According to the Xfree.0.log the "virtual size" is 1024x768, so any metamode bigger than that is incompatible, so X took the last 3 metamodes using NULL for the second monitor.

At least I can go from init 5 to init 3 and vice versa without have to kill any dm.

I've installed again the 6629 driver.

 

I've searched the knowledge base from NVidia's site but there's no mention of the virtual size at all.

Can someone explain what's that and how can I change it?

 

Of course I've installled the drivers in windows XP and the dual head worked flawlessly. My theory is: if it workedon windows it'll surely work on linux.

Share this post


Link to post
Share on other sites

http://www.nvnews.net/vbulletin/archive/in...php/t-1071.html

 

I looked it up :). The problem is with the 1024x768 resolution. If your second monitor (mine is a tv) can't do 1024x768 (it can but I guess that is the bug) you won't get a non-virtual desktop.

 

They post a hack

change Option "MetaModes" "1024x768,640x480" to "1024x768, 640x480@1024x768" it will be a real virtual resolution.

 

Good luck.

Share this post


Link to post
Share on other sites
Guest Aaack

I SOLVED THE TWINVIEW ENIGMA!!!!

 

Well, First of all thank you all very much for the support and the patience.

 

Now, how I solved it:

 

X server always complaint about the "virtual size" of the screen, every metamode I set up was bigger than that virtual size...

 

So (and thi is my mistake) I never looked down beyond the "Device" section of the XF86Config-4 file.

 

Below the "Device" section there's a definition of the "Display" in the "Screen" section.

 

like this:

 

Subsection "Display"

Depth XX (the color depth in bytes)

Virtual XXXX XXXX (the virtual resolution in pixels Width Height)

End Subsection

 

All I've done was change that 1024 768 for 2048 768

And that was it.

 

I've included my XF86Config-4 file for the rest of you who strugled with this kind of problem

 

In that file I have all the knowledge I've recollected during the last 4 days.

XF86Config_4.txt

Share this post


Link to post
Share on other sites

I had exactly the same issue when I set up my TwinView, so it's a good tip. The documentation, annoyingly, doesn't seem to suggest in any way that you'll have to do it. Wish I'd remembered about it in time to help Aack - sorry, man!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...