Jump to content
Sign in to follow this  
volfro

mouse/keyboard issues fixed, but still no sound

Recommended Posts

H'lo again,

 

I upgraded (well, formatted and installed) to 10.1 Community, which ended up fixing my keyboard/mouse issues.

 

However, sound still skips severely, no matter the driver I try. It's onboard sound on a VIA motherboard; the default kernel driver is via_82xx or something.

 

When I used Knoppix, the sound worked. It used the same default driver, but the kernel is 2.4.xx, while MDK10 uses 2.6. The sound in Knoppix was kinda crappy, but that's better than no sound at all; is there a way to downgrade the sound drivers in the kernel, or add older sound drivers, from that distro of Knoppix, to my drivers? I don't want to recompile the entire kernel...

 

Thanks all.

 

volfro

Share this post


Link to post
Share on other sites

i got the same VIA card...the ALSA driver is snd_via82xx and it's absolute crap in sound quality.

 

you should change to the older OSS driver via82cxxx_audio, which sounds much better. Putting 'via_82cxxx_audio' in /etc/modprobe.preload will be enough to be able to use the driver.

 

You *might* have to edit the module files to stop the ALSA module from booting...just try the above suggestion first.

 

At last resort, compiling the kernel with the OSS module is guaranteed to work. It's not that hard... :)

Share this post


Link to post
Share on other sites

Okay, stupid question:

 

I don't have permissions to edit that file. How do I edit it? I logged in as the SU, but how do I launch it as the SU? I know I've done that before, I just can't remember how...

 

Thanks!

Share this post


Link to post
Share on other sites

Okay. Figured it out.

 

But it's still no go. My sound skips terribly; the startup sound itself takes more than a minute to complete.

 

What other module things need editing? Or is that a solution? I've been grappling with this for some time now...I want music in Linux!!

 

thanks again

Share this post


Link to post
Share on other sites

I think its best when you configure the soundcard with the MCC. If you have setup everything correctly, try different mixer settings (open kmix or alsamixergui). Stop/start arts, experiment with different xmmx plugins, with different players etc etc.

 

Good luck

Share this post


Link to post
Share on other sites

as root, type

 lsmod

and the module via82cxxx_audio should be there. if snd_via82xx is also there, type

modprobe -e snd_via82xx

to unload it.

 

then, can you post the output from 'lsmod' here?

Edited by arthur

Share this post


Link to post
Share on other sites
then, can you post the output from 'lsmod' here?

[root@localhost vincent]# lsmod
Module                  Size  Used by
md5                     3584  1
ipv6                  230916  15
autofs4                15268  0
af_packet              16072  2
usbhid                 41088  0
floppy                 55088  0
8139too                20928  0
mii                     4224  1 8139too
ide-cd                 37280  0
cdrom                  37724  1 ide-cd
loop                   12520  0
nls_iso8859-1           3680  1
ntfs                  147964  1
supermount             34804  1
via-agp                 7360  1
agpgart                27752  1 via-agp
via82cxxx_audio        26440  2
soundcore               7008  3 via82cxxx_audio
ac97_codec             16844  1 via82cxxx_audio
uhci-hcd               28752  0
usbcore               103172  4 usbhid,uhci-hcd
genrtc                  7444  0
ext3                  120680  2
jbd                    49080  1 ext3

 

Last night I was trying to get the ALSA drivers up and running; I updated to the latest RC, but it didn't do anything. So I switched back over to OSS using harddrake and re-added "via82cxxx_audio" into the modprobe.preload file.

 

I went ahead and modprobe -r'ed the ALSA drivers, but it said they weren't in the kernel, so they're definitely not there...

 

That lsmod is the results, after a restart. The module's loaded properly, right?...What else should I do?

Share this post


Link to post
Share on other sites

Both. It's not just crappy...It's un-listenable. Just like earlier, it skips so severely that it takes a looooong time for even just the logon sound to complete. XMMS freezes when I try to play music.

 

It's been doing this since I installed MDK 10, and I upgraded hoping the later kernel would fix it...

 

When I updated the ALSA drivers, the problem was somewhat less severe--i.e. still unlistenable, but it played slightly more of the sound at a time, instead of just blips.

 

And no matter the buffer size i choose using KDE's sound system, the problem stays pretty much the same.

 

I don't understand! What can I do?

Share this post


Link to post
Share on other sites

i don't understand how you could update the ALSA drivers separately from the kernel...but anyway, bleeding-edge kernels supposedly have some improved VIA chipset support. You might want to try them.

 

You can try to find out which drivers Knoppix loads on your computer (do lsmod in Knoppix) and which kernel it uses. Unfortunately sometimes everything seems the same but the sound still doesn't work or is too faint, which was my case, prompting me to dump mandrake in favor of gentoo.

 

Debian is also a good candidate since Knoppix was based on it, as well as Ubuntu.

Share this post


Link to post
Share on other sites

There were instructions for installing the drivers on alsa-project.org, but the VIA section seems to be down, or I'd send you a link.

 

But they're modular sound drivers, they're not part of the kernel...at least I don't think. I'm still a noob, as you can probably tell.

 

Should I go Debian? Or Gentoo? I don't know if I'm advanced enough for either of those...

 

You're right, though, I should try a newer kernel. I tried before and had problems with make modules_install. I couldn't get it to work. But I will try again.

 

And I'm pretty sure Knoppix uses the OSS drivers, but the edition I have is the older 2.4 kernel. Is it wise to downgrade?

 

I went ahead and did lsmod in Knoppix...

 

Module                  Size  Used by    Not tainted
autofs4                 8756   1 (autoclean)
af_packet              13544   0 (autoclean)
agpgart                42660   0 (unused)
via82cxxx_audio        19448   1
ac97_codec             11916   0 [via82cxxx_audio]
uart401                 6052   0 [via82cxxx_audio]
sound                  55276   0 [via82cxxx_audio uart401]
8139too                13736   1
mii                     2240   0 [8139too]
crc32                   2816   0 [8139too]
serial                 52100   0 (autoclean)
hci_usb                 8924   0 (unused)
bluez                  31044   1 [hci_usb]
audio                  42140   2
soundcore               3428   6 [via82cxxx_audio sound audio]
pwc                    44912   0 (unused)
videodev                5600   1 [pwc]
pcmcia_core            39840   0
thermal                 6564   0 (unused)
processor               8976   0 [thermal]
fan                     1568   0 (unused)
button                  2508   0 (unused)
battery                 5888   0 (unused)
ac                      1824   0 (unused)
rtc                     7036   0 (autoclean)
cloop                   8740   2
ieee1394              183076   0
usb-storage            61696   0 (unused)
usb-uhci               21644   0 (unused)
usbcore                57600   1 [hci_usb audio pwc usb-storage usb-uhci]
ataraid                 6180   0
ide-cd                 28512   0
ide-scsi                8816   1

 

Seems that there's more going on in the sound department...

Edited by volfro

Share this post


Link to post
Share on other sites

actually in mandrake you can install a kernel the easy way.

just add a Mandrake Cooker ftp mirror in Media Manager, then urpmi the kernel.

 

You can find more info HERE. it's a bit old, but still an excellent easy guide. Hopefully you'll find the 'Cooker' or 10.1 folder and be able to get a newer kernel. :)

 

Once you've got Mandrake mastered, other distros will be a breeze to learn. Even if I'm not using it anymore, it's an excellent distro.

Share this post


Link to post
Share on other sites

That's cool! I didn't know you could do that.

 

But alas, I couldn't find a later kernel for 10.1. Every time I tried to access the mandrake-devel folders, I was denied access. I think it's running 2.6.8, but the latest 2.6 is under the Mdk 10 directory, and it's 2.6.3.

 

Are there any other sources I could go to for that?

Edited by volfro

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...