Jump to content
Guest olavi

how to change icon sizes in k-menu?

Recommended Posts

Guest olavi

using mandrake 10. i have 16x16 icons there i guess, but i want bigger ones. how to change these sizes?

Share this post


Link to post
Share on other sites
Guest olavi

that changes only menu (bottom), but i want to change icons located in K-menu (log off, lock, help, etc..)

Share this post


Link to post
Share on other sites

bump.

 

I, too, would love to know. The right-clickling applies only to the taskbar icon size, not to the icons in the k-menu itself, such as office, internet, multimedia, and the icons that are deeper in the menu tree.

 

I tried to look at all the look 'n feel options, but to no avail. Maybe there's a console command?

 

I'm using KDE 3.2, Mandrake 10 Official.

 

I'd appreciate any help :-)

Share this post


Link to post
Share on other sites

Go to /Look and Feel/Icons and look at the advanced settings, there are some options but I haven't played with them too much yet.

Share this post


Link to post
Share on other sites

No luck.

 

Under the "advanced" settings, I treid the "panel" option, but that is shaded and can't be changed. The other ones don't make any difference, either.

Share this post


Link to post
Share on other sites
No luck.

 

Under the "advanced" settings, I treid the "panel" option, but that is shaded and can't be changed. The other ones don't make any difference, either.

Hmmm, at work now so I can't look, it may also depend on your icon set having all the correct sizes of icons, I know the option is greyed out on some of mine and not others, but I don't recall which?

Share this post


Link to post
Share on other sites

I put this tip in Other Distributions > SUSE 9.1. It should also work in Mandrake:

 

 

Open and edit the following file:

 

~./kde/share/config/kickerrc

In this file there's a section at the bottom that is called [menus]. There's a value such as 15, for an option that is called MenuEntryHeight. Change this value to 32.

 

(you can view these kinds of hidden files/folders by enabling "Show Hidden Files" in Konqueror).

 

IF MenuEntryHeight is not there, see if adding it as follows will work:

 

MenuEntryHeight=32 .

 

Of course, you'll have to su to root >password, then use your favorite editor (gedit, vi, vim, Kwrite, kate, whatever) to edit it.

 

Then I'd reboot just to make sure the change is made. Usually rebooting isn't necessary, but this may save you an extra step if it is.

 

Please respond with your results.

 

Richard

Share this post


Link to post
Share on other sites

Well, still nothing.

 

I logged in as root, and edited that file.

 

MenuEntryHeight was not there, so I added it - alphabetically, even.

I tried it with 32 first. Once I changed it and logged in to my user account, there was no change.

I went into "advanced" in the icons section just to make sure. The icon size in the "panel" area was still

shaded.

 

I even tried the same procedure usng a height of 48. Still nothing.

 

Both times I rebooted the system, just to make sure.

 

Strange how in "panels", there's a 32 option, but it's shaded . . . you can't change it. Adding the MenuEntryHeight changed nothing.

 

Another thing I found was that with SUSE you can, in addition to the above, open up the console or press alt F2, and type in "dcop kicker pnael restart." That didn't work, either. I tihnk this whole procedure applies only to SUSE.

 

Too bad. I see no reason why the k-menu icons have to be so small in Mandrake 10. Even WinXP allows you to change the icon size in its start panel. :wall:

 

(By the way, my icon set is "Nuvola", and it has all the correct sizes, each in their own folders from 16 to 128. They resize perfectly on the desktop and in folders, etc.)

Edited by LTD602

Share this post


Link to post
Share on other sites

My apologies to you, LTD602.

 

This DOES work in KDE in other distros, so it's not KDE's fault. They *do* allow changing icon size, too.

 

It's that Mandrake has taken the liberty (as is their right) to heavily customize the Launch Menu (Start Menu).

 

Try this:

 

Go back to the file and delete your addition of MenuEntryHeight, so that the file is back to its original state.

 

Then, right-click on top of Mandrake's yellow star in the blue square (Mandrake's Start Menu), then choose Menu Editor.

 

In the new window, click on the "Menu Style" button at top-left. On the next PopUp Window, choose at the bottom "Original Menu"..the default for KDE.

 

Log back out, then in (or reboot). Go back to the file you edited before and see if there is now an entry where you have MenuEntryHeight where you can choose your size for the icons.

 

BTW, in SUSE9.1, the icons in the Launch Menu were too large for me, even though I'm an ancient "baby-boomer" (1946) and am now wearing trifocals. The Menu's large icons caused it to spread out into two columns, taking up more screen than I wanted it to, so I made it smaller. (I got the info from a thread at http://forums.suselinuxsupport.de)

 

I'm curious to know if that works.

 

I'm not a techie or a geek, but I'm trying nevertheless to be a contributor and helper since I've received tons of help from these wonderful and very polite members here who never flame.

 

Let us know your results as it may help others OR so that others with more technical knowledge than I can "hop" in here to help you.

 

Richard L.

Edited by lawsonrc

Share this post


Link to post
Share on other sites

Richard:

 

I certainly appreciate your help and attention. Yes, I'm very impressed with this site as well. :-)

 

Still no luck, though.

 

1.) I logged out and logged back in as root.

 

2.) I navigated to the kickerrc file (usr/share/config)

 

3.) I deleted the MenuEntryHeight line that I put there.

 

4.) I logged out and back in as user.

 

5.) I changed the menu style to "original." It was organized differently, but the icons size was the same.

 

6.) I decided to reboot, and I logged in as user once again.

 

7.) I navigated to the kickerrc file. There was NO MenuEntryHeight.

 

8.) Just to make sure, I checked under icons and "advanced", and the panel icon size option was still shaded and unalterable.

That's about it.

 

-Christian.

Edited by LTD602

Share this post


Link to post
Share on other sites

Most likely the way to "unshade" the panel icon size opton is to boot as root to the red desktop and look at it. Yet I know that is not a concern for you.

 

I'm really sorry that didn't help you. I'll ask next Wednesday evening at our weekly Houston LUG workshop. Maybe one of the "übergeeks", Linux geniuses if they have a solution.

 

In the meantime, perhaps another can help you on this forum.

 

-Richard L.

Share this post


Link to post
Share on other sites

New problem, perhaps related to this previous prcoess.

 

Now, I can't change the "original" menu back to what I had before (all applications.) When I click on "menu editor" , either in the panel or by right clicking on the start button, nothing happens. I can't get in to the k-menu editor . . . . .

 

Specifically, I see the "starting menu editor" flash for a second - if that, in the taskbar area, and then disappear.

 

Any idea why this is happening?

 

EDIT:::::: EDIT:::::::

 

Problem solved. I opened the console and ran menudrake. Once in, I just chaged back to "all applications" menui and saved. From then on, "edit menu" using the mouse worked alright.

 

Don't know what happened, but it looks like you can't select menudrake using the mouse or the panel when you're running the original menu. Odd. Maybe it has somethnig to woth the original menu not conforming to Mandrake's own settings, etc.

Edited by LTD602

Share this post


Link to post
Share on other sites
Guest sohni

I tried following on SuSE 9.1 and it worked.

 

Ctrl+Esc opens task list. Kill kicker process.

'killall kicker' in command line

 

open /home/YourName/,kde/share/config/kickerrc

 

Change value of MenuEntryHeight in [menus] part to 24

 

save file

 

Alt+F2

kicker

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...