Jump to content

install new software problem

chris z

Recommended Posts

hi all.........


i'm having a problem here that's driving me crazy & i'm out of solutions to try. thought i'd put it out here in hopes of somebody having this same problem &/or a fix for it.


here's the scenerio.......


i have MDK9.2 installed on my new computer. going on 2 weeks now. i did a fresh install, then copied/replaced some of my old /home/chris stuff that i needed. all the updates have been applied (except for the one you'll see about in a moment) everything is just ducky, except for when i try to install some KDE packages, either via the MCC software installer or urpmi in CLI. it's basically an endless loop of dependency hell. what's happening is, i try to install packageX, it tells me i need package(s)Y(Z,F,etc.) as depends. i give it the "OK", it asks for the proper CD, downloads the packages, but bombs on install because of the depends. but, the weird part that's driving me nuts is that i already have the depends it's telling me i need. :wall:


this is only with KDE apps, & only a select few of them. i can install 98% of the packages fine. i have no KDE cooker apps installed. it's a stock KDE3.1.3-79 install.


here's the latest example......... there are several updates/security fixes available for kdepim, kdepilot, kdenotes. i select the updates, auto select the depends (libkdepim, lib kdepilot, etc.), it downloads them, but on install it tells me the following........


[root@default chris]# urpmi kdepim-3.1.3-22.1.92mdk.i586
To satisfy dependencies, the following packages are going to be installed (5 MB):
Is this OK? (Y/n) y

installing /var/cache/urpmi/rpms/libkdepim2-kpilot-3.1.3-22.1.92mdk.i586.rpm /var/cache/urpmi/rpms/kdepim-knotes-3.1.3-22.1.92mdk.i586.rpm /var/cache/urpmi/rpms/kdepim-kpilot-3.1.3-22.1.92mdk.i586.rpm /var/cache/urpmi/rpms/libkdepim2-common-3.1.3-22.1.92mdk.i586.rpm /var/cache/urpmi/rpms/kdepim-3.1.3-22.1.92mdk.i586.rpm /var/cache/urpmi/rpms/libkdepim2-common-devel-3.1.3-22.1.92mdk.i586.rpm /var/cache/urpmi/rpms/kdepim-karm-3.1.3-22.1.92mdk.i586.rpm /var/cache/urpmi/rpms/kdepim-kaddressbook-3.1.3-22.1.92mdk.i586.rpm /var/cache/urpmi/rpms/libkdepim2-kpilot-devel-3.1.3-22.1.92mdk.i586.rpm
Installation failed:
       libkdepim2-kpilot = 3.1.3-22.1.92mdk is needed by kdepim-kpilot-3.1.3-22.1.92mdk
       libkdepim2-common = 3.1.3-22.1.92mdk is needed by kdepim-kpilot-3.1.3-22.1.92mdk
       kdepim-karm = 3.1.3-22.1.92mdk is needed by kdepim-3.1.3-22.1.92mdk
       kdepim-knotes = 3.1.3-22.1.92mdk is needed by kdepim-3.1.3-22.1.92mdk
       kdepim-kaddressbook = 3.1.3-22.1.92mdk is needed by kdepim-3.1.3-22.1.92mdk
       kdepim-kpilot = 3.1.3-22.1.92mdk is needed by kdepim-3.1.3-22.1.92mdk
       libkdepim2-common = 3.1.3-22.1.92mdk is needed by libkdepim2-common-devel-3.1.3-22.1.92mdk
       libkdepim2-common = 3.1.3-22.1.92mdk is needed by kdepim-kaddressbook-3.1.3-22.1.92mdk
       libkdepim2-kpilot = 3.1.3-22.1.92mdk is needed by libkdepim2-kpilot-devel-3.1.3-22.1.92mdk


as you can see, all the depends it's telling me i need i am selecting. and, i do have all the older files it's trying to upgrade (i know i do, i went through them all & checked) so, if i have all of the depends it needs & all the old files it's trying to upgrade, why is it telling me i still need them?! :screwy:


i have tried the following...............


removing & re-adding all of my sources (CD's included) several times. disabling sources. deleting the /var/cache/urpmi directory & letting it rebuild. deleting the /var/lib/rpm directory & letting it rebuild. i've run rpm --rebuilddb several times. i've tried upgrading to KDE3.2 from cooker, but that also bombs due to the same dependency loop! the only thing i haven't tried (yet) is trying the upgrade method with the 9.2 install CD's. i'm hesitant to do that 'cause it might undo all the tweaks & such i've accomplished these past 2 weeks.


any help with matter would be greatly appreciated. there's free beer involved!


if you need any other info from me (log files, error messages, etc.) please tell me what ya need & i'll supply it.


awaiting on your replies.......



Edited by chris z
Link to comment
Share on other sites

Normally I would say to remove xyz.rpm and reinstall, but this will wipe out half your installation in this case. Sounds like a real SNAFU... Just my suggestions here:


Have you tried creating a local source with these rpms ? say, /home/rpms

then try urpmi --autoselect kdepim-3.1.3-22.1.92mdk.i586

- or -

rpm -ivh kdepim-3.1.3-22.1.92mdk.i586 kdepim-kaddressbook-3.1.3-22.1.92mdk.i586 etc etc

from /home/rpms.


(try it with and without other sources configured)

Link to comment
Share on other sites

urpmi --noclean kdepim-3.1.3-22.1.92mdk


cd /var/cache/urpmi/rpms/

rpm -e --nodeps all-the-rpms-ur-replacing

rpm -ivh --nodeps all-the-rpms-ur-installing


If they don't work;

rpm -e --nodeps all-the-rpms-u-installed

and reinstall the old.

Link to comment
Share on other sites

i only had time to try the urpmi --noclean method this morn.......... noclean is no go.


i'll try some of the other suggestions tonight, or tomorrow when i get more time.


i have done the rpm --rebuilddb method, several times. i even went as far as removing all the header files in the cache & rebuilding the /var/lib/rpm directory from scratch...... no go.


i'll post back with any successes or failures.



Link to comment
Share on other sites

just wanted to close this out & let anyone who cares know that i solved the problem.


after trying various methods of forcing installations (--force, --allow-nodeps, --noclean) rebuilding the database numerous times, & removing/adding various sources (etc.), & even trying the "upgrade" option on the install CD, i finally (& painstakingly) went through every KDE package i had installed. i tested removing various things to see what depends it might want to take with it. when i tested removal of KDEgames3.1.3 i discovered that it wanted to remove (KDEPim included among them) several depends with KDE3.2 versions. so, i removed the games & the 3.2 depends along with it, then tried reinstalling the 3.1.3 games package from CD. for some reason, it still wanted to grab several cooker 3.2 depends instead of the 3.1.3 depends from CD. why? i don't know. so, i ended up temporarily disabling all sources except for CD's, force installed the depends from CD first, then installed the KDEgames package. all worked & i haven't had a problem since. why this occurred in the first place............? :screwy:



Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...