Jump to content

Going Back to ALT Linux


Recommended Posts

Well, after a few weeks of Mandrake 10.0 I'm sorry to say that I have to go back to my previous distro., ALT Linux.... at least until the final release of 10.0.


On Friday I was going about my business with Konqueror and wanted to check a photo I had on my compact flash card. So, as I've done several times before, I typed "/mnt/memory_card" in the URL location bar. Konqueror hung up. After about 3 or 4 minutes, I killed the app. and logged out (being done for the evening).


Mandrake would not log me out cleanly. For about 7 to 10 minutes of looking at a black screen I re-booted the PC (yes, I did check the other terminal windows F1 and F12 for activity, but saw none). The PC was hung up good.


When I rebooted I found out that the contents of my /usr directory was gone, nowhere to be found. I knew something like this could happen when logged in as SU, but as a regular user? Something went terribly wrong. I just don't have the time available for these kinds of problems. Hopefully, what ever the problem was, Mandrake will have it taken care of down the road.


Right now, I'm back using my tried and true ALT Linux Copact 2.3. No use messing with a good thing.

Link to comment
Share on other sites

  • Replies 58
  • Created
  • Last Reply

Top Posters In This Topic

It would seem konqueror had some trouble accessing cf card. this hung it up - never a great thing. what may have been better was getting to a terminal, checking processes with ps -aux and killing any konqueror processes that were still running. another possibility would have been trying ctrl-alt-backspace just to restart the X server. when you logged out, KDE was still waiting for the konqueror program to die.


why is /usr all fubared?


well, did you do a hard reboot? i mean, did you hit the reset button or did you do a shutdown from the console as root? if you just rebooted the system by hitting reset, i would imagine /usr got messed up. it was probably in the middle of being used, and the hard reset caused errors in the files and filesystem, creating the problem you've know run into.


to be completely honest, this is something that could happen on -any- linux system, quite easily. i don't think mandrake is completely to blame here - it may be KDE's fault in some way, or maybe something with the kernel caused the system not to be able to interface with the compact flashcard.


in essence, there's a million reasons this could have happened, and it being mandrake 10 may or may not have had anything to do with it.

Link to comment
Share on other sites

As before, I have to clear this up again.


It is not an RC, if it was they would have labeled it as one.


Secondly, what I was trying to point out is that it's quite possible the cause of your problem was -not- Mandrake 10.0 - there are quite a few other things that could have contributed, such as a hard reboot.

Link to comment
Share on other sites

Hi Tyme,


The basis of my opinion has been formulated from what I heard, but after reading To All Mandrake 10 Users it seems clear to me that there is A Lot of confusion about what this release is no? So it is not an RC. I'll call it the final before the official edition or the in between RC/Official versions. It's a matter of semantics to me, but you are right to say that many other things could have caused this problem and I was too quick to blame it on 10 CE. I'm eager to try it out, but seeing I am on dial up, I can't get those 600 or 800 MB's of updates so I am waiting for the official version and from a noobie perspective, I wouldn't say this would be the release to get them to switch to Mandrake or Linux for that matter. They would get disheartened and turn away. I would tell them to wait for the official. Sorry for my poor choice of terminology, but you understand how confusing this is don't you?

Edited by spiedra
Link to comment
Share on other sites

This topic is not a request for assistance and is not really about help. I am moving this to everything linux, as it is about linux. There, people can feel free to discuss whatever.

Link to comment
Share on other sites

Spiedra, only some people are confused. Lots are not. I am not, for instance.... If you read that link you mentioned, read my arguments. Then realise that no counter arguments have been made, before or after those.



I concur with what Tyme has said: this can happen on any linux, it doesn't seem related to any Mandrake specific thing.

Konqueror is part of KDE, the other thing that matters here is the kernel. Both are not Mdk tools.


But anyway, if you want to wait for Mandrake 10.0 OE, fine with me. I doubt that that will help you avoid this kind of problem though. It is not a matter of a simple bug that should have been fixed or should never have existed...

Link to comment
Share on other sites

No, I'm not putting all the blame of the incident on Mandrake. Could be something with KDE too... or just something unique to me and my PC.


I did try the CTRL-ALT-Backspace after several minutes of looking at a black screen when I tried to log out the first time.... nothing happened. I did kill the Konqueror process (or at least I thought I did) before logging out.


I also tried to log in as root on another virtual terminal, but the terminals were not responding to keyboard entries.


I do understand the danger in re-booting via the reset button and only do so when I feel I've done everything I can software and OS wise.


As I said, it may not be MDK 10's fault or KDE's, however, I've been using ALT Linux for quite some time in the same manner and this problem has never happened. MDK 10.0 is the first Mandrake distro. I've used since 8.2 so I cannot say if 9.x had the same issues.


Anyway, I just thought users of the 10.0 Community distro. should be aware of this problem I've recently encountered.

Edited by judland
Link to comment
Share on other sites

Mandrake10-CE is a dressed up name for Mandrake-10-RC3. They just just changed the RC-3 release name to CE to make more money by fooling some people into thinking its a 10 final release.

In may, they will release MDK-10 official, which to you and me is the real 10 final.

Since the 10-CE (read RC-3 release) I have d-loaded over 650MB of updates. Im not complaining, it works fine for me, but CE= RC -3. Don't get fooled by the name change. Your running a RC release.

Link to comment
Share on other sites

think a sec about those newbies that WILL get confused if we continue to ague about this change..

Thats the very reason i made the post. I don't want "newbies" to be misled into thinking its something its not.

Link to comment
Share on other sites

dang it people, it's a small t in tyme!!




either way, i don't see any reason for us to call it something other than what mandrake is calling it. Mandrake 10.0 Community Edition. Can't we just agree on the name and forget about the semantics?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...