Jump to content

Flash Player in Mageia


Recommended Posts

Sorry if in wrong forum but thought the Mageia forum was just for general chat so here it is, Mageia 2 KDE running FF 10.0.4. flash content does not even play. Either "plugin needed" or black windowbox.


Enabled non-free repos as recommended. Apparently MGA has scripts flash-player-plugin and flash-player-plugin-kde that download and installs Adobe Flash ( v. 11.2.xx.x) but FF recognizing it as Shockwave. When I install these plugins, Adobe flash control center is indeed added to KDE control center and there is a libflashplayer.so found in /usr/lb/mozilla/plugins, However no flash content can be seen and Adobe "test flash version" site shows nothing installed.


about:plugins- shows nothing installed

FF>tools>addons> shows only Shockwave

have tried gnash (flash alternative) but videos are choppy. I thought it might be ATI radeon 9250 graphics but all desktop effects fine.

tried watching video with effects disabled but still no content


Have read here and other forums about Adobe flash being 64 bit and FF being 32 bit. so it being incompatible but I know flash was working in MDV2008.1 and currently in PCLOS 2010 and 2012 so somehow they got it going.


Any help appreciated

Link to comment
Share on other sites

Yes. Tried recommended method according to MAQeia. Also tried installing outside of repos, also tried gnash.


Flashplayer control center shows up in KDE settings manager and there is libflashplayer.so in /usr/lib/mozilla/plugins but Adobe site indicates no flash installed and about:plugins in FF indicates none installed.

Link to comment
Share on other sites

I get the same thing when going to the adobe site to test my flash, I'm told it is missing. Even so when I go here http://www.albinoblacksheep.com/flash/ flash is indeed working. I see Shockwave Flash


File: libflashplayer.so


Shockwave Flash 11.2 r202 in the about:plugins. Have you tried another browser to see if the results are the same?

Link to comment
Share on other sites

When i visit:



i get:

You have version 11,2,202,236 installed.


And have same information in about:plugins

File: libflashplayer.soVersion: Shockwave Flash 11.2 r202
So don't understand what should be wrong here?




Link to comment
Share on other sites

OK, two updates here. I was mistaken with "about:plugins"


In FF >tools>addons>Plugins I see Shock

In "about:plugins" I see Shock and FutureSplash which is apparently the renamed version of FlashPlayer from Adobe.


I have the KDE > settings > network connectivity> Adobe Flash settings, but on the Adobe website there is supposed to be an actual control panel to adjust settings but nothing there. Also, I have no links to specific sites, but I don't seem to be able to play anything on youtube or metacafe and any "check flash" websites whether Adobe or otherwise show nothing- no version numbers, no spinning monkeys, nothing.


Sorry I don't have exact numbers but we are talking about Mageia 2 KDE running FF10/11 and Flash(FutureSplash) 11.2.xxx.xx. There are two recommended installers (scripts I guess) in MGA repos which then download the flash from the Adobe site and install for the user.Someone over in Mageia said he had not updated the MAQeia for MGA2, so maybe the script is installing a new version of flash that is incompatible with FF.


There seems to be chatter over in PCLOS forums about issues with latest Flash and FF versions being incompatible. Read somewhere that someone downloaded ALL archived releases of flashplayer, extracted libflashplayer.so and started plugging them in until he got one to work! Quite dedicated.


I will say that I uninstalled Flash and installed gnash, an alternative, but video is choppy and can only get 240p with audio. 360p is choppy with no audio. There is someone on pclos forums who calims it is the Radeon 9250 card causing the issues, however all my desktop effects are rocking along fine so why wouldn't it like flash? ( I did try to watch content with effects disabled - no go)

Apparently this is the last version of Adobe Flash for Linux. Maybe this is their way of discouraging.



Stumped for now


Edited by Trio3b
Link to comment
Share on other sites

  • 4 weeks later...

another thing you can try to do because maybe the shockwave is not letting the libflashplayer.so plugin work (it happened to me)why don't you try to disable or even try to move the shockwave plugin to another place (that's what I did) example your /home folder so you don't lose it and leave the libflashplayer.so in /usr/lib/mozilla/plugins, restart the firefox (close it and open it again)and see if it works (it worked for me, well it was not mageia but it is on mandriva) but I think it should work, if it doesn't you still have the shockwave file in your /home folder to move it back to /usr/lib/mozilla/plugins. but you need to be certain which one is the shockwave plugin in your /usr/lib/mozilla/plugins so you don't move another plugin.


I did that with mandriva to resolve the conflicts that I had, once I did that it let me watch youtube or any other site that requires flash...

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...