Jump to content

Sharing files using KDE-filesharing [solved]


Recommended Posts




I would like to request your help with the folowing problem:


I have a WinXP machine and a Mandriva 200.1 machine. I decided to share files via SAMBA. I read the tutorials here and in many other places before installing and configuring. Everything went well, I can see the Linux shared folder from Windows and all, BUT...


It seems that, in Mandriva 2009.1, the 'sharing' tab in Dolphin's properties menu does not work. I right click on a folder , select sharing, press the only button that appears there, then it asks for the root password, and I enter the correct one, but then it just

does nothing, the button goes gray for one second, but then the window does not appear. If I choose ignore, the right window does appear, but everything is grayed out because I am not root.


I have managed to share the files via control center, but I'd like to do it from Dolphin, as it is faster that way.



thank you

Link to comment
Share on other sites

First of all, a big and warm welcome to MUB.


If you haven't done so yet, you should make certain that you have installed the ...ntfs-3g rpm and its dependencies It enables you to read and write to Windows partitions.


Without it you haven't got a chance.


Cheers. John.

Edited by AussieJohn
Link to comment
Share on other sites

I have a feeling he has Windows and Mandriva on two separate machines, so ntfs-3g won't help in this case. The samba stuff should work, but I don't use KDE or Dolphin so I can't help with that side. However, something I found with google:




I know it's OpenSUSE, but the principals for getting Dolphin working are the same, so take a look at the KDE section and work through it.


When I've shared stuff with samba before, I've always used MCC, or installed SWAT which allows you to manage the samba shares and config from a web browser.

Link to comment
Share on other sites

Thanks for the welcome AussiJohn.



And Ian, I have already installed SWAT, but don't know how to run it. The only entry that appears in the menu is SWATconfog or soemthing like that, but when I run it, it tells me there is a xml, or config file missing. How do I use SWAT.


Oh, and yes, I have a WinXp machine and a Mandriva2009 machine. I have tried with a third machine that has Mandriva 2010, and everything works there.


Thank you for your fast replies

Link to comment
Share on other sites

Nope, my problem is that the main configuration panel does not appear after I enter the root password. Is it abug in KDE4?



Also, I can't start swat either, I type my computer's name and then :901, but it does not work either, so I can only share files using MCC's utility... This only happens in Mandriva 2009.1



Edit: solved the swat problem. It was not set to start when asked...

Still stuck with the KDE problem though

Edited by M_R
Link to comment
Share on other sites

Try Alt & F2 then type:

kcmshell4 'fileshare'





See if the File Sharing - KDE Control Module appears.  If it does set who can set shares, i.e. users, users in a particular group etc.



Link to comment
Share on other sites

  • 2 weeks later...

Sorry my mistake, you should type:

kdesu kcmshell4 'fileshare'

to run the interface as root.


kdesu is not recognized by my system. Couldn't find a way to do it like in other Mandrivas so I'll resort to the MCC interface...

Link to comment
Share on other sites

kdesu is pretty standard command for virtually any distro. You can exclude Kubuntu and spinoffs, where kdesu has been replaced by kdesudo.


Yes, I know but it gives me a 'command not found'.



I even tried just kdesu, and it didn't recognize it either. I have tried it in another machine with Manriva 2010 and it's not working either.




Oh, problem solved:


First of all: kdesu is somehow not in my PATH, therefore I ha to run /usr/lib/kde4/libexec/kdesu

Second: there were a bunch of corrupted samba configuration files, I uninstalled samba and reinstalled it. Now everything is fine.


Now, How do I mark this thread as solved again? How do I edit the title (I can edit my messages, but how do I edit the title to add [solved]?)

Edited by M_R
Link to comment
Share on other sites

You can make a symlink to kdesu so it's in your $PATH with (as root)

ln -s /usr/lib/kde4/libexec/kdesu /usr/local/bin/kdesu

You can mark this as solved using the Edit button on your first post. I'll go ahead and mark this one solved for you. :)

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...