Jump to content

Google Earth 5 with Mandriva 2010.0 - 64 bit


Recommended Posts

I'm trying to install Google Earth 5 on my Mandriva 2010.0 workstation. I'm using the 64 bit release of Mandriva 2010.0 and everything works perfectly so far. System has update to packages, graphic driver, etc. I went to the google website, downloaded the binary installer, very straight forward.


Run the installer, it does it thing, copies some files, setups the menu, and your done. When I try to run Google Earth 5, it just comes up with a blank screen where the Earth would be. The menus and such do come up, but well I can't see what I'm doing. I tried changing some options around in the graphics section of Google Earth, safe mode, etc. None of them seem to work. It finally hit me, probably not 64 bit compatible yet from Google perhaps?


So I went to the Google site, read and tried a ton of "fix the 64 bit" issues, but none of them worked or applied to my system in question. So I ask if anyone here had Google Earth 5 working with their 64 bit Mandriva 2010.0 system yet and if so, how was it achieved? ;)


Any feedback or info would be greatly appreciated.



Link to comment
Share on other sites

Try running it from the console, and you will see some error messages explaining all the 32 bit QT libraries and so forth that are missing. If you are unsure, copy the errors here about the missing packages, and we can tell you which ones to install.


I know it works, as I went through this myself on Mandriva 2010 x86_64.

Link to comment
Share on other sites

Thanks for helping out.


Here is what I got so far.


I run the installer from the console, the first error I noticed

Gtk-Message: Failed to load module "canberra-gtk-module": libcanberra-gtk-module.so: cannot open shared object file: No such file or directory
loki_setup: Suspect size value for option option

The packages are installed and the file is located on on my system at /usr/lib64/libcanberra-gtk-module.so but I don't know if that is a problem as the installer still comes up and ask where to install, etc.


So I let the installer do it's thing, everything appears to be going ok. I don't get any errors in the console during installation.


I go into the console, start up google earth from there. No console errors during the start. When it's running, the system is very, very slow with X using nearly all of the CPU time. I've attached a screenshot to show what Google Earth does when it's running. It looks exactly like that. :lol2:


My system specs (if relevant)

PIV D IA64 3.2 GHz

4GB of RAM

1TB Hard Drive

1GB Nvidia Geforce Galaxy 200 Series (using latest drivers compiled for the kernel from nvidia website)


Mandriva 2010.0 x86_64 Power Pack


Link to comment
Share on other sites

Did you install the libcanberra-gtk0 package? You need the 32 bit package, since GoogleEarth is 32 bit, the 64 bit one you have installed is no good.


Another thing, if you have compiz and all the 3D stuff enabled - disable it and see if it performs any better?

Link to comment
Share on other sites

Hmm strange, cos I don't know what else to suggest. But check the /etc/X11/xorg.conf and make sure it has nvidia and not nv as the driver for the card. Here is how it looks on mine. You can see in the screenshot, version of Google Earth I have as well as verification that I'm using Mandriva 2010 x86_64 :)


Link to comment
Share on other sites

I'm guessing it's a bug with Google Earth then. I have over 2 dozen OpenGL games that work without any issues including a lot of high powered game in Wine (like Sins of the Solar Empire) that all run fast and without errors.


Thanks for all your help, at least I know that it can run in Mandriva 2010 x86_64 because you have one that works just fine. So either it's a bug for the Nvidia team or the Google team I'm guessing. ;)


Link to comment
Share on other sites

I have an Intel card and this is all in my laptop, so it probably doesn't have a great card with a huge amount of ram like yours. I can only think that its' perhaps something with the nvidia combination, but if the rest is working fine, then perhaps it's a google issue.

Link to comment
Share on other sites

  • 5 months later...

I am new here and am new to Linux. I am trying to evaluate Linux as an alternative to Windows for my personal and business use. I have tried to install Google Earth but have run into the same problem mentioned above about a "canberra" library load failure. I have tried to search for a copy of this library, but the only references to it tell me I am forbidden to access it. I am not a technical user and almost everything I read gives the impression that I must invest a vast amount of time and energy into learning technical terms and develop an in depth knowledge of the O/S to be able to use it. When I chose Mandriva, I was told it was a "plug and play" viable alternative to Windows. Admittedly the install and general usage are very beautiful to watch, but it seems that if I want to install and experiment with add-on software, like Google Earth or games, I am going to get into a hornets nest and have to suffer high handed comments from people who have been working with this for years. I have joined this forum in hopes that other users may be able to give practical advice, directed at solving the problem and simply making it work.

Link to comment
Share on other sites

The installer routine appears to be screwed up in both 2010.0 and 2010-spring. I have a feeling that Mandriva is distracted at the moment and not paying as much attention to fixing mistakes made as distinct from bug fixing, but thats for discussion somewhere else.


My solution was to download the bin file directly from Google and it downloaded into Downloads. If you download it into a different place then transfer it to Downloads so it will be easier to follow my directions.


Open Konsole ....type su....press enter then type your password then press enter again.

Type in....... ls /home/(your user account name. mine is john, naturally)/Downloads....press enter. This will show the name of the bin file you had placed in Downloads.

Press the up arrow key and it will show the line you had earlier typed in. Change the ls to cd so it now reads .....cd /home/(your user account name.)/Downloads.....press enter.

Type in ......sh GoogleEarthLinux.bin.......(easy way is to type in the first 3 or 4 letters of the title you saw earlier and press the tab key, this will complete the title for you.) Now press enter again and it will do the install.

When completed you will find Google Earth in Menu under Internet. You will also likely find an Icon on your desktop.


Hope this makes it easier for you.


Cheers. John.

Link to comment
Share on other sites

Used about the same routine as AussieJohn a couple of weeks ago, and it works fine.

Went into the Downloads-directory and issued chmod +x GoogleEarthLinux.bin, and after that ./GoogleEarthLinux.bin

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...