MandrivaUsers.org : PC does not power-down automatically [solved] - MandrivaUsers.org

Jump to content

Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

PC does not power-down automatically [solved]

#1 User is offline   xoox 

  • casual
  • Group: Members
  • Posts: 50
  • Joined: 17-October 02

Posted 30 December 2006 - 12:49 PM

Hi.

With Mandriva 2007 my PC does not power down automatically any more (it did so with Mandriva 2006). The shutdown procedure seems to work normal and it stops with

Quote

Halting system...

System halted.

The HDD's are turned off but the fans are still running and alo the shutdown messages stay on the screen.

Automatic power down does work with Windows on the same machine so I don't think it is a hardware problem.

Anything I can try to make this work with Linux as well?
0

#2 User is offline   joaopa 

  • casual
  • Group: Members
  • Posts: 57
  • Joined: 29-June 05

Posted 31 December 2006 - 10:20 AM

It is a well-known bug for Mandriva 2007. To workaround it, in the file /etc/lilo.conf
in the lines append, add
apm=power-off

joaopa

PS: To do this, you can use mandriva control center too.

This post has been edited by joaopa: 31 December 2006 - 10:22 AM

0

#3 User is offline   ianw1974 

  • Platinum
  • View blog
  • Group: Admin
  • Posts: 14,049
  • Joined: 09-March 05

Posted 01 January 2007 - 09:27 AM

On mine, I needed more parameters:

acpi=off apm=on apm=power-off

Ian Walker

Light travels faster than sound. This is why some people appear bright until you hear them speak.........

Posted Image2 x systems installed with Ubuntu 14.04 x86_64 (Laptop and Desktop)
Posted Image1 x systems installed with Gentoo x86_64 (Desktop)

My Linux Solutions | Linux Systems Limited
0

#4 User is offline   xoox 

  • casual
  • Group: Members
  • Posts: 50
  • Joined: 17-October 02

Posted 01 January 2007 - 03:17 PM

View Postjoaopa, on Dec 31 2006, 11:20 AM, said:

apm=power-off


Works fine for me. :thumbs:/>
The other parameters are not necessary on my machine.

Thank you very much for your help. :thanks:/>
0

#5 User is offline   skinky 

  • New Here
  • Group: Members
  • Posts: 25
  • Joined: 02-March 06

Posted 09 January 2007 - 12:56 AM

I have the same problem and first tried adding just:

apm=power-off


but it made no difference so I tried adding:

apm=on apm=power-off


The computer still will not power off completely. I do get the final "System halted" message but I have to physically turn off the computer by pressing the power button.

The line in my lilo.conf file is now:

"acpi=off resume=/dev/sda5 resume2=swap:/dev/sda5 splash=silent apm=on apm=power-off"


Any other suggestions? Thanks.
Mandriva 2008.1 x86_64
0

#6 User is offline   joaopa 

  • casual
  • Group: Members
  • Posts: 57
  • Joined: 29-June 05

Posted 10 January 2007 - 04:38 AM

Maybe a problem with resume. Try only
"acpi=off apm=power-off apm=on splash=silent'

Joaopa
0

#7 User is offline   skinky 

  • New Here
  • Group: Members
  • Posts: 25
  • Joined: 02-March 06

Posted 13 January 2007 - 11:12 AM

Joaopa, thanks for the suggestion. I just tried that but unfortunately it didn't make any difference... the darn thing just refuses to power off! Oh well, I guess I'll just have to live with switching it off myself. It is annoying though when Windows will power it off. Also the actual box is in another room on the other side of the house. :wall:/>

Thanks anyway.
Mandriva 2008.1 x86_64
0

#8 User is offline   joaopa 

  • casual
  • Group: Members
  • Posts: 57
  • Joined: 29-June 05

Posted 14 January 2007 - 05:13 AM

Another suggestion. ;)/>
You could try an another kernel. In cooker, it is kernel version 2.16.17.9. Give it a chance

Joaopa
0

#9 User is offline   gaiterin 

  • New Here
  • Group: New here
  • Posts: 1
  • Joined: 21-February 07

Posted 21 February 2007 - 07:05 AM

Hi. Excuse my english, i put in better in spanish, but i will try in english too.
My Ubuntu, Windows xp, Knoppix, not problen for power off, but Mandriva 2007 not power off.
It disconnet the hard disk, but not the power.

I try more solutions in the grub, but the Mandriva not power off :(

I repair it, modifiqued the bios.
I modifiqued the BIOS as "Power Management Setup".
- ACPI: Enabled.
- Power Management -> User define -> In submenu, all disable.
- ACPI Suspend type -> S1 (POS).
- PM Control by APM -> Yes.
Soft-off by PWRBTN -> Instant off
CPU Fan in suspend -> On
Wake up Events -> all disabled.

And SOLVED! :D/>


In spanish, if you don't undertand my english, try a translator as google ;)/>
Hola.
A mi tampoco me apagaba el ordenador Mandriva 2007 (Sin embargo en Windows XP u otras distribuciones de Linux como Ubuntu, Kubuntu, Knoppix... sí apagaba).
Hacia el ruido de desactivar los discos duros, y activaba las luces del teclado, e incluso (lo peor), anulaba el botón de encender el ordenador. Debía dar a reset, y luego a apagar.

Modifiqué el arranque de Grub como decian en muchos foros pero no solucioné nada.

La solución la encontré modificando la BIOS.
En mi placa, aparece como "Power Management Setup". Yendo ahí, la función ACPI estaba desactivada, por lo que pase a ponerla activada (Enabled).
También modifiqué el menú entero, de la siguiente manera (por si acaso no era solo esa de arriba):
- Power Management -> User define -> Dentro del submenu, todo disable.
- ACPI Suspend type -> S1 (POS).
- PM Control by APM -> Yes.
Soft-off by PWRBTN -> Instant off
CPU Fan in suspend -> On
Wake up Events -> Todo disabled.

Con esto apaga perfectamente :D/>
Espero que pueda ayudar a alguien.
Un saludo
Marcos.
0

#10 User is offline   skinky 

  • New Here
  • Group: Members
  • Posts: 25
  • Joined: 02-March 06

Post icon  Posted 30 May 2007 - 08:53 PM

This is an update in case it may help others with the same problem.

First, I did try other kernels but no go.

I recently upgraded to Mandriva Spring (2007.1) with a clean install and same problem. Also tried the tmb-desktop-smp kernel - still no go.

I then installed Debian Etch (4.0 r0) which performed an overwrite of Mandriva's grub with settings Debian thought were required for my system and voila! the computer powers off. Debian added the same settings to the Mandriva boot options so now Mandriva also powers off the computer. :D/>

The boot options required for this system are:

noapic nolapic pci=noacpi


As a side note: this system will NOT boot without the pci=noacpi option, including both distro installations.

HTH someone.

This post has been edited by skinky: 06 June 2007 - 01:18 PM

Mandriva 2008.1 x86_64
0

#11 User is offline   AussieJohn 

  • MAGEIA votary
  • Group: Members
  • Posts: 3,119
  • Joined: 25-August 03

Posted 30 May 2007 - 09:33 PM

Use the the instructions you show but change the (Leave....noapic nolapic.....the same) pci=noacpi to...... acpi-off.

See how that goes.

Cheers. John.
The Computer future is here TODAY ..... Mageia-4, KDE4, Dolphin, K3B, Grip, Audacious, Totem, Kaffeine, SVLC, Kmail, Libre-Office, Scribus, XSane, Gimp, OpenShot, FireFox, FlightGear, Filelight, Gwenview, Geeqie, GoogleEarth, Skype, Pysol-FC.

Corsair Obsidian 750D Full Tower Case (with full Window), AMD Athlon-FX8120 8-Core 3.1Ghz Processor, Gigabyte GA-990FXA-UD3 USB3 rev.4 MainBoard, Gigabyte Nvidia-GeForce-9600-GT VideoCard, 16Gb Corsair "Vengeance" DDR3 Memory, 1 x Corsair 240Gb SSD Neutron Hard Drive, WD SATA-II 500GB 16mb HDD, 2 x LG Sata DVD-R/RW Burners, LG 27" LED LCD HDMI Monitor, Hewlitt-Packard PhotoSmart 6510 Printer, APC BackUPS-CS-650 UPS, Corsair HX650W Power Supply, Vantec Dual HDD Docking Station SATA-USB3.

ADSL-2+ Internet Connection_50Gb (Bigpond)

JOHN. (79+yrs, Young) Registered LINUX user #318452
0

Share this topic:


Page 1 of 1
  • You cannot start a new topic
  • You cannot reply to this topic

1 User(s) are reading this topic
0 members, 1 guests, 0 anonymous users