Jump to content

AnyDATA Modem installation


Recommended Posts

Hello to you and thx so much for this enriching forum.

I am quite new to Linux and have just installed Mandriva 2010.

Problem i'm getting is how to install my wireless USB AnyDATA modem.

For Vista&XP, the manufacturer provided a modem and a wireless data installation.

How do I do it in Mandriva??

Thanking you for your reply

Link to comment
Share on other sites

Thanks a lot for your reply!

Actually, I have tried the KPPP modem configuration and I have been able to connect the modem.

However, Internet Browsers (Konqueror, FireFox) can not access the modem.. Is there may be a firewall I need to tuneup?

Thanks a lot for your help!

Link to comment
Share on other sites

Open a console and type in

ping www.google.com

If you get no response, then you must enter the Mandriva Control Center and set your network in there to use the aforementioned modem for connection.

The Mandriva-specific network scripts have been made with ease of use in mind, and as such they are complex- IMHO a tad too complex for their own good.

Edited by scarecrow
Link to comment
Share on other sites

Hi Scarecrow, thanks a lot for your precious time!

I have done as per your advice - Mandriva Network Center actually shows the 3 connections available:

Wired (ethernet) eth0

Wireless (Wi-Fi) wlan0

GPRS/Edge/3G ppp0


When I have connected to the Anydata modem thru the dial up, Mandriva says:

Network up on ppp0





How do I say to Mandriva that this is the connection it should use to access internet?

Thansk a lot again!

Link to comment
Share on other sites

Try disabling your wireless and wired connections, and bring up the ppp connection. Your default gateway looks like your internal network and so it will not attempt to use the default gw. Temporarily you can do this:


su (enter root when prompted)
ifdown eth0
ifdown wlan0


and then start the ppp connection and see if you have any better luck.

Link to comment
Share on other sites

Thanks Ian for your suggestion, tried it out but it doesn't work...

The wireless modem gets connected through kppp

however no access to internet.. if I go to the Network Centre adnd try to configure the AnyDATA modem, it cuts down the connection and nofurther action.

Please advise if there is any script to be run, i'm desperate of having to switch to windows to get the internet connection!

Link to comment
Share on other sites

  • 2 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...