Jump to content

Got a New PC [solved]


Recommended Posts

Yes, blacklisting the defunct module has got rid of the timeout. Unfortunately it has not cured the problem. What I did notice, by accident, when I booted up I got sound via the line in, I had a sound source playing, however when the login screen appeared the sound disappeared. So I switched from graphical boot screen to text and sure enough had sound until Alsa was started. So the problem is with Alsa would think. Just what I don't know.

Link to comment
Share on other sites

Do the contents of /etc/asound.state match the ones found by the ALSA script you've run?


The problem is that the model of the snd-hda-intel soundcard is by default set as "auto". Using "auto" the system tries to read the card's details directly from system BIOS. You may first try upgrading the BIOS, if an upgrade is available by Asustek, or explicitly define the card model.

Anyway, it is probably ALSA related, and looks quite similar to this problem:


There are several things to try, but I can't be sure withoout having the hardware. Sure enough, I can try a few shots in the dark though... :P

Edited by scarecrow
Link to comment
Share on other sites

Yes the contents of /etc/asound.state do match the output of the script.

Finding out the exact details for the card is a bit iffy. It's identified as '02:00.1 Audio device: nVidia Corporation Device 0be3 (rev a1)'

Googleing does not really help, as I posted earlier there is a number of requests for information on this card.

The system bios is too new to be upgraded and gives very little information on the card itself. One thing I have thought about is the possibility of an interrupt clash. Unfortunately I don't know how to fault find this on Linux. What's your thoughts on that Scarecrow?

Link to comment
Share on other sites

Right I found

cat /proc/interrupts

gave me a list interrupts and noticed that HDA_intel shares an interrupt with USB3.

The only interrupt that was vacant was interrupt 4. Can I force hda_intel to use the vacant interrupt, or some other one?

I have included the output of the above command line if you wish to take a look.


Link to comment
Share on other sites

Shared interrupts aren't an issue on modern hardware, provided that the BIOS isn't broken.


Here's some great documentation about problems with hd-audio cards:



Could you try adding, say to /etc/modprobe.d/sound.conf or /etc/modprobe.d/modprobe.conf something like


options snd-hda-intel probe_mask=1


options snd-hda-intel enable_msi=1



and see if it solves the problem?

Edited by scarecrow
Link to comment
Share on other sites

As I don't appear to have either of the .conf files you suggest I elected to add the lines to /etc/modprobe.conf with no effect.

I have tried alsactl -r init NVidia (NVidia being the card)

and got the result:-

Unknown hardware: "HDA-Intel" "VIA VT1708S" "HDA:11060397,104383b7,00100000" "0x1043" "0x83b7"

Hardware is initialized using a guess method

Which would confer with what you said earlier about snd_hda_intel being started in auto. I will now do the bed-time read of the website you pointed me to.

Thank you for your patience in this. I find it really interesting.

Edited by SilverSurfer60
Link to comment
Share on other sites

I've thrown the rattle out of the pram(baby buggy) today. Soundblaster has gone in and onboard card disabled. Thank you for the assistance but I feel the card is just too new for the Alsa drivers. I will try again when I can afford to waste a day or too. ;)

Link to comment
Share on other sites

It's fixed. :thumbs: How I don't know :blink:

After much heavy reading, running scripts the line input suddenly burst into life.

I have checked all the saved data and there is nothing different in channels, controls etc. The only thing I can think of is the Jack Plug Socket was not connecting properly. I think this because I pushed on the plug a little bit harder, by accident I add, and it was after this things started working. Maybe a mechanical fault after all. I should have thought of testing that before with all my years of fault finding on office machinery. You know thing where one looks straight past the obvious.

The bottom line is Alsa, snd-hda-intel works, and so does my sound now. :banana:

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...