Jump to content
banjo

No eth0 after mobo replacement

Recommended Posts

I am stuck at work again with no access to Linux, so I will have to take another look when I get home.

 

It would be way cool if I could understand this well enough to work through these issues, but I am still baffled about how it all hangs together.

 

To summarize the situation, the PCI bus seems to see the sound device OK, but something in the kernel does not. That goes along with the contention that my version of Mandy does not "support" the G41 chipset on the MOBO. My question is... What is it in the kernel that "supports" a chipset on the MOBO if it isn't the device drivers? Is there a set of drivers that interact specifically with the MOBO chipset?

 

Last night I looked on my system for /dev/MAKEDEV and there was no such file found. So I guess that is an old system that is now deprecated. I think maybe I need to study the workings of devfs next.

 

Thanks to all for pointing me to useful info.

Banjo

(_)=='=~

Share this post


Link to post
Share on other sites

I have started digging really deep now, even studying how the PCI system works and how Linux Device Drivers work. There is a lot of material to cover.

 

I dumped out /var/log/messages to see if there are any errors WRT the audio device. Then I copied out all of the messages from today to analyze them.

 

Before I get to that, the lspci command returns the following:

 

00:00.0 Host bridge: Intel Corporation Unknown device 2e30 (rev 03)
00:01.0 PCI bridge: Intel Corporation Unknown device 2e31 (rev 03)
00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 01)
00:1c.0 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 1 (rev 01)
00:1d.0 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #1 (rev 01)
00:1d.1 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #2 (rev 01)
00:1d.2 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #3 (rev 01)
00:1d.3 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #4 (rev 01)
00:1d.7 USB Controller: Intel Corporation 82801G (ICH7 Family) USB2 EHCI Controller (rev 01)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev e1)
00:1f.0 ISA bridge: Intel Corporation 82801GB/GR (ICH7 Family) LPC Interface Bridge (rev 01)
00:1f.1 IDE interface: Intel Corporation 82801G (ICH7 Family) IDE Controller (rev 01)
00:1f.2 IDE interface: Intel Corporation 82801GB/GR/GH (ICH7 Family) SATA IDE Controller (rev 01)
00:1f.3 SMBus: Intel Corporation 82801G (ICH7 Family) SMBus Controller (rev 01)
01:00.0 VGA compatible controller: nVidia Corporation Unknown device 0622 (rev a1)
03:01.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)

 

There is still no eth0 listed. The Ethernet controller at the bottom is our little Rosewill NIC.

 

The audio device is at 00:1b.0.

 

I opened today's snippet from /var/log/messages and searched for that device number and came across this:

 

Dec 17 08:58:14 localhost kernel: ACPI: PCI Interrupt 0000:00:1f.3[b] -> GSI 19 (level, low) -> IRQ 18
Dec 17 08:58:14 localhost kernel: 8139too Fast Ethernet driver 0.9.28
Dec 17 08:58:14 localhost kernel: ACPI: PCI Interrupt 0000:03:01.0[A] -> GSI 18 (level, low) -> IRQ 19
Dec 17 08:58:14 localhost kernel: eth0: RealTek RTL8139 at 0xf8e04c00, 00:0a:cd:19:23:b6, IRQ 19
Dec 17 08:58:14 localhost kernel: ACPI: Thermal Zone [THRM] (40 C)
Dec 17 08:58:14 localhost kernel: ACPI: PCI Interrupt 0000:00:1b.0[A] -> GSI 16 (level, low) -> IRQ 16
Dec 17 08:58:14 localhost kernel: udev: renamed network interface eth0 to eth2
Dec 17 08:58:14 localhost kernel: hda_intel: azx_get_response timeout, switching to polling mode: last cmd=0x100f0000
Dec 17 08:58:14 localhost kernel: hda_intel: azx_get_response timeout, switching to single_cmd mode: last cmd=0x100f0000
Dec 17 08:58:14 localhost kernel: hda-intel: no codecs initialized
Dec 17 08:58:14 localhost kernel: ACPI: PCI interrupt for device 0000:00:1b.0 disabled

 

It seems to have picked up our NIC initially as eth0. Then it got renamed to eth2 for some reason.

 

The PCI handling for device 00:1b.0 seems to get into some trouble and has its interrupt disabled.

 

I don't know what any of this really means, but it doesn't look too healthy to me.

 

Are there any device driver gurus or kernel gurus out there who can interpret this stuff? I am seriously over my head here.

 

BTW, there are lots and lots of other errors in the file, but I don't know how serious they are or whether they are just normal chatter or whatever. Here is one that I don't quite understand:

 

Dec 17 08:58:14 localhost kernel: PCI: Using ACPI for IRQ routing
Dec 17 08:58:14 localhost kernel: PCI: If a device doesn't work, try "pci=routeirq".  If it helps, post a report

 

The advice given in the suggestion is lost on me. "try pci=routeirq" where?

 

Thanks

Banjo

(_)=='=~

Edited by banjo

Share this post


Link to post
Share on other sites

A quick update on this issue in case anybody is watching it.

 

My son downloaded a recent Knoppix (6.2) to see if it could see the MOBO hardware. Knoppix on a CD is so primitive now that we couldn't do much, but we managed to get connected to Google using the onboard MOBO RJ45 connector, so I guess the ethernet hardware works with the right drivers. We were stuck in a Curses browser because the graphical one froze. We also managed to get a croaky synthesized voice to come out of the sound card, so that was working at a primitive level. We had no real sound files to play, and the primitive browser would not play any online stuff like youtube.

 

I guess that means that the hardware works and the problem is some kind of chipset drivers. I don't know where those drivers come from, but assume that they are built into the kernel or the distro? I suppose a Mandy upgrade is in order, but I will have to think about that since the last time I did it I was down on a lot of the tools for a month. The setup work on this thing takes a lot of time.

 

The search goes on.

 

Advice on upgrade paths is welcome.

 

Banjo

(_)=='=~

Edited by banjo

Share this post


Link to post
Share on other sites

Regarding pci=routeirq, it looks like it is a kernel parameter you add to the boot line.

http://lkml.indiana.edu/hypermail/linux/kernel/0409.2/1823.html

http://wiki.arklinux.org/Booting%2C_First_Time_and_Thenceforth

 

Maybe you should revisit my post #9.

 

I was never really convinced that your mobo ethernet was dead at the hardware level.

Edited by David Batson

Share this post


Link to post
Share on other sites

I'm surprised Knoppix can see the on-board ethernet, as far as I knew lspci would show all PCI devices regardless whether Linux supports them with drivers or not, as lspci simply reads the info from the BIOS.

 

In any case you could try a Mandriva 2010.0 One Live boot CD too as that boots up to a much more complete desktop environment than Knoppix without requiring installation. From that you could determine if the newer Mandriva supports your mobo better.

Share this post


Link to post
Share on other sites

The Mandy 2008.1 lspci command shows the sound card OK, even though my system apparently does not have the drivers for it, because it does not work either. The sound driver comes up and says that it does not see the device, even though lspci does see the device. Edit: I have the "correct" sound driver installed, but it apparently is out of date.

 

lspci does not show the onboard ethernet. So I assumed a hardware failure.

 

We booted the Knoppix and did the lspci, and it showed the sound card and two ethernet adapters on two different PCI buses. I forget the details, and the Knoppix was so disjoint that I could not figure out how to capture the information, but one must be my little Rosewill card and the other must be the onboard card. I also thought that the BIOS configures the PCI, so I am confused.

 

I will see if I can download a Mandy 2010 and boot that. I have been too busy recently with work and Christmas etc. to mess with this.

 

Thanks for the help.

I will be back when I know more.

Banjo

(_)=='=~

Edited by banjo

Share this post


Link to post
Share on other sites

Greetings. I am taking a short break from the Holiday festivities and thought I would check in.

 

I downloaded a Mandriva Live One 2010.0 image and booted this computer from it.

 

Everything seems to work right out of the box. The onboard ethernet came up as eth0, and the Rosewill card came up as eth1. Using the onboard ethernet connection I went out to youtube with Firefox 3 and had sound and pictures with no additional setup.

 

So here I am with egg all over my face. I guess the problem with the MOBO is that the G41 chipset really is too new to be supported by my old OS. Who knew? :blush: Well...my son told me that on day 1, but I needed to figure it out for myself. :blush: I still do not understand why a Linux kernel can be unable to deal with a MOBO chipset. I thought that the BIOS took care of that. Are there drivers that talk to the BIOS that need to be refreshed? Are those drivers compiled into the kernel? So many questions. The Mandy 2010 still could not see a CPU temp down in /proc/acpi.

 

I should retract some of the nasty things I said about Foxconn, but it is still a bit early in this game to eat crow. The holes on the board for the standard click-in heat sink were definitely too small, and it broke one leg of my heat sink.

 

I suppose this means that an upgrade to my Mandy is in order. While I had the 2010.0 booted I poked around with some of the widgets. They do not seem to crash like they did in the 2009 that I tried last time. Kinda cute. Mostly looks like fluff. It also appears that the desktop with shortcuts on it is back. In the 2009 there were no shortcuts on a desktop (unless I am mis-remembering). They had to be put onto a "plasma" or some such other nonsense.

 

So I will boot my 2010 CD again some time in the New Year and check out all the stuff I use, such as shortcuts and USB backup disks etc. Then, if all works out I will probably upgrade. I have not decided about KDE4. Starting over with my settings in all the KDE apps is a daunting chore. If I cannot import my address books and my Quanta+ projects etc. I might have to bail out of KDE. Recreating all of that would take way too much time.

 

I will also consider buying a Powerpack this time. Last time I installed from the Mandy 2008.1 Live One CD and it took me a month to straighten out all the problems. I currently have 5 different kernels installed trying to get one that could see all my RAM, and my HP printer and my Nvidia graphics card etc. :lol: I did not have that problem on the two previous installations, which were done from powerpacks. We shall see what happens.

 

Maybe I should wait for 2010.1? Suggestions are welcome.

 

Happy politically appropriate festivities greetings to all.

Banjo

(_)=='=~

Share this post


Link to post
Share on other sites

You can still use Quanta+ in Gnome as well as Kmail if you want (assuming that this is managing your contacts). So if you don't like KDE, it's not a problem to use another DE and just the KDE apps that you used previously.

Share this post


Link to post
Share on other sites

Happy politically appropriate festivities greetings to all.

Banjo

(_)=='=~

 

I'm glad 2010.0 solved it all for you.

 

Merry Christmas to you too! (no NWO slogans from me!)

Edited by tux99

Share this post


Link to post
Share on other sites

Merry Christmas to you too! (no NWO slogans from me!)

 

LOL Okfine. Merry Christmas.

 

Not being one to leave any dead horse unbeaten, I have continued to delve into this puzzle. I want to understand what is going on so I found and downloaded the datasheets for the chipsets in question. I found them here:

 

Intel Chipsets

 

My new Foxconn board has the G41 chipset, which is documented here:

 

G41 Express

 

My old MSI board had the G33 chipset, which is documented here:

 

G33 Express

 

The chipset consists of two major glue chips, the Graphics and Memory Controller Hub (GMCH) and the I/O Controller Hub (ICH). Each mother board is constructed with different versions of these chips.

 

The GMCH has the onboard graphics controller and memory bus controller. The ICH contains all the I/O controllers including the SATA, ISA, PCI, Gigabyte Ethernet, and sound card.

 

Here is the summary of what is on each board:

 

MSI - purchased in September 2008 has the G33 GMCH and Rev 9 of the ICH, ICH9.

 

Foxconn - purchased December 2009 has the G41 GMCH and Rev 7 of the ICH, ICH7.

 

This is weird.

 

The newer board (Foxconn) has ICH7, for which the datasheet has the date August 2007, and the older board (MSI) has ICH9, for which its datasheet has the date August 2008.

 

However....

 

The MSI board has the GMCH G33 chip, which is dated August 2007, and the Foxconn board has the newer G41 GMCH, which is dated October 2009.

 

The newer board has an older version of the I/O controller chip.

 

So there are parts of the ICH7 that my Mandy 2008.1 cannot see, whereas it can see the ICH9 just fine. I am wicked confused about why my OS cannot see the older ICH hardware but it can see the newer stuff just fine.

 

Adding to the weirdness, the newer Mandy 2010.0 can see the older hardware just fine.

 

Did the installation process install a newer driver for the ICH9 components, and that driver is not backward compatible? Do I need to take my Mandy drivers backward instead of forward? The Mandy 2010.0, being a live CD will not have any bias about what hardware it is running on, and hence it will probe the hardware and load an appropriate driver. My old Mandy 2008.1 has been installed permanently, so perhaps it does not probe any more?

 

When I get some time, I might try to test this by booting my Mandy 2008.1 Live CD and see if it works. If it does work, then I just need to find out how to put this OS into the wayback machine and have it reconfigure the drivers.

 

Now I have to go find that old CD.

 

Stay tuned.

 

Banjo

(_)=='=~

Share this post


Link to post
Share on other sites

The really beautiful thing about my theories is how easy it is to blow them to smithereens.

 

I found my original Mandy 2008.1 Live CD and booted it.

 

It did not find the onboard ethernet, and there was no sound. It does basically what the installed version does.

 

I am back to the upgrade-to-just-fix-it theory.

 

Banjo

(_)=='=~

Share this post


Link to post
Share on other sites

Happy New Year, everybody.

 

This is just an update on fixing my no-sound problem on the Foxconn board. It will be a while before I can get around to an upgrade for my OS, so I bought a short term hardware solution that has worked out. I bought a Turtle Beach Audio Advantage Micro, which is a USB sound card with 5.1 surround card. I got it from newegg for 30 bucks. It is the size of a jump drive.

 

To install it, I plugged it into a USB port and then plugged in my powered speakers and I had sound. Linux hot-swapped the snd_usb_audio driver to run it. The control software for the device is fnWindows only, so I don't have access to any of the fancy features. Kmix shows only volume control. That is OK since this is an interim solution anyway, and I have it plugged into some ancient powered speakers and then into some ancient headphones. :o The point is that I have sound again, so I can take my time to plan an upgrade. I am thinking of waiting for 2010.1, but not sure yet. My concern is ending up with a stable system. This is a multi-user, primary family computer, and taking it down for upgrades takes a bit of planning.

 

Thanks to all for the help on this issue.

 

Banjo

(_)=='=~

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...