Jump to content
Sign in to follow this  
matzlo

KDE shows windows in different styles..? [solved]

Recommended Posts

Hi all!

 

I upgraded my 2008.1 version to 2010.0.

 

I'm using KDE and the theme/style that I've set for buttons and checkboxes, etc. is "Oxygen".

 

BUT.. this style is obviously not accepted by all windows. So, for instance not by OpenOffice. The window style looks like the very old FreeBSD style, you know? The colour is very grey and the buttons very simple and rectangular. Or for example, when I click on "browse files", the window that appears has the same old style, not the Oxygen style. Or the standard buttons and dropdown boxes in firefox look different as well.

 

What shall I do? Does somebody knows whats wrong or how to fix this? I can upload pictures if you want.

 

Thank you,

Matt

Share this post


Link to post
Share on other sites

The reason for the problem was GTK. I found out that all windows that where generated by gtk where unstyled.

 

There is a package gtk-qt-engine that i've installed. Now I can change the option "GTK-Style" in "Appearance" to "Use my KDE options".

 

Thanks anyway!!

 

Matt

Share this post


Link to post
Share on other sites

The cleanest solution is replacing OpenOffice with Go-Openoffice, and start the latter as

$ OOO_FORCE_DESKTOP=kde4 soffice

And voila, perfect desktop/dialog integration with KDE4.

You can export the above string ( OOO_FORCE_DESKTOP=kde4 ) to any startup script you find convenient, so you won't have to type it all the time to Start (Go)Openoffice.

 

It should also help if you had a uniform theme for both KDE4 and gtk+, e.g. qtcurve.

For adjusting the gtk+ theme under KDE4, you can use a few graphical apps- I suggest "lxappearance", which is part of LXDE, but completely independent of the rest LXDE modules.

Edited by scarecrow

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...