Jump to content
Sign in to follow this  
viking777

RC1 fresh install - not easy

Recommended Posts

I have been having so many problems with my Cooker install just recently that I decided to start again with a fresh install of RC1. It has been the most difficult configuration of an instllation that I have had for a long time, and it looks as if the problems I am having with Nvidia are still there. This is what happened.

 

I installed the Gnome version this time so as to avoid KDE4 which I don't like - did I tell you that before? :lol2: The install itself went OK, at least this time I got a graphical login (first time for months on Cooker) but only the 'nv' driver which just doesn't work with my screen setup. Normally I then install the Nvidia driver myself but this time I thought I would try it with the built in tools, so I fired up XFdrake (in a terminal login so that there was no running graphics to screw things up). Most distros these days would by now have mentioned that there was an additional driver available, but not Mandriva, in order to 'prompt' it I had to click on my graphics card (as if I were going to change it to something else) then select it again and only then did it mention the additional driver - not good. I elected to install it and it went away and downloaded all the required extra packages and then proceeded with the install. After a few seconds it came up with 'Install failed reverting to open source driver'.

 

I then decided to use my normal method of installing Nvidia myself. This failed too. I booted back into the nv driver to get graphics back and then poked around in rpmdrake and found this. My kernel was 2.6.29-6.1.1, my kernel-devel and kernel-source files were 2.6.29-8.3.1 and my kernel-header files were 2.6.29-7.4.1. Is it any surprise that the poor old Nvidia driver can't install with this jumble! The point to bear in mind here is that I have had no input in this, it has entirely been the work of the installer + XFdrake, not me messing around and not updates either because at that stage I hadn't done any. I was able to sort this out by installing the correct kernel (which was available all the time), so why wasn't XFdrake able to do this? Again not good.

 

I would normally put this down to it being a testing distro, but if it is at release candidate stage it should be capable of better than this.

 

I have not had any kernel updates come up yet so I don't know if it will handle these by itself, it certainly didn't on my previous install, that was its biggest problem.

 

The other problem that I had with the previous install was Virtualbox puel not running. I have managed to solve it on this install, but what a performance. Before I could even install it I had to trawl around the net for obscure python libraries that are not installed in Cooker, then to make the VM run I had to manually edit the makefile, then install vboxdrv over again. It doesn't sound much when you write it like that, but if you throw in all the searching I had to do to find the solution, again it was not easy.

 

I know that if I reported this as a bug to Mandriva I would just be told that it was 'upstream' and therefore nothing to do with them, but when you release it there are going to be a whole lot of people that want the puel version running on Mandriva and they are not all going to be as patient as I am. I also had a lot of problems with AWN, which I won't bore you with because again that is 'upstream', but people are going to want to run that on 2009.1 as well.

 

Overall I was not really impressed, this was almost back to the bad old days of Linux when you spent a day installing and a couple of months to get things working! That kind of performance is not acceptable any more.

 

Having said that it now has Xfce running over Gnome and everything seems to be working, but it hasn't been easy. Both Mint and Pclos, which I have installed recently, were much easier to work with.

 

EDIT. If the above wasn't bad enough I now find it doesn't produce any sounds - not a peep. Bloody pulseaudio again I presume :wall:

 

EDIT2. OK I solved that one as well. It just depends which one of the 37 different installed volume controls you choose to work with.

Edited by viking777

Share this post


Link to post
Share on other sites
EDIT. If the above wasn't bad enough I now find it doesn't produce any sounds - not a peep. Bloody pulseaudio again I presume :wall:

 

Interestiing report, my experience so far with earlier versions of MDV (up to 2008.1) and the mandriva nvidia binary drivers have been positive, I only had to change the xorg.conf manually for my dual screen setup (Mandriva, when will you finally add dual screen setup to the MCC tools??!!)

 

With regards to pulseaudio, it's pointless, it's the first thing I always disable on a new install (unfortunately it's a hasssle to disable too, as so many apps have it as their default, that need reconfiguring).

ALSA supports natively playback from multiple programs at the same time, and has been for quite a while, therefore I don't see the point of any 'audio server' anymore (apart from Jack for Pro-Audio use).

Edited by tux99

Share this post


Link to post
Share on other sites

On Cooker, editing xorg.conf is pretty pointless- unless of course you disable evdev.

I had evdev disabled in all my boxes at first, as I hated the evdev idea (quite logical: why write hal stuff in XML instead of simpler plaintext xorg rules?) but since evdev managed hardware is "the future" I have been using it in all my boxes since a few weeks ago.

Share this post


Link to post
Share on other sites

That is interesting scarecrow. I'll be honest here and say that my knowledge of 'evdev' is ever so slighlty more than zero, but not by much. I thought it had something to do with mouse/keyboard configurations, are you saying it could influence the graphical side of xorg as well? I just wonder if this is why I have had so many problems with Nvidia drivers since installing Cooker that I have never had before and don't have with other distributions - 2009 for example is quite OK. I do often use xorg.conf files saved from previous installs in new installations since that is often easier than trying to configure them yourself and has usually been 100% successful. Is that about to end?

 

Incidentally, I didn't do that on the latest install.

Share this post


Link to post
Share on other sites
I have been having so many problems with my Cooker install just recently that I decided to start again with a fresh install of RC1.

You seem to have done a one/dualarch or netinstall, if you would have installed from one(or powerpack) the nvidia drivers would have been set up by default from install. If you do do an install from free/dualarch or netinstall, then problems like this are very likely to happen on cooker but not stable, as the cooker repositories are in constant flux and it takes some time for them to sync. The released version will have binary kernel modules for the version of the video driver at release and all kernel updates...

Share this post


Link to post
Share on other sites
That is interesting scarecrow. I'll be honest here and say that my knowledge of 'evdev' is ever so slighlty more than zero, but not by much. I thought it had something to do with mouse/keyboard configurations, are you saying it could influence the graphical side of xorg as well? I just wonder if this is why I have had so many problems with Nvidia drivers since installing Cooker that I have never had before and don't have with other distributions - 2009 for example is quite OK. I do often use xorg.conf files saved from previous installs in new installations since that is often easier than trying to configure them yourself and has usually been 100% successful. Is that about to end?

 

Incidentally, I didn't do that on the latest install.

 

Cooker has switched to the latest x11 server (1.6.0) where input hardware is managed by evdev, and so all the entries for it in xorg.conf get ignored.

You can still disable the so-calleed "device hotplugging" by adding to your xorg.conf

 

Section "ServerFlags"

Option "AutoAddDevices" "False"

EndSection

 

...but my guess is that at some time this option will be obsoleted, so it's better to get used to device hotplugging, its niceties and its annoynaces right now.

Edited by scarecrow

Share this post


Link to post
Share on other sites

That is interesting my "Server Flags" section doesn't contain such an option, only these.

 

Option "allowmouseopenfail"

Option "Xinerama" "0"

Option "ignoreABI" "true"

 

When I used XFdrake to generate a new xorg.conf it had no "Server Flags" section at all!

 

Never mind I have it working (for now).

Share this post


Link to post
Share on other sites

AFAIK the only way to make xorg 1.5.X+ to respect your xorg.conf settings is putting in the above "AutoAddDEvices" argument.

Personally, I have backed up (renamed) my xorg.conf, and booted X with no xorg.conf (evdev to the command). Keyboard and mouse were working, but I had to add some XML rules to make evdev manage keyboard layouts, and I also had to create a new, minimal xorg.conf as evdev was using vesa as driver for my nvidia card. Creating this xorg.conf was pretty straighforward, by simply typing

#nvidia-xconfig --composite

Hardly an optimized xorg configuration, but you can do it at your leisure l8r...

The ArchLinux wiki for xorg, policykit and hal is a good read for the issue, and most of the tips there apply for pretty much any modern distro, not just Arch.

OF course the traditional config methods are still valid, but the current trend is Freedesktop.org compliance, which means ConsoleKit, PolicyKit, hal, evdev and managing XML files. I surely prefer oldfashioned (and understandable) plaintext config files, but I'm slowly getting better in using XML. One of these days I may even get proficient... I'm not THAT old yet! :P

Edited by scarecrow

Share this post


Link to post
Share on other sites

Thanks scarecrow. If it goes wrong in the future I will try and remember that, but for the moment it is working Ok so I will just leave it.

Share this post


Link to post
Share on other sites

Well, I just picked up my first kernel update in my 'new' cooker - the result is exactly the same as the old one - no graphics and no virtualbox. So basically the whole reinstallation was a waste of time. And Cooker is no nearer to being usable than it was when it was released.

 

Dkms installed the graphics driver with no reported errors but still no graphics, the dkms vboxdrv and vboxnetflt installs both failed. I think the graphics fail because the -devel files do not cut it, it needs the -source files which are not installed by default. I am away off to get those now to see if it makes a difference. As for vboxdrv I have no idea I will probably have to install it manually. Last time I had to manually edit the vboxdrv makefile before it would work.

 

Edit. No. Source files made no diference, I had to install the nvidia and vboxdrv drivers by hand now everything works again. This is NOT the way it should have to be, and this is a completely fresh install remember.

Edited by viking777

Share this post


Link to post
Share on other sites

nvidia driver 180.41 is broken for AGP cards; dont know if you have one. Anyway there is another weird bug were you the x server won t start initially and you will see a black screen with a blinking cursor only. To get x started do service dm restart in a vt

Edited by ffi

Share this post


Link to post
Share on other sites

Might be something in that ffi. As for AGP I don't know if I have got one either!! I don't play games so I don't take much notice of graphics cards.

It don't get the same behaviour as you describe. I get a couple of annoying screens asking me if I want to check output of this or that log file. Then a login prompt.

Share this post


Link to post
Share on other sites

if it is the laptop in your signature, I actually doubt it still has AGP but rather (mini)pci-e but still not 100%, laptops can be weird.... DKMS works here for me  (with all 180 series drivers) and I only have -devel installed.

 

Maybe you have a bad burn? btw did you try the service dm restart thing?

Share this post


Link to post
Share on other sites

I have no need to try the service restart because since I installed the nvidia driver manually Cooker graphics work normally, but the next time I get a kernel update it will break again and I will try your suggestion then.

 

I would stress that I have 4 distros running on this laptop (which is pci-e you are right) and Cooker is the only one affected in this way. It must be the driver (dkms installs 180.41 which does install but fails to produce any images whatsoever) I install 180.29 which works.

Share this post


Link to post
Share on other sites

I think you would best file a bug and/or ask Anssi on irc, when he's not away for military service he's quite fast to respond and help fix things...

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...