Jump to content
seebor

Changing bootloader options, and one other issue

Recommended Posts

Hi all,

 

I have spent the past couple of hours trying to figure this out, and it just isn't working.

 

When I load the Configuration Center and go to the Boot section then click "Set up boot system" or "Set up boot graphical theme of system", I get the error "This program has exited abnormally". Running "drakboot --splash" gets me the following:

INTERNAL ERROR: hd1 has no mapping in device.map (when translating (hd1,0))
MDK::Common::Various::internal_error() called from /usr/lib/libDrakX/bootloader.pm:1569
bootloader::grub2dev_and_file() called from /usr/lib/libDrakX/bootloader.pm:1576
bootloader::grub2dev() called from /usr/lib/libDrakX/bootloader.pm:334
bootloader::read_grub_menu_lst() called from /usr/lib/libDrakX/bootloader.pm:220
bootloader::read_grub() called from /usr/lib/libDrakX/bootloader.pm:173
bootloader::read() called from /usr/sbin/drakboot:51

 

After searching Google for the past several hours, I have finally decided to throw in the towel and ask here.

 

The other issue I am having at the moment is the following error when running almost anything from a terminal:

GConf Error: Failed to contact configuration server; some possible causes are that you need to enable 
TCP/IP networking for ORBit, or you have stale NFS locks due to a system crash. 
See [url="http://www.gnome.org/projects/gconf/"]http://www.gnome.org/projects/gconf/[/url] for information. 
(Details -  1: Failed to get connection to session: Did not receive a reply. Possible causes include: the remote application 
did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.)

 

This does not seem to be having any adverse effects, however it repeats multiple times and is generically irritating.

 

For reference I am running:

MandrivaLinux Release 2009.0 (zarapha)

Kernel Linux 2.6.27-desktop586-0.rc8.2mnb

 

Any ideas as to how to fix these would be appreciated. Thanks in advance.

Share this post


Link to post
Share on other sites
For the second error, if you are trying to load something from terminal as root then try using:

su -

 

For execution of single commands as root you normally use "sudo" from terminal. The dash in the example above makes the resulting shell a login shell - which is rarely necessary.

Share this post


Link to post
Share on other sites
Thanks, that stopped any errors from coming up, but what does it do differently?

The command "su" without parameter executes the "set user" command with defaul user "root", i.e. as result you get a shell prompt with root privileges.

Share this post


Link to post
Share on other sites

su => switches to root but keeps the current user's environment and current path

su - => switches to root with root user evironment and changes to root user home dir (normally /root)

 

it is generally advisable to always use 'su -', using 'su' without the minus can have strange effects as you will be root but still be using your own environment settings (sometime you want that, but if in doubt 'su -' is the better choice)

 

I'm not sure about the drakboot problem but the file the error refers to seems to be:

/boot/grub/device.map

 

What does that file contain on your system, is a hd1 entry in there?

Edited by tux99

Share this post


Link to post
Share on other sites

contents of /boot/grub/device.map

 

(hd0) /dev/sda

 

 

I am going to try adding the following:

 

(hd1) /dev/sda1

 

 

And we'll see what that does for me.

Share this post


Link to post
Share on other sites
it is generally advisable to always use 'su -', using 'su' without the minus can have strange effects as you will be root but still be using your own environment settings (sometime you want that, but if in doubt 'su -' is the better choice)

 

Hm. Didn't have the need to use "su -" in more than eight years of Linux. Strange...

Share this post


Link to post
Share on other sites
Thanks, now i just need to figure out how to fix gconf.

 

Seebor, you shouldn't run gnome apps out of root context if you don't have to (could be mcc, it's modules or similar). If the error occurs for *normal* apps from user context, there's something wrong elsewhere, not with gconf.

Share this post


Link to post
Share on other sites
Hm. Didn't have the need to use "su -" in more than eight years of Linux. Strange...

 

It varies from one distro to the next. I also never ever used "su -" unless it was Red Hat/CentOS. But then I just edited /etc/bashrc and created an alias instead - which most of the other distros I used already had, which was:

 

alias su="su -"

 

so whilst in the other distros, we just typed "su", it was actually doing "su -" we just never knew about it. Mandriva used to be like this until recently it seems.

Share this post


Link to post
Share on other sites
so whilst in the other distros, we just typed "su", it was actually doing "su -" we just never knew about it. Mandriva used to be like this until recently it seems.

 

This is quite interesting! Arch Linux, which I'm using here recently, doesn't have it (obviously). I'll check Ubuntu and SuSE, too.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...