Jump to content

How to get the correct Nvidia configuration.


Recommended Posts

I just upgraded from 2008.1 to 2009. I did it by updating the repos, and running an update.


The only issue I have is the video configuration.


Lspci shows :

lspci |grep VGA
00:0d.0 VGA compatible controller: nVidia Corporation GeForce 6150SE nForce 430 (rev a2)


I ran XFdrake ( several times ). I can get the xserver to run if I specify NVIDIA GeForce FX series, which the card is not.


This hardware has worked for at least 10 months on 2008.1 with NVIDIA GeForce 6100 or later. If I select that on 2009, and run a 'test' through XFdrake, I get the rainbow picture, if I click YES to save, the screen screws up, and the system is locked. Only a power off gets it going again.


I can not activate 3D stuff with a FX card defined. 3D worked well in 2008.1.


Here are the device lines from xorg.conf.


Section "Device"
   Identifier "device1"
   BoardName "NVIDIA GeForce FX series"
   Driver "nv"
   Option "DPMS"


I can remember XFdrake asking if I wanted to use the 'proprietory drivers' , I said yes when I selected the 6100 card or later.


How do I go about getting the correct card and driver selected, so I can get the 3D stuff going?

Link to comment
Share on other sites

I have tried to add the two backports, they add to the list, but I can not get them to update.


I click on the check box, the pop up asks Is it O.K. to contact... I click YES, and nothing happens. This is frustrating. Is this function broken???

Link to comment
Share on other sites

I am having a similar problem, cannot add backports. I click on that little box but I can't get the tick mark to appear there. :huh:


I wonder if it has something to do with the way I added the repositories. I did it from command line, in three lines;


urpmi.removemedia -a

urpmi.addmedia --distrib --mirrorlist 'http://plf.zarb.org/mirrors/$RELEASE.$ARCH.list'

urpmi.addmedia --distrib --mirrorlist '$MIRRORLIST'

Edited by boatman9
Link to comment
Share on other sites

I got the backports to add, and update, finally. I clicked on the backport, then on the Edit button. On the window that appears, I selected Curl, and Save Changes. Then it does the update. Did the same for Non free backports, and it updated.


I then followed the instructions to update 'ldetect-lst'.


I ran XFdrake from a root shell. It appeared to do the same thing as before. If I picked 6100 or newer, and then Test, the test did not work.


I thought I would take a stab in the dark, selected 6100 or newer, and saved it. Booted the system, the driver now works. I was able to enable the 3D stuff :thumbs:


I have no idea why the test should fail, it makes it look like the wrong card is specified. If I go to MCC now, and run XFdrake, I see the correct card selected, the test works as normal.


Any way, I'm calling my problem solved. B)


Back to the spinning cube...

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...