Jump to content
Helmut

USB stick read only [solved]

Recommended Posts

Hi Folks,

 

I'm running Mandriva 2009 in Gnome on an IBMx31 laptop.

Upon inserting the USB-stick it will mount, but all files remain read only. I cannot put anything on the stick.

 

grateful for any help,

Helmut.

Share this post


Link to post
Share on other sites

Are you part of the “floppy†group? It seems that this is the group for a usb key:

[yves@localhost ~]$ ls -l /dev/sdb1
brw-rw---- 1 root floppy 8, 17 2009-01-20 11:34 /dev/sdb1

Yves.

Share this post


Link to post
Share on other sites

if floppy is marked as the group, like yves shows in his example, then try:

 

gpasswd -a username floppy

 

replace username with your username and then log out and back in again. Then see if you have access to the pendrive.

Share this post


Link to post
Share on other sites
that code brings me "command not found"

 

It seems you are not running it as root. Else, it would return "adding user abcde to group floppy" or something very close to that.

Share this post


Link to post
Share on other sites

It may have a high level of security if it is to MDV.

msec 1 ###as root.

Install package msdostools

Edited by Lexicon

Share this post


Link to post
Share on other sites

After running "gpasswd..." as root, ( I did that before as user) it did add my username to the group floppy, but the problem persists.

The security level was reduced to "poor" and this problem persists: If I want to record onto the pendrive it says "device is read only".

I shall follow your suggestion and install package dostools, but then what?

 

Helmut

Edited by Helmut

Share this post


Link to post
Share on other sites

Either that solves the problem or it has to be searched somewhere else. I've experienced that kind of problem before. To me it seems rather access rights related - on system level you have to mount the device, but you want to use (i.e. write to) the device as user. Nowadays we have hal, so I cannot go further. Maybe scarecrow or someone else with further experience can give another hint?!?

 

A workaround would be to login as root, then copy all the files you want. For security reasons I'd disable all network connections beforehand.

 

Kind regards,

 

schollsky

Share this post


Link to post
Share on other sites

I I saw what I used in the mtab and options remount rw (read-write)

example

mkdir /mnt/disk

mount -o remount rw /dev/sdb1 /mnt/disk

remembet this is example....Lex

Edited by Lexicon

Share this post


Link to post
Share on other sites

Currently, the mtab contents are rather irrelevant. However, seeing if there is some odd fstab entry for USB devices is certainly a good idea.

Do you have any entries about /proc/bus/usb in your /etc/fstab config file?

Share this post


Link to post
Share on other sites

If you added to the floppy group, and then logged out and back in again, it should have given you access to read/write. If not, I also found this to solve my problem today:

 

chmod -R g+s /media/disk

 

or replace /media/disk with whatever mount point you have for the disk. Plug in the pendrive, and then from a console prompt, as root, type:

 

mount

 

and see what it shows for /dev/sdb1. Then, check the rights on this mount point:

 

ls -l /media/disk

 

or whatever the mount point is. See what the username and group is assigned to it, post it here so we can help.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...