Jump to content
Sign in to follow this  
Sunwatcher

Cannot configure my monitor correctly

Recommended Posts

I have just installed Linux Mint 6 on one of my computers, but I cannot get the optimum resolution on my monitor. The monitor is an (older) NEC MultiSync LCD 2010X. It measures 20" and the optimum resolution is 1280x1024. Currently, is displays at 1024x728. I have an nvidia 6200 video card which Mint configured nicely. I have compiz working, and everything looks great -- except the resolution!

 

Here is the content of xorg.conf:

# xorg.conf (X.Org X Window System server configuration file)

#

# This file was generated by dexconf, the Debian X Configuration tool, using

# values from the debconf database.

#

# Edit this file with caution, and see the xorg.conf manual page.

# (Type "man xorg.conf" at the shell prompt.)

#

# This file is automatically updated on xserver-xorg package upgrades *only*

# if it has not been modified since the last upgrade of the xserver-xorg

# package.

#

# Note that some configuration settings that could be done previously

# in this file, now are automatically configured by the server and settings

# here are ignored.

#

# If you have edited this file but would like it to be automatically updated

# again, run the following command:

# sudo dpkg-reconfigure -phigh xserver-xorg

 

Section "Device"

Identifier "Configured Video Device"

EndSection

 

Section "Monitor"

Identifier "Configured Monitor"

EndSection

 

Section "Screen"

Identifier "Default Screen"

Monitor "Configured Monitor"

Device "Configured Video Device"

EndSection

 

Can anyone help?

Share this post


Link to post
Share on other sites

What is the output of this command in a terminal window ?

xrandr -q

 

Yves.

Share this post


Link to post
Share on other sites
What is the output of this command in a terminal window ?

xrandr -q

 

Yves.

 

xrandr -q gives:

$ xrandr -q

Screen 0: minimum 320 x 240, current 1024 x 768, maximum 1024 x 768

default connected 1024x768+0+0 0mm x 0mm

1024x768 50.0*

800x600 51.0 52.0 53.0

680x384 54.0 55.0

640x480 56.0

576x432 57.0

512x384 58.0

400x300 59.0 60.0 61.0

320x240 62.0

Share this post


Link to post
Share on other sites

Oh! That's not a good sign. You'll probably have to play with modelines to get to anything higher than 1024x768. I have no knowledge in this area though. Good luck. Maybe gtf can help you.

 

Yves.

Share this post


Link to post
Share on other sites
Oh! That's not a good sign. You'll probably have to play with modelines to get to anything higher than 1024x768. I have no knowledge in this area though. Good luck. Maybe gtf can help you.

 

Yves.

 

Sounds bad. Yves, if you have a moment, could you explain what exactly is not a good sign? I'm still trying to learn more about how my machines and linux work.

Share this post


Link to post
Share on other sites

Normally when I've seen this sort of thing, the wrong monitor was chosen that didn't support higher than 1024x768, for example. I don't know if Linux Mint is using the new xorg or not, because now in Ubuntu 8.10 I don't see options so far for configuring the monitor as it tends to all auto-detect now in the new version of xorg.

 

Check the monitor you have configured, if you have it configure correctly, but the resolution won't let you go higher than this, then ensure that you use Generic CRT or Generic LCD and choose the one that supports your maximum resolution. Then you should be fine. Of course, don't try to use too high a mode, else you could cause problems to your monitor. Only use what you know it supports.

Share this post


Link to post
Share on other sites

Good advice Ian.

 

I was going to suggest that Sunwatcher edit his xorg.cong file and add an appropriate modeline, but I like your suggestion better.

Share this post


Link to post
Share on other sites

On just checking, it does have the latest xorg (since it's based on Ubuntu 8.10), so it will be auto-detecting everything like I have it. My xorg.conf looks like this:

 

Section "Monitor"
Identifier	"Configured Monitor"
EndSection

Section "Screen"
Identifier	"Default Screen"
Monitor		"Configured Monitor"
Device		"Configured Video Device"
SubSection "Display"
	Virtual	2704 1050
EndSubSection
EndSection

Section "InputDevice"
Identifier	"Generic Keyboard"
Driver		"kbd"
Option		"XkbRules"	"xorg"
Option		"XkbModel"	"pc105"
Option		"XkbLayout"	"us"
EndSection

Section "InputDevice"
Identifier	"Configured Mouse"
Driver		"mouse"
Option		"CorePointer"
EndSection

Section "InputDevice"
Identifier	"Synaptics Touchpad"
Driver		"synaptics"
Option		"SendCoreEvents"	"true"
Option		"Device"		"/dev/psaux"
Option		"Protocol"		"auto-dev"
Option		"HorizEdgeScroll"	"0"
EndSection

Section "ServerLayout"
Identifier	"Default Layout"
Screen		"Default Screen"
InputDevice	"Synaptics Touchpad"
EndSection

Section "Device"
Identifier	"Configured Video Device"
EndSection

 

output of xrandr -q command:

 

root@esprit:/home/ian# xrandr -q
Screen 0: minimum 320 x 200, current 1680 x 1050, maximum 2704 x 1050
VGA disconnected (normal left inverted right x axis y axis)
LVDS connected 1680x1050+0+0 (normal left inverted right x axis y axis) 331mm x 207mm
  1680x1050	  60.6*+
  1600x1024	  60.2  
  1400x1050	  60.0  
  1280x1024	  60.0  
  1440x900	   59.9  
  1280x960	   60.0  
  1360x768	   59.8  
  1152x864	   60.0  
  1024x768	   60.0  
  800x600		60.3  
  640x480		59.9  
TV disconnected (normal left inverted right x axis y axis)

 

now, I know that my monitor maximum on my laptop is 1680x1050, and yet my monitor config looks like this:

 

Section "Screen"
Identifier	"Default Screen"
Monitor		"Configured Monitor"
Device		"Configured Video Device"
SubSection "Display"
	Virtual	2704 1050
EndSubSection
EndSection

 

xrandr reported a max of 2704x1050 as shown by the screen section that I took from the xorg.conf and just posted above to highlight it even more. I'd suggest editing your screen section and adding a virtual line for the resolution that you want to run, so based on what you posted before, your screen section would look like:

 

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
SubSection "Display"
	Virtual	1280 1024
EndSubSection
EndSection

 

and see how you get on. Will require a restart of xorg to do this, so a simple CTRL-ALT-BACKSPACE will sort this out unless you prefer to fully reboot the system. You'll then need to go into screen resolution and see if you can change it and get it to go higher. Not guaranteeing that this will work, but just an idea. I can't go to 2704x1050 anyway, but all I can think of, unless a modeline would do the trick. You could always try the detect displays button also to see if it changes anything and gives you a higher resolution to use.

Share this post


Link to post
Share on other sites

Don't waste your time...

This version of Mint is using the latest Ubuntu base, and xorg-server 1.5X, which simpy ignores the xorg.conf settings.

Whatever you may want to do to change the default behaviour, you MUST change the HAL settings.

Or, alternatively, you can add to your /etc/X11/xorg.conf (if this thing exists right now) a section like that:

 

Section "ServerFlags"

Option "AutoAddDevices" "False"

EndSection

 

This will disable input hotplugging, and make your xorg.conf settings being respected.

Edited by scarecrow

Share this post


Link to post
Share on other sites

...but your monitor is not an input device.

 

The problem is not input hotplugging, which is irrelevant here, but RandR 1.2-compliant drivers. These don't use the old xorg.conf format for specifying preferred resolution and all that jazz, they'll happily ignore it. You can, however, specify preferred resolution in a way that RandR 1.2-compliant drivers should accept. Details here:

 

http://wiki.debian.org/XStrikeForce/HowToRandR12

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...