Jump to content

Updating Java (JRE)?

Recommended Posts


I just tried to update Java from 1.6.0_06 to the new 1.6.0_10, but when I check my Java version on java.com or javatester.org it still says my version is 1.6.0_06. I have tried uninstalling it using 'Mandriva Software Management' but I still get the same thing. I am using the jre-6u10-linux-i586.rpm to install with and it doe's not give any errors. Any ideas please?



[moved from Virtual Machines & Emulators by spinynorman]

Link to comment
Share on other sites

I suspect that you are using the rpm from sun to replace a Mandriva rpm, given by the fact that the test is reporting an earlier version . I believe that the sun rpm will not update the Mandriva rpm, Similarly when installing with the sun rpm you have to manually add the link between the plugins directory for Firefox and the plugin you have installed along with the runtime.


what is the output of

ls -la /usr/lib/mozilla/plugins

Link to comment
Share on other sites

Where do I get java-1.7.0-icedtea-plugin from?

output of rpm -qa | grep -i jre is:



output of ls -la /usr/lib/mozilla/plugins is:

total 468
drwxr-xr-x 2 root root   4096 2008-10-27 17:38 ./
drwxr-xr-x 4 root root   4096 2008-04-18 16:33 ../
lrwxrwxrwx 1 root root	 39 2008-10-21 22:25 libflashplayer.so -> /usr/lib/flash-plugin/libflashplayer.so*
-rwxr-xr-x 1 root root   7932 2008-09-23 17:29 libmozsvgdec.so*
-rwxr-xr-x 1 root root  18200 2008-07-24 22:32 libnpflash.so*
-rwxr-xr-x 1 root root  66436 2008-10-02 09:20 libtotem-basic-plugin.so*
-rwxr-xr-x 1 root root  94220 2008-10-02 09:20 libtotem-cone-plugin.so*
-rwxr-xr-x 1 root root 102628 2008-10-02 09:20 libtotem-gmp-plugin.so*
-rwxr-xr-x 1 root root  68508 2008-10-02 09:20 libtotem-mully-plugin.so*
-rwxr-xr-x 1 root root  77028 2008-10-02 09:20 libtotem-narrowspace-plugin.so*
lrwxrwxrwx 1 root root	 39 2008-10-27 17:38 nphelix.so -> /opt/real/RealPlayer/mozilla/nphelix.so*
lrwxrwxrwx 1 root root	 40 2008-10-27 17:38 nphelix.xpt -> /opt/real/RealPlayer/mozilla/nphelix.xpt*

Link to comment
Share on other sites

Icedtea was in the Main Release repositories for 2008.1, but it appears it is not in the Main Release repositories for 2009.0. I am still using 2008.1. All I see in 2009.0 in Main Release is: java-1.6.0-openjdk-plugin- One would think that the version in Mandriva 2009.0 would be at least as recent as the one in the previous Mandriva release, but maybe not.


Here is all I find for icedtea on 2009.0:


EDIT: And I don't even see the plugin listed there.

Edited by David Batson
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...