Jump to content
Sign in to follow this  
xboxboy

Suggestions for new hard drive partitions

Recommended Posts

Ian, there are 8 sata ports in all. 2 are on the silicon image controller, which you can use software (os controlled raid).

6 ports are controlled through the intel matrix, ICH10R controller, which is raid on the motherboard, but the ICH10R needs a driver install to use as raid. I guess this means the ICH10R is the fakeraid we hear so much about.

 

I spun up my mandriva install disk and the install program sees the raid array correctly, so my raid installation is fine. Yay. I have a copy of pclinux07 which is a live disk and that runs fine.

 

The bad news...looks like windows is broken....when trying to use raid1 :wall:

 

I guess I'm gonna have to trawl the web.....

Share this post


Link to post
Share on other sites

If a driver is required, it's not always software raid or fakereaid as such. You may find the Intel Matrix performing better, but you can check and test it. So you have two RAID controllers that you can configure? The Silicon and Intel?

Share this post


Link to post
Share on other sites

From what I understand yes. The mother board manual is written in broken english unfortunately.

 

The windows install goes fine, just upon initial reboot it doesn't load past the windows symbol and enters a continual reboot loop.

Share this post


Link to post
Share on other sites

Do you mean the Windows XP loading sign or when you get to login?

 

Perhaps try installing without loading the Intel Matrix driver if your disks are not attached to it.

Share this post


Link to post
Share on other sites

Yes its the loading sign. If I diable raid through the bios, then it boots fine.

Share this post


Link to post
Share on other sites

I had a friend pop over, who was able to boot windows with out the auto reboot, so I could read the BSOD.

 

STOP 0x0000007B

 

A very broad fault code.. We believe it is the raid driver given that it boots fine with raid turned off.

 

So far I have tried the latest driver from intel, no good

 

The latest driver from ASUS no good.

 

I've just done a bios update, and reinstalling with latest ASUS driver.

 

So Im just letting it install and we will see how we go this time.....

 

Funnily enough, my Mandy 2008 disk (Thanks Aussie john) sees the Raid array, with no messing around what so ever......

Share this post


Link to post
Share on other sites

mmm now I feel silly. I changed to an untampered xp disc. Fired up straight away, installing all drivers now. Raid1 is working! Wooo Hoo!

Share this post


Link to post
Share on other sites

So now my windows i performing perfectly...well as good as it can LOL....

 

I've been thinking, has anyone managed to get the My Docs from windows and /home from linux on the same partition? I can see how to move my docs to a partition and /home to a partition, but how to combine them???

 

could you have /home with /my docs as a directory with in that? I'm not sure

 

Suggestions please,

 

Thank you for your help with the RAID setup, I'm most pleased with the result.!!!

Share this post


Link to post
Share on other sites

First, you'd have to have MyDocs in Windows on it's own disk or partition if you like. For example, if you had Windows on C:, then just create another partition called D: and place all your documents here. Then it is separate from the usual place of C:\Documents and Settings\blah blah blah.

 

Then, you just change the My Documents icon on the desktop, to point to the folder on D: and you've sorted the Windows side.

 

Then, all you do now in Linux would be:

 

mkdir /home/username/mydocs

 

for example, and then:

 

mount /dev/sda2 /home/username/mydocs

 

assuming that D: was /dev/sda2 and C: was /dev/sda1, and you'd have access to your home user and mydocs in the same place. Of course, it would have meant that you had Windows installed and the second partition in place first, before you then installed Linux.

Share this post


Link to post
Share on other sites

Ok so I tried to install 2008. Everything went ok I think.

 

I left the windows install at 50gb

2nd partition at 500gb, this is to be my data partition, not sure what to format it as, so I did NTFS,,,,Had the option of NTFS-3G should I have used this????

3rd partition was 7mb swap, was as low as I could go, next size up was like 15gb or something rediculous.

4th partition was 10gm for mandy 2008

and the remaining 50gb free for other distros and messing around

 

When I rebooted, no menu!!! Straight back into windows....:(

 

So I try to reinstall the boot loader, what it sees is: (detects the raid setup fine)

 

/dev/loop0

/dev/sda

/dev/sda1

/dev/sda5

/dev/sda6

/dev/sda7

/dev/sdb

/dev/sdb1

/dev/sdb5

/dev/sdb6

/dev/sdb7

 

It finds a mandriva linux, root on /dev/sda7

 

when i run reinstall, this is what i get:

 

running: sh/boot/grub/install.sh with root /mnt

 

grub>root (hd0,86)

error 21 Selected disk does not exist

 

grub> setup --stage2=.boot/grub/stage2 (hd0)

error 12 Invalid device requested

 

grub> quit

 

Too me it seems as though it isn't installing to the MBR correctly...Ok how does one go about fixing this???

Share this post


Link to post
Share on other sites

It should have been:

 

root (hd0,8)

 

assuming that /dev/sda7 is where you put / when you were installing. What mount points did you choose for:

 

/dev/sda5

/dev/sda6

/dev/sda7

 

it would help, because then I'll know which partition has /boot, and so we can choose what to put in grub. But hd0,86 is definitely not correct unless that was a type. Usually though from an install, I would have expected /dev/sda5 to be / unless you changed all this and did it custom.

Share this post


Link to post
Share on other sites

Ian, thanks for reply.

 

sda1 is windows

sda5 data

sda6 swap

sda7 linux root

Share this post


Link to post
Share on other sites

So it should be:

 

root (hd0,6)

 

Since:

 

sda1 = 0,0

sda2 = 0,1

sda3 = 0,2

sda4 = 0,3

sda5 = 0,4

sda6 = 0,5

sda7 = 0,6[/code]

 

I was thinking wrong the other day so definitely not hd0,8. That should sort you out.

Share this post


Link to post
Share on other sites

Hello xboxboy.

 

That 7mb swap is a waste of time. It is so small that you might as well have had no swap partition at all. It will serve no practical purpose at all. If you want a minimum swap because you have swags of hard memory then set from 265mb up to 512mb.

 

Cheers. John.

Share this post


Link to post
Share on other sites

Thanks guys, how do I edit this grub then?? Sorry I tried to reinstall the bootloader from the mandriva disc, but no good.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...