Jump to content

2009 on the way!


Recommended Posts

I have finally got the bandwidth available to update one of my 2008.1 installations to Cooker, so at the present moment in time I am downloading 1242 packages to carry out the conversion. I am going to be very interested to see if this works as I have not upgraded to a Cooker variant before, the last time I installed Cooker it was from one of the ISO's.


It is obviously going to take a while but I will let you know what I end up with later on tonight.


Fingers crossed :unsure:

Link to comment
Share on other sites

Be aware that you could trash your system like i did 2 days ago so.....you have been warned and a backup of the old system seems a good idea. :thumbs:




Link to comment
Share on other sites

Well it comes as no matter of surprise to me that after 2 1/4 hrs of updates I got a system that produces only a login screen. It is a very familiar login screen, it even has my name on it, but whatever choices you make from it all you get is another login screen. Not much use really, but just about what I expected (no, come to think of it I didn't even think I would get as far as a login screen!).




Thank you for your concern, but I always have multiple installations on my hard drive so that if I trash one I can always boot another - as well as full partition images.


I haven't had time to look around to see if anyone else has been affected like this so maybe there is a fix somewhere I don't know, I will have a look tomorrow.


Expecting that amount of updates to work together is really far too opimistic for anyone, never mind a died in the wool pessimist like me!

Link to comment
Share on other sites

Sometimes when you're updating to cooker it won't get all of the packages on the first go-around.


What you're describing looks very much like a problem with your WM/DE. Have you tried launching it from the command line so you can see if there are any errors?

Link to comment
Share on other sites

What login manager do you use?


When you get that login screen, press Ctrl-Alt-F2 to switch to another screen, then login as root and type:


killall kdm (or gdm, or xdm depending on what you use)


You can then switch back to the normal screen with Ctrl-Alt-F1 and log in as your normal user.

Link to comment
Share on other sites

now's not a good time for Cooker - we moved lots of stuff in X around a few weeks ago, now it's all getting moved back, and things are going up the spout thanks to it...


if you're stuck in the eternally-cycling-login-manager situation, try this - switch to a virtual console, log in as user, su to root, run 'service dm stop', go back to being normal user and run 'startx KDE'. that should get you into KDE, i think (if not try 'startx KDE3' or 'startx KDE4' or something, all I know for sure is it's 'startx GNOME' for GNOME).

Link to comment
Share on other sites

Thanks Adam and liquidzoo, between you those instructions worked. It only seems to be running IceWM at the moment but at least that is enough to get me going (thinks - I wonder if I could have booted IceWM from the login screen all along? must try that later). I can update from here and gradually get things put right.


I'm thouroughly ashamed that I couldn't remember Ctl/Alt/F2 to get a console - now I know I am going senile :woops:


That is what comes of being a gui junkie I suppose!


Anyway this is posted from 2009 so the internet is working obviously. Sound doesn't seem to be but that is something I can work on.


Thanks again for your help.


Edit. I can't start IceWM from the login screen, I have to go through a console as Adam suggested. Here is another strange fact though - if I login as normal user from the console I get IceWM whatever I type, but if I 'startx' as root from the console I get KDE3!! Is that strange or what?

Edited by viking777
Link to comment
Share on other sites

Now I have finally got it going here is a list of what does and doesn't work for me. No criticism is intended I know it is only beta (or is it alpha?) but I just thought it might be of interest.

Bear in mind that I have not made any effort to 'make' things work here just tried them out to see if they work 'out of the box' so to speak. Also the list is not exhaustive but just some of the programs I use regularly.



Firefox, Thunderbird, Kshowmail, KMyMoney, Unison, Kaffeine (dvd movies), Gparted.


Not working (generally meaning that they just wont load):

Krusader, Amarok, GoogleEarth, Virtualbox

Login (have to use console trickery - see above).

KDE (only works if I login as root)


Partially working:

Totem (loads but wont play dvd movies) Probably codecs (although Kaffeine has them)

MPlayer (loads and starts to play but generally unwatchable constant error messages and picture breakup during playback)

Sound (works but is very quiet and I haven't found a way to turn it up yet - alsamixer shows it to be at 100% already)

Link to comment
Share on other sites

Try creating a file in your /home/user folder called .xinitrc


In this file, just put the following:




Then follow the instructions adam posted to log in as your normal user (if you reboot, you don't have to as you can just log out of X) and type startx


In theory, that should launch KDE as your normal user.

Link to comment
Share on other sites

Thanks liquidzoo that worked. I now have KDE3 on 2009 as a normal user. Strangely though in KDE the sound does not work at all (error message: unable to initialize sound server)whereas in IceWM it did work, albeit quietly. Never mind that is something I can work on later.


Thanks for you time in sorting that out for me.


Edit. A side effect of running KDE is that Amarok will now load and will attempt to play music (although not very successfully without a sound server!)

Edit2. Disabled Pulse Audio and sound server is back to normal.

Edited by viking777
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...