Jump to content
Sign in to follow this  
chris:b

USB Digital Camera - how to access in MDK 9.1

Recommended Posts

Feeling very stupid to ask this question.

Yesterday we bought a digital camera, and now I can't figure out how I can access the files (.jpg) on the CF-card.

(I am able using win xp, just connecting via usb cable).

 

I connect the usb cable. What do I have to do next?

 

When I do a

 

tail -f /var/logmessages

 

it says, a new USB device blabla is found, and scsi1: scsi emulation for USB Mass storage

 

Doing lsusb:

....

Bus 002 Device 002:ID 0d96:2105 Traveler

(thats the correct camera)

 

lsusb -v:

 

a lot of information about the camera: vendor, product ID ,etc

 

I can see the 'camera' in MCC, but as unknown, the same in KDE - information about usb devices.

 

How and where do I mount the camera?

:oops:

Share this post


Link to post
Share on other sites

I would check in /dev look for a scd0 or scd1 (scd0 if you have no other scsi devices-including any cd burner, scd1 if you have a cd burner or any other scsi device, etc. if you have more than one).

 

also, since /dec/scdx is probably a symlink, if there is none check in /dev/scsi (i think that's the dir). if it's there somewhere, just create your mount point and try to mount it-although I have no clue what the filesystem maybe :?

Share this post


Link to post
Share on other sites

Not much time to help as I am about to leave, but normally those cards/cameras are identified as /dev/sdax

 

I use an USB card reader which mdk sees as /dev/sda1 and I mount it that way. It worked well when I plugged in the card reader and booted the computer. Mdk identified it and then I just had to mount it. I think it will do the same for your camera. The CF card is a V16 format if I remember correctly and mdk can see it fine.

 

Search the board a bit for "mass storage" devices and "sda" and I think you'll see a couple helpful posts. Sorry I am a bit cryptic due to short time here. HTH though! :)

Share this post


Link to post
Share on other sites

If you don't have a mount point jsut create one.

/mnt/camera for example...

It may already have made a /mnt/removable.

As root

 

mkdir /mnt/removable

chmod 777 /mnt/removable (if you want to be able to write to it too)

 

Assuming you have no other scsi disks or emuklated scsi disks

 

mount /dev/sda1 /mnt/camera -o(rw,user)

 

It should piuck up the filesystem type automatically but you can always put in a (-t vfat) at the end.

Share this post


Link to post
Share on other sites

Thanks for the responses.

I guess I was not very clear, sorry.

I had created a /mnt/camera and tried it with

 

mount /dev/sda1 /mnt/camera

and

mount /dev/sda /mnt/camera

 

The problem is that I get the error: sda1 (or sda) no such block device (that's the translation ;-). And indeed in /dev there is no sd* or sda* (whatever)

 

I tried to plug in the camera before booting, and hotplugging.

 

tyme: there is a /dev/scd0, that's my cd burner, no scd1.

And a /dev/scsi/host0/bus0/target0/lun0/cd, also the cdrom

Share this post


Link to post
Share on other sites

Which type of camera do you have?

My Fuji Finepix 2400Z is on /dev/sda1 (on Mandrake 9.0 and Mandrake 9.1)

 

Mayby Supermount is causing trouble? Have you tried turning that off?

Share this post


Link to post
Share on other sites
Which type of camera do you have?

My Fuji Finepix 2400Z is on /dev/sda1 (on Mandrake 9.0 and Mandrake 9.1)

 

Mayby Supermount is causing trouble? Have you tried turning that off?

 

It's a Jenoptik JD 2100 z3s (aka 'Traveler', aka 'Skanhex'),

a very cheap camera for great pictures :lol:

 

Traveler provides on their website a 'linux step by step' to setup an older model, but only to use gphoto2, I don't know if this is the same for usb mass storage.

 

I'll try the supermount thing the next days. Does supermount + digicam work for you?

Share this post


Link to post
Share on other sites

anna, I forgot that one, i.e. Supermount.

It was causing all osrts of problems so I turned it off a long time ago... :-)

You should be seeing the device though...

From memory the gphoto2 (last time I checked) doesn't do USB mass storage. I spent ages before RTFM

 

I justed plugged in a USB Mass storage, hers the automatic entries in my /dev

 

[root@shuttle dev]# ls -l sda*

lr-xr-xr-x    1 root    root          33 Jun  1 12:47 sda -> scsi/host0/bus0/target0/lun0/disc

lr-xr-xr-x    1 root    root          34 Jun  1 12:47 sda1 -> scsi/host0/bus0/target0/lun0/part1

Try using USBVIEW or Kde Control centre to view your USB tree. Mine picks up the USB Mass storage device.

 

(from KDE control Centre View USB}

Archos Multimedia Jukebox

 

Manufacturer: Archos

Serial #: 000000000001

etc etc...

Share this post


Link to post
Share on other sites
I justed plugged in a USB Mass storage, hers the automatic entries in my /dev

 

[root@shuttle dev]# ls -l sda*

lr-xr-xr-x    1 root     root           33 Jun  1 12:47 sda -> scsi/host0/bus0/target0/lun0/disc

lr-xr-xr-x    1 root     root           34 Jun  1 12:47 sda1 -> scsi/host0/bus0/target0/lun0/part1

Try using USBVIEW or Kde Control centre to view your USB tree. Mine picks up the USB Mass storage device.

 

 

Thanks alot stephen. that's what I was expecting to happen when plugging in the camera. But obv. though the mass storage and the camera gets detected, there it stops and a sda* is not created, i can see this in the output of the log messages. Also, I checked if all the usb and scsi modules are loaded, yes they are.

At the moment I have to get new batteries to go on testing. Found usbview on the cd 1 and installed it ...I'ill post here what will happen disabling supermount.

Share this post


Link to post
Share on other sites

anna,

its also possibly worth checking that the hotplug service is actually started and running.

 

I guess if when you installed you didn't have any usbmass storage (or other usb devices) attached it wouldn't start the service by default.

 

I'm on NT now but I guess you should have a /etc/init.d/hotplug ?

 

You can run it with status as an option and check.

If it isn't try starting it and then replugging the device??

Share this post


Link to post
Share on other sites

Good news: I disabled supermount. I should have done that earlier because now I can access faster my hdd- partitions, and the ugly cdrombalalalalala-icons on the desktop are gone :D

 

Bad news: no luck with the digicam. And here are the results. Hot-plugging the camera, I get

Jul  1 10:40:56 localhost kernel: hub.c: new USB device 00:1f.4-1, assigned address 2

Jul  1 10:40:57 localhost kernel: usb-uhci.c: interrupt, status 2, frame# 1512

Jul  1 10:40:57 localhost kernel: scsi1 : SCSI emulation for USB Mass Storage devices

 

usbview:

Unknown Device

Speed: 12Mb/s (full)

USB Version:  2.00

Device Class: 00(>ifc )

Device Subclass: 00

Device Protocol: 00

Maximum Default Endpoint Size: 8

Number of Configurations: 1

Vendor Id: 0d96

Product Id: 2105

Revision Number:  0.01



Config Number: 1

Number of Interfaces: 1

Attributes: c0

MaxPower Needed:  10mA



Interface Number: 0

 Name: (none)

..... [cut]

 

Cold-plugging:

Jul  1 11:01:41 localhost /etc/hotplug/usb.agent: Setup usb-storage for USB product d96/2105/1

Jul  1 11:01:41 localhost /etc/hotplug/usb.agent: ... no modules for USB product 0/0/0

Jul  1 11:01:41 localhost /etc/hotplug/usb.agent: ... no modules for USB product 0/0/0

 

I still don't know if its a problem of the camera (though standard usb mass storage) or a problem of my mdk configuration.

 

General news: After 6 weeks I saw win xp again on my pc, installing Adobe Photoshop which came with the camera :roll:

Share this post


Link to post
Share on other sites

How about posting the output from a lsmod ???

 

Hers mine (edited usb stuff left in)

 

]Module Size Used by Tainted: PF

lusb-storage 51952 1

sg 31276 0 (autoclean) (unused)

st 26740 0 (autoclean) (unused)

sr_mod 15096 0 (autoclean) (unused)

sd_mod 11788 0 (autoclean)

scsi_mod 90372 5 (autoclean) [usb-storage sg st sr_mod sd_mod]

ohci1394 16812 0 (unused)

ehci-hcd 14472 0 (unused)

usb-uhci 21676 0 (unused)

usbcore 58304 1 [usb-storage ehci-hcd usb-uhci]

 

If your depmod is correct you should get the usb stuff with insmod usb-storage

Share this post


Link to post
Share on other sites
How about posting the output from a lsmod ???

 

this is what i get:

 

ohci1394               19048   0  (unused)

ieee1394               45900   0  [ohci1394]

sr_mod                 16920   0  (autoclean)

ide-cd                 33856   0

cdrom                  31648   0  [sr_mod ide-cd]

ide-scsi               11280   0

usb-storage            72952   0  (unused)

scsi_mod              103284   2  [sr_mod ide-scsi usb-storage]

usb-uhci               24652   0  (unused)

usbcore                72992   1  [usb-storage usb-uhci]

usb-storage            72952   0  (unused)

scsi_mod              103284   2  [sr_mod ide-scsi usb-storage]

usb-uhci               24652   0  (unused)

usbcore                72992   1  [usb-storage usb-uhci]

______________

[edited: don't take the above code seriously, its a copy&paste mistake ...]

 

If your depmod is correct you should get the usb stuff with insmod usb-storage

 

sorry stephen, I don't understand, what is depmod?

Share this post


Link to post
Share on other sites

Hi anna

depmod is the program which makes the makefile used by modprobe to load the modular kernel drivers at runtime....

 

Yours should be created when you installed.

I can see you have usb-storage but its unused.

Actually you have it twice (both unused)

 

You could try a

modprobe usb-storage

 

 

it should then be picked up (in theory) and hopefully clean the redundant copy.

then you ca redo the lsmod.

 

It should be picked up by hotplug

 

 

ahhhh ... disgregard....

You don't have the fat or vfat modules loaded.

Your Camera will probably act like a FAT/12 filesystem so you need these to access it.

 

Check you have it:

/lib/modules/2.4.21-0.13mdk/kernel/fs/vfat/vfat.o.gz

 

If you do try an

insmod vfat

 

:-)

Share this post


Link to post
Share on other sites
I can see you have usb-storage but its unused.  

Actually you have it twice (both unused)

 

Hi Stephen, I made a stupid mistake copy&paste, so the output of lsmod has actually only one usb-storage. Also I had snipped the vfat, ntfs and so ... to make it more clear, ooh aah. Thank you for being so patiently.

Here the correct output (I snipped the sound thing...):

nfsd                   74256   0  (autoclean)

af_packet              14952   1  (autoclean)

sr_mod                 16920   0  (autoclean)

floppy                 55132   0

8139too                17160   1  (autoclean)

mii                     3832   0  (autoclean) [8139too]

ohci1394               19048   0  (unused)

ieee1394               45900   0  [ohci1394]

nls_cp850               4316   2  (autoclean)

vfat                   11820   2  (autoclean)

fat                    37944   0  (autoclean) [vfat]

nls_iso8859-15          4092   3  (autoclean)

ntfs                   76812   1  (autoclean)

ide-cd                 33856   0

cdrom                  31648   0  [sr_mod ide-cd]

ide-scsi               11280   0

usb-storage            72952   0  (unused)

scsi_mod              103284   2  [sr_mod ide-scsi usb-storage]

usb-uhci               24652   0  (unused)

usbcore                72992   1  [usb-storage usb-uhci]

rtc                     8060   0  (autoclean)

ext3                   59916   2

jbd                    38972   2  [ext3]

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...