Jump to content
Sign in to follow this  
rohitsz

Can't Connect to ADSL router via LAN

Recommended Posts

Hi,

 

First a bit of history: I have been for past couple of days trying to configure VPN client to work at home system. No success has been achieved on that front.

 

So today, I wanted to remove those VPN network interfaces. I had three of them (in order from latest to oldest): ppp0,tun0,eth0.

 

So first I stumbled across not finding a GUI to delete them, a quick google revealed:

drakconnect --delete

 

So I removed only the ppp0 interface.

I rebooted, still the default interface was getting selected as tun0,previously ppp0 was selected. I manually selected eth0, the graphical icon showed that connection was successful :-)

But a ping to the router resulted in an answer from the host itself. :huh:

 

I pinged 192.168.1.1 and got response from 192.168.1.2, indicating some network error in the ping result.

 

So I deleted the tun0 interface!

 

Then I rebooted and saw problems relating to

1)DCOP server not being started(or not being readable)

2)Configuration files kfmclientrc and kdeglobals not writable

 

These error screen came when I clicked the help option of the network icon(with a green tick or orange exclamation).

 

Please help/suggest me what next to do :unsure:

 

thanks,

rohit.

Share this post


Link to post
Share on other sites

It's not possible for the host to reply to the router IP unless eth0 was configured for 192.168.1.1. Since you got a reply from 192.168.1.2 - this was not a standard ping reply but communicating that there was some sort of error - which you just mentioned.

 

If the interface had been up and configured with an IP correctly, no reply would have appeared unless the router was online to reply. So it would mean your interface was either down, or misconfigured. Rerun configuration for the network interfaces and reconfigure eth0 so that it is correctly done.

 

You can also look in /etc/sysconfig/network-scripts and see if you have any interface files for ppp0 and tun0 and delete these as well. These should most likely be ifcfg-ppp0 and ifcfg-tun0 unless I'm mistaken, you can leave ifcfg-eth0 file though.

Share this post


Link to post
Share on other sites

Hi,

 

here are the different outputs:

 

[root@mandrivabox network-scripts]# pwd
/etc/sysconfig/network-scripts
[root@mandrivabox network-scripts]# ls
cellular.d/   ifdown-post*	ifup.d/	   ifup-sit*
hostname.d/   ifdown-ppp*	 ifup-eth*	 ifup-sl*
ifcfg-eth0*   ifdown-routes*  ifup-ipv6*	ifup-tunnel*
ifcfg-lo@	 ifdown-sit*	 ifup-ipx*	 ifup-wireless*
ifdown@	   ifdown-sl*	  ifup-plip*	init.ipv6-global*
ifdown-bnep*  ifdown-tunnel*  ifup-plusb*   network-functions
ifdown.d/	 ifup@		   ifup-post*	network-functions-ipv6
ifdown-eth*   ifup-aliases*   ifup-ppp*	 vpn.d/
ifdown-ipv6*  ifup-bnep*	  ifup-routes*  wireless.d/
[root@mandrivabox network-scripts]#

 

[root@mandrivabox home]# ifup eth0
[root@mandrivabox home]# ifconfig
eth0	  Link encap:Ethernet  HWaddr 00:19:D1:B3:4C:66
	  inet addr:192.168.1.2  Bcast:192.168.1.255  Mask:255.255.255.0
	  UP BROADCAST MULTICAST  MTU:1500  Metric:1
	  RX packets:0 errors:0 dropped:0 overruns:0 frame:0
	  TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
	  collisions:0 txqueuelen:1000
	  RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)
	  Interrupt:17 Base address:0xa000

lo		Link encap:Local Loopback
	  inet addr:127.0.0.1  Mask:255.0.0.0
	  inet6 addr: ::1/128 Scope:Host
	  UP LOOPBACK RUNNING  MTU:16436  Metric:1
	  RX packets:739 errors:0 dropped:0 overruns:0 frame:0
	  TX packets:739 errors:0 dropped:0 overruns:0 carrier:0
	  collisions:0 txqueuelen:0
	  RX bytes:58061 (56.7 KiB)  TX bytes:58061 (56.7 KiB)

[root@mandrivabox home]# ifconfig

 

[root@mandrivabox home]# ping 192.168.1.1
PING 192.168.1.1 (192.168.1.1) 56(84) bytes of data.
From 192.168.1.2 icmp_seq=1 Destination Host Unreachable
From 192.168.1.2 icmp_seq=2 Destination Host Unreachable
From 192.168.1.2 icmp_seq=3 Destination Host Unreachable
From 192.168.1.2 icmp_seq=6 Destination Host Unreachable
From 192.168.1.2 icmp_seq=7 Destination Host Unreachable

--- 192.168.1.1 ping statistics ---
7 packets transmitted, 0 received, +5 errors, 100% packet loss, time 6000ms
, pipe 3
[root@mandrivabox home]#

 

Another surprise: When I created the connection through the GUI, it did not comeup in the right-click menu of the network-icon. I had to do an

ifup eth0

from console.

 

Any thing on the DCOP server? Should I look at it at all?

 

thanks,

rohit.

Edited by rohitsz

Share this post


Link to post
Share on other sites

Check for link lights on the cable connection from your computer to the router to see if there are activity lights. If there are none, then there is no connection from the machine to the router.

Share this post


Link to post
Share on other sites

Hi ian,

Check for link lights on the cable connection from your computer to the router to see if there are activity lights. If there are none, then there is no connection from the machine to the router.

 

Well all that is done and checked.

To my(and all) surprise, the network icon is showing connected now, but the problem now is no web browser is able to open up any website, although I can ping the linux box from another system and the other way round too...

 

I can also ping my ISP gateway successfully.

 

I tried firefox, konqueror, flock, opera and lynx.

 

None of them are able to connect to any website!

 

pleae help!

 

rohit. :unsure:

Share this post


Link to post
Share on other sites

Sounds like an ipv6 issue. In Firefox, type "about:config" without the quotes and then filter for ipv6 and enable the option to disable ipv6 by double-clicking it. You can also do it for the whole system as well:

 

http://www.linuxsolutions.org/index.php?op...5&Itemid=26

Share this post


Link to post
Share on other sites

What's the contents of /etc/resolv.conf? Does it have a valid DNS Server listed?

Share this post


Link to post
Share on other sites

Hi ian,

 

What's the contents of /etc/resolv.conf? Does it have a valid DNS Server listed?

 

It has the entry as follows:

 

nameserver <IP Address>

 

I changed the address manually and restarted /etc/init.d/network but my changes were overwritten, so still no success!

 

rohit.

Share this post


Link to post
Share on other sites

Edit your /etc/resolv.conf and add in there say

nameserver 208.67.222.222

(this is the primary opendns server)

Now restart network

service network restart

from a root console.

Can you browse now?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...