Jump to content
Sign in to follow this  
Guest Graeme43

SBLive and Geforce 3

Recommended Posts

Guest Graeme43
as root, do:
lsmod

and post the results.

 

[graeme43@pc4-kirk1-3-cust45 graeme43]$ lsmod

bash: lsmod: command not found

 

and i also have on board sound that is set as master, but how do i make it secondary ( its disabled in bios, but shows up ) :x

Share this post


Link to post
Share on other sites
Guest Graeme43

Its prolly the wrong place for this but... :lol:

 

I installed Redhat 9 because it gives me sound by deafult

 

But i dont know how to install nVIDIA drivers on it :shock:

Share this post


Link to post
Share on other sites
Guest Graeme43

I think i know the problem, in the redhat setup you can choose your primary soundcard, i have onboard sound, its disabled, but it shows up, and its went primary/master because in a terminal i did alsamixer or something, and it came up for it

 

i want mandrake instead of redhat, but with sound :shock:

Share this post


Link to post
Share on other sites

The em10k1 driver that is used by many creative labs products is almost always present in a mandrake system. It is sort of like one of the default modules installed. But I have not made a system yet that won't "lsmod". If you are the superuser, or root, and you cannot "lsmod", then I agree with bvc: you have serious configuration problems! Given that all of this is installed by default, I am concerned that the installation process is somehow faulty.

Share this post


Link to post
Share on other sites
Guest Graeme43

its a lowercase L isnt it?

 

if i type alsamixer or whatever it is that brings up the mixer in terminal. it says my onboard is master, but i dont want it master, i want my SB Live master

 

would taking it out, reinstalling mandrake then putting it in solve it?

 

the reason i get sound in redhat is that during first boot i can set it to the deafult card instead of my onboard :D

Share this post


Link to post
Share on other sites

i don't understand why mandrake would be picking up your onboard sound if you have disabled in your BIOS. my mobo has onboard sound, but since i had the onboard sound disabled in my BIOS, mandrake never tried to make use of it....not sure why this isn't working for you :-/

 

either way, to fix it you'd have to be IN mandrake...and i'm sure if you had mandrake installed, we could help you fix it....

 

 

and yes, it's a lowercase L, vs. an uppercase I

Share this post


Link to post
Share on other sites
Guest Graeme43

im going back to linux now. ima gonna run setup

 

 

Quote:

In both KDE and GNOME on Mandrake, it does not start the soundserver by default. In KDE, go to the control panel and the sounds applet (I use GNOME so I can't remember what KDE calls it)... click the box to start the ARTS soundserver on startup.

 

Does sound happen to be disabled on deafult??? :shock:

 

Thanks, next message will be on Mandrake

 

:banghead:

Share this post


Link to post
Share on other sites

Linux in general is not an "all gui" system like windows. So some things that we al take for granted must be started deliberately by the user. For my part, Mnadrake sound always has worked after I initiated it in the window manager; I use kde. The real pick in 9.1 is that the sound volums are all turned down or muted by default, so after starting your arts server you need to launch a program like aumix and adjust all of your settings.

Share this post


Link to post
Share on other sites
Guest Graeme43

[root@pc4-kirk1-3-cust45 graeme43]# lsmod

Module Size Used by Not tainted

isofs 27988 1 (autoclean)

zlib_inflate 21156 0 (autoclean) [isofs]

udf 90464 0 (autoclean)

parport_pc 25096 1 (autoclean)

lp 8096 0 (autoclean)

parport 34176 1 (autoclean) [parport_pc lp]

emu10k1 62792 0 (unused)

ac97_codec 12488 0 [emu10k1]

sound 70644 0 [emu10k1]

snd-pcm-oss 43556 1

snd-mixer-oss 14488 0 [snd-pcm-oss]

snd-cmipci 23200 1

snd-pcm 77536 0 [snd-pcm-oss snd-cmipci]

snd-page-alloc 7732 0 [snd-pcm]

snd-opl3-lib 8036 0 [snd-cmipci]

snd-timer 18376 0 [snd-pcm snd-opl3-lib]

snd-hwdep 6368 0 [snd-opl3-lib]

snd-mpu401-uart 4396 0 [snd-cmipci]

snd-rawmidi 17600 0 [snd-mpu401-uart]

snd-seq-device 5832 0 [snd-opl3-lib snd-rawmidi]

snd 40868 0 [snd-pcm-oss snd-mixer-oss snd-cmipci snd-pcm

snd-opl3-lib snd-timer snd-hwdep snd-mpu401-uart snd-rawmidi snd-seq-device]

soundcore 6276 0 [emu10k1 sound snd]

af_packet 14952 1 (autoclean)

sr_mod 16920 2 (autoclean)

floppy 55132 0

8139too 17160 1 (autoclean)

mii 3832 0 (autoclean) [8139too]

nls_iso8859-15 4092 3 (autoclean)

ntfs 76812 2 (autoclean)

supermount 15296 3 (autoclean)

ide-cd 33856 0

cdrom 31648 0 [sr_mod ide-cd]

ide-scsi 11280 1

scsi_mod 103284 2 [sr_mod ide-scsi]

printer 8448 0

usb-uhci 24652 0 (unused)

usbcore 72992 1 [printer usb-uhci]

rtc 8060 0 (autoclean)

ext3 59916 2

jbd 38972 2 [ext3]

 

 

thats lsmod, im on Mandrake 91 at the moment, no soun :shock: :cry:

Share this post


Link to post
Share on other sites
Guest Graeme43

I think all i need to know is how to change deafullt sound device :!: :?:

Share this post


Link to post
Share on other sites

Check in MCC (Mandrake Control Center)->Hardware->Hardware List (I think that's it), see if your sound card is listed (either the onboard or the sound blaster). Also check your volume settings-and verify that your onboard is disabled in the BIOS-like I stated, if it is, Mandrake really _should not_ be trying to use it...

Share this post


Link to post
Share on other sites
Guest Graeme43

they are both listed, and the onboard is deafult/master/primary sound device :screwy:

Share this post


Link to post
Share on other sites

If you install mandrake in expert mode;

At the splash screen of the first Install CD press F1, and at the next screen type

expert <and hit Enter>

 

at the end of the install is a Summary screen. There you can configure stuff. Configure your sound to use the driver for what you want to be the default soundcard.

 

I don't know if this will work....but it's all I can suggest. :unsure:

Share this post


Link to post
Share on other sites

Before doing that expert install, hit DEL or whatever it is for your system to go into the BIOS. Disable both the onboard sound AND Plug'n'Play BIOS (P'n'P bios). Then do your expert install and configure the sound toward the end. Once you boot up, your volumes will be down all the way. Just open up mixer and turn em up. Shouldn't need to do anything else.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...