Jump to content
wahur

How to eliminate Ctrl-Alt-Del [solved]

Recommended Posts

Hi!

Such a funny problem. I am using certain program (Wordfast) a lot, which is heavy on keyboard shortcuts. Including all thinkable Ctrl, Alt, Ctrl-Alt combinations. Result tends to be, that when typing really fast, sometimes I end up giving it unwanted three-finger-salute :(

Is there a way to switch Ctrl-Alt-Del off, ideally only if certain program is running (it might still come handy in some other occasion)?

 

Wahur

Edited by wahur

Share this post


Link to post
Share on other sites
You should be able to disable it in kcontrol (KDE Control Centre)--> Regional & Accessibility--> Keyboard Shortcuts--> Global Shortcuts--> Desktop.

Yep, that place I know, although the default settings there were not consistent with what really happened.

I found two settings there - Log Out (Ctrl-Alt-Del) and Log out without Confirmation (Ctrl-Shift-Alt-Del). In my case C-A-D was quite enough to cause logout without any confirmation despite what these settings said. Which was annoying and caused actual loss of data. I disabled both just in case.

Still, it would be cool to know if such disabling/enabling could be done depending on, say, certain program window being/becoming active.

Share this post


Link to post
Share on other sites
Yep, that place I know, although the default settings there were not consistent with what really happened.

In my case C-A-D was quite enough to cause logout without any confirmation despite what these settings said.

 

If it's repeatable and you have a few minutes, you can look for this bug, and if it's not there, you can submit a bug report. Maybe no one is aware to this problem.

Share this post


Link to post
Share on other sites
Including all thinkable Ctrl, Alt, Ctrl-Alt combinations. Result tends to be, that when typing really fast, sometimes I end up giving it unwanted three-finger-salute :(

Are you positive that you're not hitting Ctrl + Alt + backspace sometimes?

Share this post


Link to post
Share on other sites
Are you positive that you're not hitting Ctrl + Alt + backspace sometimes?

No. In fact, now that i think about it, this might have been the case.

If speed-typing and concentrating on the text, it is sometimes quite hard to reconstruct, what I did exactly.

I do a lot of Ctrl-backspace and if because of Wordfast, finger goes to Alt a lot, this is probably what happened

This does restart X, right? Now how can I get rid of this - its just another catastrophy waiting to happen?

Share this post


Link to post
Share on other sites

Taken from here (I know you're not using Ubuntu, but it's general Linux stuff to stop this for the X Server):

 

http://www.ubuntugeek.com/how-to-disable-c...x-in-gnome.html

 

First you need to take backup of xorg.conf file using the following command

 

cp /etc/X11/xorg.conf /etc/X11/xorg.conf_backup

 

Now you need to edit the file using the following command:

 

ALT-F2 to get run command dialog

gksu gedit /etc/X11/xorg.conf

 

Add the following lines at the end of file

 

Section “ServerFlagsâ€

 

Option “DontZap†“yesâ€

 

EndSection

 

Save the edited file

 

found with google :)

 

http://www.google.co.uk/search?hl=en&q...earch&meta=

 

replace gedit with kedit if you use KDE instead of Gnome.

Share this post


Link to post
Share on other sites
Taken from here (I know you're not using Ubuntu, but it's general Linux stuff to stop this for the X Server):

 

http://www.ubuntugeek.com/how-to-disable-c...x-in-gnome.html

OK, for further reference to all Mandriva users.

Do not do it the Ubuntu way like ianw suggested above.

You will end up with X spewing errors and not coming up again.

Instead, when you open xorg.conf, you will find this DontZap option, commented out, in one of the first sections.

Simply uncomment, restart X, done.

And then pray you never need it in emergency ;)

 

Wahur, many thanks to everyone

Share this post


Link to post
Share on other sites

My way isn't any different, as it still uses the DontZap option so find it strange how it was different and didn't work since it is only this one single option, and not anything else that did it. Unless of course, your DontZap option is in another place. If so, please update the post so that people know where to look for it.

Share this post


Link to post
Share on other sites

I thought I already explained.

You suggested adding DontZap option in a new section in the end of the file.

Problem is, Mandriva xorg.conf already has that option, only its commented out.

So adding it once more ends up with X not starting anymore.

Therefore, Mandriva (and possibly, other non-Ubuntu distros) users should look for the already existing option in the file and simply uncomment.

Difference is, indeed, tiny, but might save lots of trouble for someone not used to digging in conf files.

 

Wahur

Share this post


Link to post
Share on other sites

I suggested something yes. But you didn't tell anyone exactly where the DontZap option is within your xorg.conf file. So if it has it, where is it? Copy and paste it from your existing config so people can see. This helps them :)

 

And yeah, I should have mentioned to search the file first before adding it again, because sometimes configs already have them. And sometimes not..... :)

Share this post


Link to post
Share on other sites

First, I did:

"Instead, when you open xorg.conf, you will find this DontZap option, commented out, in one of the first sections."

 

But if you insist, beginning of my xorg.conf (Ctrl-Alt-BS already disabled) looks like this:

# File generated by XFdrake (rev 230776)

Section "Extensions"
Option "Composite"
EndSection
# **********************************************************************
# Refer to the xorg.conf man page for details about the format of
# this file.
# **********************************************************************

Section "ServerFlags"
DontZap # disable <Ctrl><Alt><BS> (server abort)
AllowMouseOpenFail # allows the server to start up even if the mouse does not work
#DontZoom # disable <Ctrl><Alt><KP_+>/<KP_-> (resolution switching)
EndSection

 

Wahur

Share this post


Link to post
Share on other sites

Technically, my info is correct, since it is the same section, just that if you have it twice it causes a problem.

 

Thanks for adding it, it makes things easier when people come across the same problem as you.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...