Jump to content
  • Announcements

    • spinynorman

      Mandriva Official Documentation

      Official documentation for extant versions of Mandriva can be found at doc.mandriva.com.   Documentation for the latest release may take some time to appear there. You can install all the manuals from the main repository if you have Mandriva installed - files are prefixed mandriva-doc.
    • paul

      Forum software upgrade   10/29/17

      So you may have noticed the forum software has upgraded !!!
      A few things that have changed. We no longer have community blogs (was never really used) We no longer have a portal page.
      We can discuss this, and decide whether it is needed (It costs money) See this thread: Here
Sign in to follow this  
Peter Snow

Printing (CUPS): Won´t print PDF? [solved]

Recommended Posts

Hi Chaps,

 

I´m pretty new to Linux, so please go easy with me!

 

I thought I had succeeded in setting up this linux machine to print to a remote print que on WinXP. I succeeded in printing a test page from Printer Drake (although to be truthful, a blank page came out each try) and I can successfully print from Open Office... so I naturally thought, ´Job Done!´, it seems I´ve been too hasty...

 

When I attempted to print from KPDF, I get an error message which says:

A print error occurred. Error message received from system:

 

Unable to start child print process. Check the command syntax: cupsdoprint -P 'SAMSUNML1610' -J 'statement.pdf' -H '/var/run/cups/cups.sock:631' -o ' copies=1 cpi=12 lpi=7 number-up-layout=lrtb orientation-requested=3 page-bottom=36 page-left=36 page-right=36 page-top=36 scaling=100'

 

I visited localhost:631 through my browser and can see that CUPS is running and it can see the printer. I successfully printed a fine looking test page from there.

 

Details:

OS: Mandriva ONE 2008 / all updates applied

CUPS: 1.3.0

Printer: Samsung ML1610

Driver: Samsung ML-1610 Foomatic/gdi

Users: All users allowed

 

 

Any suggestions would be greatly appreciated!

 

Thanks, peter

Edited by Peter Snow

Share this post


Link to post
Share on other sites

Welcome Peter. I have a Samsung ML-1510 and depending on the content of a 'pdf sometimes I have to print to a postscript file and then print that to the printer. It seems like PDF's are not handled correctly or there is oddities in the file itself. I know it's printing twice but give that a try.

Good Luck.

Share this post


Link to post
Share on other sites

Thanks for your suggestion. I've just tried printing to postscript file (although I have no idea what one of those is or what their purpose is!). I saved it to the desktop and then double clicked it to open it. It opened in my pdf reader and looked just like the pdf did. Is that right?

 

Anyway, I then tried to print it normally and it still failed. Is what I did, what you intended me to do?

 

If so, then unfortunately, it didn't work. Any other ideas?

 

Regards, peter

Share this post


Link to post
Share on other sites

Your actions were as intended, the output to postscript does the conversions before sending to the printer which usually sorts out any abnormalities. Seeing as that didn't work you could try a print preview in kpdf and see if it looks right. Other than that I'm out of ideas, sorry.

Share this post


Link to post
Share on other sites

Hey, I'm sorry to take so long to reply. I only just saw your post, which reminded me that I should update this thread!

 

I did check the preview and all looks fine, in addition, the same document prints fine in windows.

 

It turns out that it must have been the CUPS driver thingy! The day after my last post, there was an update offered on the auto update feature which was for CUPS (actually, I think there were quite a few for CUPS that day), saying something about fixing a security vulnerability. Well, I religiously installed them all, but coming from a windows environment, I didn't honestly expect them to fix anything, but, praise God, it's all fixed now!

 

Thanks for your suggestions. Perhaps the update for CUPS will solve your issue too SilverSurfer?

 

Kind regards

 

Peter Snow

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×