Jump to content

MDV 2008 - Keeping wireless connection


Recommended Posts



the gist of the post is this: i still haven't figured out how to keep my wireless connection. doing the setup works somewhat but it is not permanent and the workaround is not reliable. I don't want to keep on doing it everytime and tear what is left of my hair. The loss of the keyboard input is killing me.


for the long story i am not going to hash the entries in my blog so i will just post the links:


* Day one, with matching giddy feeling

* Day two, shock starts to settle in.

* Day three, straws are piling up on the camel's back.


i have started with mandrake since around 2002 so this operating system has a special place in my heart. aside from some short flings with Arch Linux, I haven't really gotten around to using any other distro. I hope somebody can suggest a way to fix my current troubles,





[moved from Installing Mandriva by spinynorman]

Link to comment
Share on other sites

yeah since it was the default and the X server seems fine. is that the cause of the missing keyboard input whenever i shut down the wired connection? ill try switching to the default driver by tomorrow as i am finishing some document that relies too much on excel macros. :(


any suggestion on the wireless problem? i know it can connect but the problem is how to do it consistently. thanks.



Link to comment
Share on other sites

i already tried both and ill take anything that works. in 2007 i was using prism54 but in 2007.1 i needed to use ndiswrapper. as it looks in 2008 ndiswrapper might be my only choice since using the prism54 configuration does not enable me to list the available wireless routers.





Link to comment
Share on other sites

okay, so do this:


edit /etc/modprobe.conf and remove any line that looks like this:


alias (something) prism54


add a line that looks like this:


blacklist prism54


and make sure there's a line that looks like this:


alias (something) ndiswrapper


then use 'ndiswrapper -l' as root to see how many drivers are installed in ndiswrapper. Remove any beyond the one you're actually using with 'ndiswrapper -r (name)'.

Link to comment
Share on other sites

hi adam,


did what you told me and now my modprobe.conf looks like this:

blacklist prism54 

alias eth0 b44
alias sound-slot-0 snd_atiixp
options snd-ac97-codec power_save=1
install scsi_hostadapter /sbin/modprobe usb_storage; /bin/true
install usb-interface /sbin/modprobe ohci_hcd; /sbin/modprobe ehci_hcd; /bin/true

#alias eth1 prism54
install ide-controller /sbin/modprobe atiixp; /bin/true
alias wlan0 ndiswrapper


and these are the listed items from ndiswrapper -l

[root@Lala ~]# ndiswrapper -l
Unknown line at line 2389
prisma00 : driver installed
	device (1260:3886) present (alternate driver: prism54)


i don't know what file to look at for line 2389 since the ndiswrapper perl script is only up to 1023 lines and i don't know any perl to start reading it. :(


rebooting the machine froze after ALSA was shutdown so I don't know which ones of these are the culprit (from /etc/init.d/rc3.d) but my bets are either on contestant number 18 or 24.

  • S18sound
  • S24messagebus
  • S25haldaemon
  • S26apmd

the startup sequence has shown that the missing wlan0 device message has been replaced with this one (copied from a piece of paper)

Error for wireless request "Set encode" (8B2A)
Set failed on device wlan0; Invalid Argument


in the desktop i still dont have a wireless connection but clicking on the "Wireless Networks->(Name of our router)" enabled my laptop to get an IP Address but no internet access. The reason I found out is because it connected to one of the non-encrypted routers in the area. Clicking on the "Manage wireless networks" launched drakroam and after a few retries i was able to connect to our router.


this problem seems to be half-solved but for the issues below:

  1. why is my shutdown freezing after the ALSA server has been shutdown? this might be related on the Radeon driver mentioned by ix so ill try changing to the default one to try isolating the problem.
  2. what did the boot-up wlan0 message mean and how can i solve it? - currently looking at google for some answers.
  3. how do i tell drakroam or whatever the sequence on the wireless networks to connect. i am looking for something like in windows wherein there is a primary or preferred router and then a ranked list of routers to try.


Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...